Page Index Toggle Pages: [1] 2 3 ... 6
Topic Tools
Very Hot Topic (More than 25 Replies) You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl (Read 13,313 times)
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Oct 10th, 2012 at 1:37am
Post Tools
I'm at my wit's end with this. I have v2.4, and all of a sudden, with literally no change to anything since the last time I've used it, I'm getting the error in the topic whenever I try to make a change to the forum itself. It's popping up now when I go into Forum Layout > Template Configuration. If I tried to adjust anything, I get that error.

So I've looked for help topics on the subject, and I've found discussions relating to file permissions. All of my file permissions are correct, I have CHMOD ability thru my server/FTP. All of that is good.

I tried upgrading to v2.5. Still does it! 

What am I missing? What info can I give you to help further?
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #1 - Oct 10th, 2012 at 12:16pm
Post Tools
spentastico2 wrote on Oct 10th, 2012 at 1:37am:
I'm at my wit's end with this. I have v2.4, and all of a sudden, with literally no change to anything since the last time I've used it, I'm getting the error in the topic whenever I try to make a change to the forum itself. It's popping up now when I go into Forum Layout > Template Configuration. If I tried to adjust anything, I get that error.

So I've looked for help topics on the subject, and I've found discussions relating to file permissions. All of my file permissions are correct, I have CHMOD ability thru my server/FTP. All of that is good.

I tried upgrading to v2.5. Still does it!  

What am I missing? What info can I give you to help further?


ok what are the CHMOD you have used on AdminIndex.pl
the CHMOD default for this is 755

also I take it that YaBB.pl is loading fine and it is just AdminIndex.pl that is the problem

also can you take a look at .htaccess in the root of your website and also the .htaccess in /yabb2/

also can you open up AdminIndex.pl and look for #!/usr/bin/perl -- on line one
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,373
Location: Earth

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #2 - Oct 10th, 2012 at 4:06pm
Post Tools
Also check the permissions on the yabb/Templates/ folder and all the folders inside it (The folders should be 755 and the files 644 but you may need to change the files to 666.) Same with the yabbfiles/Templates - make sure the folders and file permissions are correct.)

Also check and see if there are any errors in your server error log, not the YaBB error log.

@xnoddyx - it sounds like he's able to access the Admin Center, but not able to save things from it. My suspicion is write privileges to the various folders.

And since this apparently happened suddenly without any changes on his part, I also suspect the change came from the hosting service messing around.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #3 - Oct 10th, 2012 at 5:13pm
Post Tools
Thanks for your replies!

Yep, AdminIndex.pl is set to 755, and YaBB.pl is fine. Everything else works. It's like Dandello described: I can't save stuff in the admin panel.

What in .htpaccess should I look for? I'll report back shortly on the #1/usr line shortly.

Now I did notice that everything is set to 755, even the image & non-essential files. Would that cause an access error?
  
Back to top
 
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #4 - Oct 10th, 2012 at 5:16pm
Post Tools
Checked AdminIndex.pl. #!/usr/bin/perl -- is the first line.
  
Back to top
 
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #5 - Oct 10th, 2012 at 5:22pm
Post Tools
Checked .htaccess in both places. No matching IP address bans, so I'm good there, I believe.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #6 - Oct 10th, 2012 at 5:39pm
Post Tools
ok cool and thank you for checking so after this i also now think the same as Dandello so if you can try
Dandello wrote on Oct 10th, 2012 at 4:06pm:
Also check the permissions on the yabb/Templates/ folder and all the folders inside it (The folders should be 755 and the files 644 but you may need to change the files to 666.) Same with the yabbfiles/Templates - make sure the folders and file permissions are correct.)

  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #7 - Oct 10th, 2012 at 5:54pm
Post Tools
Okay, I tried it both ways. First I changed all the files within the folders to 644, didn't fix it. Then I switched them all to 666, no dice either. Folders are still 755.  Undecided
  
Back to top
 
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #8 - Oct 10th, 2012 at 6:00pm
Post Tools
I just checked the server log, and when I tried to make a change to the template after I made the permission changes, I got these errors. Might they offer a clue?

[Wed Oct 10 18:55:03 2012] [error] [client 216.111.246.218] File does not exist: /home/midohi/public_html/403.shtml, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modcss
[Wed Oct 10 18:51:33 2012] [error] [client 216.111.246.218] File does not exist: /home/midohi/public_html/404.shtml, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modskin
[Wed Oct 10 18:51:33 2012] [error] [client 216.111.246.218] script not found or unable to stat: /home/midohi/public_html/cgi-bin/yabb2/{yabb html_root}, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modskin
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #9 - Oct 10th, 2012 at 6:17pm
Post Tools
spentastico2 wrote on Oct 10th, 2012 at 6:00pm:
[Wed Oct 10 18:55:03 2012] [error] [client 216.111.246.218] File does not exist: /home/midohi/public_html/403.shtml, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modcss[Wed Oct 10 18:51:33 2012] [error] [client 216.111.246.218] File does not exist: /home/midohi/public_html/404.shtml, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modskin[Wed Oct 10 18:51:33 2012] [error] [client 216.111.246.218] script not found or unable to stat: /home/midohi/public_html/cgi-bin/yabb2/{yabb html_root}, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modskin


ok this looks like it is a paths prob in the admin center can you check
Path Settings for HTML Dir:
from your error log i can see it will look something like
/home/midohi/public_html/yabbfiles/
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #10 - Oct 10th, 2012 at 6:27pm
Post Tools
Yeah, HTML Dir: = /home/midohi/public_html/yabbfiles

I think that just means I don't have a 403 (or 404).shtml file, which I don't. I only have a 500.shtml in there.
  
Back to top
 
IP Logged
 
The Boy
Full Member
***
Offline



Posts: 339
Location: UK
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #11 - Oct 10th, 2012 at 6:43pm
Post Tools
Do you just have the 1 template?  Having a feeling there is a missing Template file....
  
Back to top
WWW  
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #12 - Oct 10th, 2012 at 6:50pm
Post Tools
I have 2: the default and the Old Style 2.1. 

I get this error even when I try to make a new color scheme and save it under a new file name.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #13 - Oct 10th, 2012 at 6:56pm
Post Tools
spentastico2 wrote on Oct 10th, 2012 at 6:27pm:
Yeah, HTML Dir: = /home/midohi/public_html/yabbfiles

I think that just means I don't have a 403 (or 404).shtml file, which I don't. I only have a 500.shtml in there.


ok now as the HTML Dir: was set ok
can you also check Templates Dir: this will be
/home/midohi/cgi-bin/yabb2/Templates
or
/home/midohi/public_html/cgi-bin/yabb2/Templates

ok now for the permission test  /yabbfiles/Templates/Forum/default.css is set to CHMOD of 644
also test
/home/midohi/cgi-bin/yabb2/Templates is set to CHMOD of 755
or
/home/midohi/public_html/cgi-bin/yabb2/Templates is set to CHMOD of 755

/home/midohi/cgi-bin/yabb2/Templates/default is set to CHMOD of 755
or
/home/midohi/public_html/cgi-bin/yabb2/Templates/default is set to CHMOD of 755

also all files in
/home/midohi/cgi-bin/yabb2/Templates/default
or
/home/midohi/public_html/cgi-bin/yabb2/Templates/default
is set to CHMOD of 644
if the CHMOD dont work try 777 for the dirs and 666 for the files in /home/midohi/public_html/cgi-bin/yabb2/Templates
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,373
Location: Earth

YaBB 2.6.1
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #14 - Oct 10th, 2012 at 7:03pm
Post Tools
Code
Select All
[Wed Oct 10 18:51:33 2012] [error] [client 216.111.246.218] script not found or unable to stat: /home/midohi/public_html/cgi-bin/yabb2/{yabb html_root}, referer: http://www.midohiospeakeasy.com/cgi-bin/yabb2/AdminIndex.pl?action=modskin 



The highlighted section is where the problem is originating - there's an issue with YaBB resolving the actual location of the file it needs. (We shouldn't be seeing
Code
Select All
{yabb html_root} 

at all ever in that line. ) So check your paths first as something is keeping Admin/ManageTemplates.pl (and probably other things as well) from putting the proper path where it belongs.
« Last Edit: Oct 10th, 2012 at 7:04pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: [1] 2 3 ... 6
Topic Tools
 
  « Board Index ‹ Board  ^Top