Page Index Toggle Pages: 1 2 [3] 4 5 6
Topic Tools
Very Hot Topic (More than 25 Replies) You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl (Read 12,653 times)
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #56 - Oct 17th, 2012 at 8:50pm
Post Tools
OK

I think I have it figured out. "think" is a qualifying term.

I think it's directly related to Alejandro's problem as I suspected.  In his case, it was a missing '+' on ExecCGI.  It was about .htaccess/Apache directives syntax.

Edited:
Please enquire from the host what the Directory directives are for the ScriptAlias folder and the DocumentRoot of this vhost.  It may be a wildcard configuration.  

I have dug up the notes for Alejandro's fix - we located the error using the Apache error log.  There was a conflict in rule application.

[Wed Aug  8 02:20:30 2012][error] [client 66.249.67.134]Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /home/ey000099/public_html/cgi-bin/yabb2/YaBB.pl

Says that directive was not enforced, possibly by the lack of an AllowOverride All in a Directory directive.


That does NOT mean we have the exact same issue here, but I think its a similar problem.  

I tested a vriety of .htaccess oriented fixes.
We had the same '500' errors with Alejandro if you tried to 'fix' the .htaccess, just like xnoddyx had with this one.

Just my best guess at the moment, and -- if I am correct -- I have not grokked what the fix is.  The 'Directory' Apache directives may tell us what's up.  Much of the same syntax you use in .htaccess can be globally applied via Apache's httpd.conf files.

Roll Eyes

« Last Edit: Oct 17th, 2012 at 11:49pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #55 - Oct 17th, 2012 at 3:17pm
Post Tools
I'm in it for the long haul, thank YOU guys for all the help!
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #54 - Oct 17th, 2012 at 3:11pm
Post Tools
Thank you for your patience in this matter there will prob be some more questions to come and items to ask your host please bear with us  Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #53 - Oct 17th, 2012 at 12:29pm
Post Tools
Yeah, that's fine with me to pass that log in info along.

The Apache version is 2.2.23, and I'm just on the standard Z-500 package from www.z-host.com.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #52 - Oct 17th, 2012 at 12:24pm
Post Tools
Hi spentastico2

i have some more quick questions for you

1. can you find out the Apache version of your server
2. what web hosting package are you on or is it a an in-house or a custom VPS setup
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #51 - Oct 17th, 2012 at 1:05am
Post Tools
JonB wrote on Oct 17th, 2012 at 12:36am:
I suspect this is related to the problem Alejandro had -

http://www.yabbforum.com/community/YaBB.pl?num=1344227739/20#20

just a thought

Cool

ok the .htaccess in the html root
Code
Select All
RewriteEngine on
RewriteCond %{HTTP_HOST} ^midohiospeakeasy\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.midohiospeakeasy\.com$
RewriteRule ^/?$ "http\:\/\/www\.midohiospeakeasy\.com\/wp" [R=301,L]
 



i had a look and can't see any .htaccess in yabbfiles also no .htaccess in yabb2/ but most subdirectories of yabb2/ have .htaccess with
Code
Select All
AuthUserFile /dev/null
AuthGroupFile /dev/null
AuthName DenyViaWeb
AuthType Basic


<Limit GET>
order allow,deny
deny from all
</Limit>
 


this of any help?
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,785
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #50 - Oct 17th, 2012 at 12:36am
Post Tools
I suspect this is related to the problem Alejandro had -

http://www.yabbforum.com/community/YaBB.pl?num=1344227739/20#20

just a thought

Cool
« Last Edit: Oct 17th, 2012 at 12:40am by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #49 - Oct 17th, 2012 at 12:00am
Post Tools
ok the 2.5.2 test was the same so will pass this up the chain for you so Dandello or JonB or Dandello and JonB may have some more questions for you also if you are not on at the time is it ok to pass on the ftp info if it is required i only ask as this will help speed up support for you.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #48 - Oct 16th, 2012 at 8:18pm
Post Tools
spentastico2 wrote on Oct 16th, 2012 at 7:35pm:
Ya, definitely. The user/pass I made for ya is still there.

ok cool i am just about to get something to eat and will do this after that  Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,174
Location: Earth

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #47 - Oct 16th, 2012 at 8:05pm
Post Tools
One thing to have your server people check - the 'ownership' of the yabbfiles/Templates/Forum/ directory, its parents and children. You can't overwrite a file you don't 'own'. (Although you should 'own' it if you can FTP to it.) This issue happened to me a lot on my old hosting service. One directory had the wrong 'ownership' and so YaBB couldn't write to it. And it took a while for the hosting service tech support to realize that was what was going on. (And what was more frustrating was once a week the 'ownership' would reset back to the wrong settings.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #46 - Oct 16th, 2012 at 7:35pm
Post Tools
Ya, definitely. The user/pass I made for ya is still there.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #45 - Oct 16th, 2012 at 7:31pm
Post Tools
spentastico2 wrote on Oct 16th, 2012 at 6:41pm:
Here's what I got from the server folks:

Quote:
Hi,

I can't find any problem with the server. If there was a generic problem, I would expect the script to fail all the time. It is OK until you try to change the CSS, which would appear to indicate a problem with the script, probably an error causing the script to stop running before it outputs the HTTP header.


That seems to be a valid point, because I can still add/change/move boards around and stuff.

why we think it maybe a server misconfiguration is that i copied over your forum system files to my test server and i was able to edit and save the template and also the css as well.
after the test on my test server i installed a new yabb 2.4 on your host to test and this had the same error on saving the template and also the css as well.
if it is ok can i ftp back onto your host if the temp ftp info you sent me is still setup and start a new test and get some more info on this the new test will be me setting up a new yabb 2.4 to verify the same error agen and also test the yabb 2.5.2 Beta and see if this has the the same error as well if i still get the same results i will pass this up to our server expert here at yabb as there will be nothing more i can do for you.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #44 - Oct 16th, 2012 at 7:07pm
Post Tools
Hmmm... I'll ask the host folks about that. They did do a server change a few months ago. Maybe that got changed, too. I'll give that a look-into. Thanks for the tip.
  
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #43 - Oct 16th, 2012 at 6:59pm
Post Tools
xnoddyx wrote on Oct 11th, 2012 at 6:10pm:
[quote]Forbidden
You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


I recently had something very similar with a new host I tried. Final response from their support people "Hi,

I've found the issue with this, it looks like your account had created without CGI privilages which was preventing this from running correctly. I have fixed this though would still advise moving to a PHP/MySQL based forum."


I cancelled account, maybe you should look for another host?
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
spentastico2
YaBB Newcomer
*
Offline



Posts: 41

YaBB 2.6.0
Re: You don't have permission to access /cgi-bin/yabb2/AdminIndex.pl
Reply #42 - Oct 16th, 2012 at 6:41pm
Post Tools
Here's what I got from the server folks:

Quote:
Hi,

I can't find any problem with the server. If there was a generic problem, I would expect the script to fail all the time. It is OK until you try to change the CSS, which would appear to indicate a problem with the script, probably an error causing the script to stop running before it outputs the HTTP header.


That seems to be a valid point, because I can still add/change/move boards around and stuff.
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 2 [3] 4 5 6
Topic Tools
 
  « Board Index ‹ Board  ^Top