Page Index Toggle Pages: 1 [2] 3 
Topic Tools
Very Hot Topic (More than 25 Replies) 2.2.2 to 2.5 (Read 6,047 times)
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: 2.2.2 to 2.5
Reply #20 - Nov 5th, 2012 at 4:27am
Post Tools
Bunta wrote on Nov 5th, 2012 at 2:51am:
OK avatars don't work at all. Any suggestions?


Bunta wrote on Nov 5th, 2012 at 4:18am:
I reckon I have a Paths.pl issue. Is there any way of generating a new Paths.pl file?

you can edit them from the admin center

there are two avatar paths
one will look like
Avatar Dir: C:/xampp/www/yabbtest.test/site/new/avatars
and two will look like this
Avatar URL: http://yabbtest.test/new_fc/avatars
you will find Path Settings in the admin center.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,130
Location: Earth

YaBB 2.6.0
Re: 2.2.2 to 2.5
Reply #19 - Nov 5th, 2012 at 4:26am
Post Tools
Xnoddyx is our go to guy for that sort of thing - give him your particulars via PM and I'm sure he'll take a look and get you squared away.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #18 - Nov 5th, 2012 at 4:18am
Post Tools
Dandello wrote on Nov 5th, 2012 at 3:54am:
All the folders need to be 755. It's the items in the folders that are 644 - except for YaBB.pl and AdminIndex.pl. Spellchecker.pl and ModuleChecker.pl may or may not need to be 755, depending on the system.

OK, well the guide has an error then. I reckon I have a Paths.pl issue. Is there any way of generating a new Paths.pl file?
« Last Edit: Nov 5th, 2012 at 4:18am by Bunta »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,130
Location: Earth

YaBB 2.6.0
Re: 2.2.2 to 2.5
Reply #17 - Nov 5th, 2012 at 3:54am
Post Tools
All the folders need to be 755. It's the items in the folders that are 644 - except for YaBB.pl and AdminIndex.pl. Spellchecker.pl and ModuleChecker.pl may or may not need to be 755, depending on the system.
« Last Edit: Nov 5th, 2012 at 3:57am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #16 - Nov 5th, 2012 at 2:51am
Post Tools
The quick guide lists the CHMOD for  public_html/yabbfiles/avatars/UserAvatars folder as 644. Is that correct? I had to change it to 755 to be able to replace the HTML file.

OK avatars don't work at all. Any suggestions?

update: images don't work (except for smilies and stars) menu buttons don't appear either. Images don't work in posts or signatures.
« Last Edit: Nov 5th, 2012 at 3:23am by Bunta »  
Back to top
 
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #15 - Nov 5th, 2012 at 2:35am
Post Tools
The only issue I have now is avatars don't work. I checked and noticed that UserAvatars is empty. I was sure it had an html file in there. So I reloaded the html from the 2.52 package and it wouldn't upload, something wrong with the file. My old forum did not have a UserAvatars folder at all. I'm going to download the 2.5.2 package again just in case that file is corrupt. Will post here when I resolve this or get stuck trying Cheesy
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,130
Location: Earth

YaBB 2.6.0
Re: 2.2.2 to 2.5
Reply #14 - Nov 4th, 2012 at 4:57pm
Post Tools
Glad things are okay now.  Smiley

What we've discovered (and should make this a really big instruction in the Quick-Guide), errors creep into the data - not enough to make things crash when run through the program that created them (ie. older version of YaBB) but enough to choke FixFile. So running all the maintenance utilities first takes care of the little niggles.
« Last Edit: Nov 4th, 2012 at 4:58pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #13 - Nov 4th, 2012 at 4:33pm
Post Tools
SOLVED. I went back and ran maintenance again on old files and reloaded boards, members, messages. Thanks for the tip. Smiley
  
Back to top
 
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #12 - Nov 4th, 2012 at 4:11pm
Post Tools
The new forum seems to work fine. What wouldn't work properly if the file structure hadn't been updated?
  
Back to top
 
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #11 - Nov 4th, 2012 at 3:48pm
Post Tools
Yep the CHMOD is right for that file. Maybe I've run this file on an earlier upgrade, would that cause the error?

2.5.2
« Last Edit: Nov 4th, 2012 at 3:53pm by Bunta »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,130
Location: Earth

YaBB 2.6.0
Re: 2.2.2 to 2.5
Reply #10 - Nov 4th, 2012 at 3:29pm
Post Tools
In 2.5AE or 2.5.2?

When I've gotten that screen, it usually means bad data has gotten through or something has gotten corrupted. Is the chmod for Fixfile.pl set to 755?

Did you go through all your file maintenance on your old forum before copying the files into the new one?
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #9 - Nov 4th, 2012 at 2:34pm
Post Tools
Everything went fine up 'til the Fixfile.pl step. I ran it, then I clicked on the 'update file structure' button and got this:

Content Encoding Error
      
The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,130
Location: Earth

YaBB 2.6.0
Re: 2.2.2 to 2.5
Reply #8 - Oct 22nd, 2012 at 3:49pm
Post Tools
2.5.2 is now out and you don't have to go through 2.3.1 for your initial conversions. There are built-in anti-spam features, too. Let us know how it goes.  Smiley
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bunta
Full Member
***
Offline



Posts: 102
Re: 2.2.2 to 2.5
Reply #7 - Oct 22nd, 2012 at 11:01am
Post Tools
Dandello wrote on Oct 19th, 2012 at 2:03pm:
You'll need to backup your forum to a safe place and install the new software. Transfer your messages, members, boards, User Avatars, and attachments into their proper places according to the newest Quick-Guide. Depending on the age of the forum, you may need to run either the File Convert or FixFile for the final step in the upgrade installation.

There are substantial changes between 1x,2x and 2.5x so simply 'upgrading' by replacing files is not a good option and so has not been offered. At some point in the future we hope to have a feature where the software really is close to a one-click install/upgrade.

Thanks mate, that's the info I wanted to know about. Every YaBB upgrade I've done has been that way. I was hoping I could do it automatically this time. I'll save the upgrade for the next rainy night. Smiley
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,130
Location: Earth

YaBB 2.6.0
Re: 2.2.2 to 2.5
Reply #6 - Oct 19th, 2012 at 2:03pm
Post Tools
You'll need to backup your forum to a safe place and install the new software. Transfer your messages, members, boards, User Avatars, and attachments into their proper places according to the newest Quick-Guide. Depending on the age of the forum, you may need to run either the File Convert or FixFile for the final step in the upgrade installation.

There are substantial changes between 1x,2x and 2.5x so simply 'upgrading' by replacing files is not a good option and so has not been offered. At some point in the future we hope to have a feature where the software really is close to a one-click install/upgrade.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 
Topic Tools
 
  « Board Index ‹ Board  ^Top