Page Index Toggle Pages: 1 [2] 3 
Topic Tools
Very Hot Topic (More than 25 Replies) Load time (Read 10,687 times)
malmklang2
Jr. Developer
Language Team
***
Offline



Posts: 257
Location: Norway

None
Re: Load time
Reply #15 - Nov 10th, 2012 at 10:40am
Post Tools
The front page takes forever to load for me, but all other pages load quickly...... Weird!!
  

if ($human) {die("Sorry, you lot have destroyed too much already")}
Back to top
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Load time
Reply #16 - Nov 10th, 2012 at 1:17pm
Post Tools
I use the time to make a cuppa  Grin
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Load time
Reply #17 - Nov 10th, 2012 at 5:09pm
Post Tools
malmklang2 wrote on Nov 10th, 2012 at 10:40am:
The front page takes forever to load for me, but all other pages load quickly...... Weird!!

lol more than Weird i am still getting slow loading on most pages but if i logout there is almost no load time at all  Huh lol

depablo wrote on Nov 10th, 2012 at 1:17pm:
I use the time to make a cuppa  Grin

cool where my cuppa  Grin
« Last Edit: Nov 10th, 2012 at 5:09pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Load time
Reply #18 - Nov 11th, 2012 at 2:47am
Post Tools
I have an idea (if the problem is the Index Page of the Forum), but I will need to test things, and confirm what I suspect.

If you are talking about the Front Page of YaBBforum.com (the site Index page) I can only say - you have to ask?

BTW. I just 100% cleared/flushed a copy of IE8.

I typed in "http://www.yabbforum.com/community/YaBB.pl" by hand, and used a stop watch - <Enter> 2 seconds later the Front Page of the forum was built.

Just tested an overloaded Win 7 machine with Google 4 seconds-

That one I had a cookie in - I suspect Guests do get a faster load, as they fail all the tests - thus there is much less work for YaBB to do.

If you both are in Scotland it could be a BGP or routing issue, have you run traceroute?

Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Load time
Reply #19 - Nov 11th, 2012 at 1:46pm
Post Tools
i didn't bother with a traceroute as it is only here that is slow to load
but made one just for you tracert yabbforum.com >c:/tr/yabbtr.txt
and it only happens when i am login so not so much of a prob as it is not so bad just now but something to keep my eye on but here is a copy of my traceroute  Wink
  

yabbtr.txt ( 1 KB | 102 Downloads )

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
westwegoman
Ex Member
**




YaBB 2.5.2
Re: Load time
Reply #20 - Nov 13th, 2012 at 3:55am
Post Tools
Wow. seems like it just took forever to load Sad
  
Back to top
 
IP Logged
 
malmklang2
Jr. Developer
Language Team
***
Offline



Posts: 257
Location: Norway

None
Re: Load time
Reply #21 - Nov 13th, 2012 at 8:28am
Post Tools
Yah, the forum index is a time-to-make-coffee project to load, like depablo suggested Tongue
  

if ($human) {die("Sorry, you lot have destroyed too much already")}
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Load time
Reply #22 - Nov 13th, 2012 at 9:17am
Post Tools
ok this is only a suggestion but can we run the forum in
Debug Mode everyone sees out put for a maximum of 30 min
at a set time so we can all copy and post the output back here.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
malmklang2
Jr. Developer
Language Team
***
Offline



Posts: 257
Location: Norway

None
Re: Load time
Reply #23 - Nov 13th, 2012 at 9:44am
Post Tools
I vote not to (as if I have a say!!). I say, we send in Dolph and Stallone with some nukes and big guns, threaten the bits and bytes to get a move on or face doom!!!!
  

if ($human) {die("Sorry, you lot have destroyed too much already")}
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Load time
Reply #24 - Nov 13th, 2012 at 3:26pm
Post Tools
Before we get off on any wild goose chases, I need documented facts.

Id Est:

How long, with a cleared cache, logged out (no cookie) YaBBforum.com does it take to load the 'Front Page'?  IN seconds. measured, not guessed.

Then repeat experiment with cache cleared, but a cookie set before entering.

Finally - enter the forum with the cache intact and and a cookie set.

Please test on IE8/9, Google, and Latest FF (what would that be 267.18?)

Also please give your rough bandwidth speed down/up.

I appear to not be suffering the slings and arrows of outrageous fortune (or perhaps I am more patient).

Thanks
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Load time
Reply #25 - Nov 13th, 2012 at 8:05pm
Post Tools
ok i will get the ifo for you  Smiley but will probably be tomorrow.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Load time
Reply #26 - Nov 13th, 2012 at 8:55pm
Post Tools
Thank you -

Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Load time
Reply #27 - Nov 14th, 2012 at 10:47am
Post Tools
ok just whent to do this and my load time has been ok see pic but luckily i made one last night as well  Wink in the pic this has been 20s+ you can see this in Load_Data_yabbforum.com_wc_OLD.xml the one for the pic is Load_Data_yabbforum.com_wc.xml find them in the zip but will start this if the long load time starts agen that i hope won't Smiley .
  

load_data.zip ( 513 KB | 69 Downloads )
screentime.jpg ( 717 KB | 79 Downloads )
screentime.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,039
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Load time
Reply #28 - Nov 14th, 2012 at 8:36pm
Post Tools
OK -

Here's the deal - personally, I have rarely had the issue you describe. 

I have listened carefully and thought about this.  I also did my own (albeit limited) testing. It looks like the average load time for a Staff user (lots to build for YaBB) runs around 3-5 seconds (acceptable) and the Guest load runs 2-4 seconds (very acceptable).  The fact it loads OK for me almost always says - not a bug.  Everyone gets the same code, so it has to be one of a limited number of things.

A. General Traffic load related - those in the UK may be on primarily when the server farm is most loaded.

B. Specific node related - even though we have a VPS, it is sitting in a containerized physical server co-residing with other VPS's - we might be sitting on the same node as a UK based e-commerce site for instance.

C. Traffic shaping/routing related.  If all our problem loads are geographically close - could be a routing/BGP/Circuit issue.  Unless you do a circuit/peering analysis, there no way to understand likely causes in this area.

D. Server Backup related. According to our host, the whole server is being 'tarred' up daily. IF its a 'plain tar' (uncompressed) that's a four hour job, if that was poorly timed - it could be the cause.

Speaking as a systems engineer, I'm betting on 'its time related' in some fashion.

If you have a 'slooooow load', please go to this Topic and note 'roughly how long' to load and the both UTC time it happened & what your local time was.  I think we will find a pattern

If you have a good load, also please note the UTC time.

SOOOOOOO - as we know there is nothing wrong with the code, and this is mostly a 'lets see' issue I am going to move it to ServerSide. (where the truly geeky go)

Thanks to everyone -
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Load time
Reply #29 - Nov 14th, 2012 at 11:41pm
Post Tools
just now i am back to 3-5 not the 20+ i was getting for the past week or so but if it happens agen i will get all the info i can and post it here.

JonB wrote on Nov 14th, 2012 at 8:36pm:
If you have a 'slooooow load', please go to this Topic and note 'roughly how long' to load and the both UTC time it happened & what your local time was.  I think we will find a pattern If you have a good load, also please note the UTC time.

my local time and UTC are the same as my time zone is (UTC/GMT) Wink


  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 
Topic Tools