Page Index Toggle Pages: 1 [2] 3 
Topic Tools
Very Hot Topic (More than 25 Replies) Need help with sendmail (Read 6,267 times)
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Need help with sendmail
Reply #26 - Nov 13th, 2012 at 7:46am
Post Tools
Miracles we can do at once, the impossible takes a little longer.

Some hosts try hard but their systems are just not up to it, keep trying with xnoddys help  Cool
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #25 - Nov 13th, 2012 at 12:08am
Post Tools
Is this SMTP email feature all dependent on Gmail, or does it also need to use certain resources and go through my hosting service?

The reason being is their server may be having problems with this too.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Need help with sendmail
Reply #24 - Nov 12th, 2012 at 10:35pm
Post Tools
Hi Miss Emily

i can confirm the info i have giving you is corrected doing the test from my YaBB 2.5 AE!.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Need help with sendmail
Reply #23 - Nov 12th, 2012 at 10:19pm
Post Tools
i can't see that causing you any problems i will go run a test with Net::SMTP (Perl Module) on my host to double check the info  but what i have given you should work for it.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #22 - Nov 12th, 2012 at 10:03pm
Post Tools
I don't know if this is the reason for it not to work, but my YaBB executable files end in ".cgi".
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Need help with sendmail
Reply #21 - Nov 12th, 2012 at 9:39pm
Post Tools
Miss Emily wrote on Nov 12th, 2012 at 9:02pm:
but where is "Use Authentication: Yes",

it is here
xnoddyx wrote on Nov 12th, 2012 at 8:21pm:
Select SMTP Server Authorization Type: AUTO or try LOGIN or PLAIN if AUTO dont work


Miss Emily wrote on Nov 12th, 2012 at 9:02pm:
"Port for TLS/STARTTLS: 587" etc?

this is for Net::SMTP::TLS (Perl Module) but if you keep to Net::SMTP (Perl Module) and try this as smtp.gmail.com:465 was giving you Socket is already connected try smtp.gmail.com as it seems to be set to Socket 465  Huh but the default Socket is 25 but your host seems to have set the default to 465

hope this gets you working  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #20 - Nov 12th, 2012 at 9:02pm
Post Tools
I know where the email section is, but where is "Use Authentication: Yes", "Port for TLS/STARTTLS: 587" etc?



smtp.gmail.com:465 gives the follow error message after registration:
Net::SMTP fatal error : Unable to create Net::SMTP object. Server: 'smtp.gmail.com:465' Socket is already connected at (eval 1) line 4.

Then I tried smtp.gmail.com:587 and smtp.gmail.com, but still no email messages going through after registration.

My Gmail POP Download is set to the following:
1. Status: POP is enabled for all mail that has arrived since 12:00pm
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Need help with sendmail
Reply #19 - Nov 12th, 2012 at 8:21pm
Post Tools
Miss Emily wrote on Nov 12th, 2012 at 7:57pm:
Can you please tell me what area in the Admin center because I couldn't find the fields to enter the data below? I am using YaBB 2.5

-----------------------------------------------------------------
1. Outgoing Mail (SMTP) Server - requires TLS or SSL:
smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

2. smtp login:
Account Name or User Name: your full email address (including @gmail.com or @your_domain.com)

3.Password:
your Gmail password
----------------------------------------------------------------


NOTE: this will only work if on your Gmail account you have Enable pop/smtp see in Gmail:

ok in YaBB goto the admin center then to
"YaBB Advanced"
then goto "Email"

then set all settings here as


Send emails using: Net::SMTP (Perl Module) or Net::SMTP::TLS (Perl Module)

SMTP-Server: smtp.gmail.com if this dont work try smtp.gmail.com:465 or smtp.gmail.com:587

Select SMTP Server Authorization Type: AUTO or try LOGIN or PLAIN if AUTO dont work

SMTP Authorization Username: your full email address (including @gmail.com)
SMTP Authorization Password: your Gmail password

« Last Edit: Nov 12th, 2012 at 8:23pm by xnoddyx »  

smtp.jpg ( 527 KB | 59 Downloads )
smtp.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #18 - Nov 12th, 2012 at 7:57pm
Post Tools
Can you please tell me what area in the Admin center because I couldn't find the fields to enter the data below? I am using YaBB 2.5

-----------------------------------------------------------------
1. Outgoing Mail (SMTP) Server - requires TLS or SSL:
smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

2. smtp login:
Account Name or User Name: your full email address (including @gmail.com or @your_domain.com)

3.Password:
your Gmail password
----------------------------------------------------------------
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Need help with sendmail
Reply #17 - Nov 12th, 2012 at 1:01pm
Post Tools
Miss Emily wrote on Nov 12th, 2012 at 12:22pm:
I'm lost with the steps below. Where are the settings, is this in Gmail or YaBB?

-----------------------------------------------------------------
1. Outgoing Mail (SMTP) Server - requires TLS or SSL:
smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

2. smtp login:
Account Name or User Name: your full email address (including @gmail.com or @your_domain.com)

3.Password:
your Gmail password
----------------------------------------------------------------


sorry i will clear it up abit for you

in Gmail:
--------------------------------------------------------------------
Are you able to log in to the Gmail web interface?
Visit http://mail.google.com to log in to Gmail. If you see a CAPTCHA (a security image with distorted letters), you'll need to log in before you can enable.

next to Enable pop/smtp on Gmail:

Here's how to enable POP in Gmail:
1.Sign in to Gmail.
2.Click the gear icon in the upper right, then select Settings.
3.Click Forwarding and POP/IMAP.
4.Select Enable POP for all mail or Enable POP for mail that arrives from now on.
5.Choose what to do with your messages after your POP client or device receives them.

Although the radio button next to your selected option may not stay selected, Gmail displays the status next to 'POP Status:.' When you enable POP, your settings display 'POP Status: POP is enabled.'

If your POP settings are turned off, the status will indicate that POP is disabled.


settings you will need in yabb:

1. Outgoing Mail (SMTP) Server - requires TLS or SSL:
smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

2. smtp login:
Account Name or User Name: your full email address (including @gmail.com or @your_domain.com)

3.Password:
your Gmail password

you can verify this has worked by using a mail client
i.e. outlook express see http://support.google.com/mail/bin/static.py?hl=en&page=ts.cs&ts=1668960&rd=2 and click on I want to enable POP this will then show a list of mail client.
----------------------------------------------------------------------------



YaBB email settings:
----------------------------------------------------------------------------

ok in YaBB goto the admin center then YaBB Advanced Forum Preferences and Settings > Email:

then set all settings here as

NOTE: this will only work if on your Gmail account you have Enable pop/smtp see in Gmail:



Send emails using: Net::SMTP (Perl Module) or Net::SMTP::TLS (Perl Module)

SMTP-Server: smtp.gmail.com if this dont work try smtp.gmail.com:465 or smtp.gmail.com:587

Select SMTP Server Authorization Type: AUTO or try LOGIN or PLAIN if AUTO dont work

SMTP Authorization Username: your full email address (including @gmail.com)

SMTP Authorization Password: your Gmail password

hope this is ok for you
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #16 - Nov 12th, 2012 at 12:22pm
Post Tools
I'm lost with the steps below. Where are the settings, is this in Gmail or YaBB?

-----------------------------------------------------------------
1. Outgoing Mail (SMTP) Server - requires TLS or SSL:
smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

2. smtp login:
Account Name or User Name: your full email address (including @gmail.com or @your_domain.com)

3.Password:
your Gmail password
----------------------------------------------------------------
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Need help with sendmail
Reply #15 - Nov 12th, 2012 at 11:22am
Post Tools
Miss Emily wrote on Nov 12th, 2012 at 10:34am:
I forgot about the other automated messages that needs to be emailed out. I will give it one last go.--------------------------------------------------------In Gmail, When I "Add another email address you own" to my Gmail account, I get the following options:Send through Gmail Send through my host SMTP servers I assume I select "Send through Gmail" ?--------------------------------------------------------


you will also have to check setting in your gmail as well under "Forwarding and POP/IMAP"

ok to start Gmail Problems sending mail

Are you able to log in to the Gmail web interface?
Visit http://mail.google.com to log in to Gmail. If you see a CAPTCHA (a security image with distorted letters), you'll need to log in before you can enable.

next:

Here's how to enable POP in Gmail:
1.Sign in to Gmail.
2.Click the gear icon in the upper right, then select Settings.
3.Click Forwarding and POP/IMAP.
4.Select Enable POP for all mail or Enable POP for mail that arrives from now on.
5.Choose what to do with your messages after your POP client or device receives them.

Although the radio button next to your selected option may not stay selected, Gmail displays the status next to 'POP Status:.' When you enable POP, your settings display 'POP Status: POP is enabled.'

If your POP settings are turned off, the status will indicate that POP is disabled.

next settings you will need:

1. Outgoing Mail (SMTP) Server - requires TLS or SSL:
smtp.gmail.com
Use Authentication: Yes
Port for TLS/STARTTLS: 587
Port for SSL: 465

2. smtp login:
Account Name or User Name: your full email address (including @gmail.com or @your_domain.com)

3.Password:
your Gmail password

YaBB Advanced Forum Preferences and Settings > Email:

Send emails using: Net::SMTP (Perl Module) or Net::SMTP::TLS (Perl Module)

SMTP-Server: smtp.gmail.com if this dont work try smtp.gmail.com:465 or smtp.gmail.com:587

Select SMTP Server Authorization Type: AUTO or try LOGIN or PLAIN if AUTO dont work

SMTP Authorization Username: your full email address (including @gmail.com)

SMTP Authorization Password: your Gmail password



hope this is of help to you  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #14 - Nov 12th, 2012 at 11:01am
Post Tools
Dandello ... My hosting provider have been fixing the sendmail issue about 30 times already this year.

I'm not sure what the issue is, but they've only been general by saying that they've "made some changes and the issue has been fixed". But within a few days, sendmail stops working again.

The hosting provider is very helpful but you are probably right that it may be something that can't be easily handled.
  
Back to top
 
IP Logged
 
Miss Emily
Junior Member
**
Offline



Posts: 93
Re: Need help with sendmail
Reply #13 - Nov 12th, 2012 at 10:34am
Post Tools
I forgot about the other automated messages that needs to be emailed out. I will give it one last go.

--------------------------------------------------------

In Gmail, When I "Add another email address you own" to my Gmail account, I get the following options:

Send through Gmail
Send through my host SMTP servers

I assume I select "Send through Gmail" ?

--------------------------------------------------------

I will use Net::SMTP (Perl Module) because it worked for you.

Do I leave the "Location of Sendmail Program" field to blank because that won't be used?

For SMTP username, password and email address fields, do I enter the details for my webmaster email address or Gmail email address?      


Thank you.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Need help with sendmail
Reply #12 - Nov 12th, 2012 at 8:33am
Post Tools
Miss Emily wrote on Nov 12th, 2012 at 3:34am:
When I think about it, it's not that bad because I can still approve memberships in the Admin Center even though automated registration emails are not being sent.

That's a good perspective to have about this. However, I'm concerned that your forum's other automated messages such as a member's notifications aren't being sent out. Or a password reset, etc. So somehow, someway, this problem probably needs to be fixed.

Dandello is right about engaging Xnoddyx to help you out directly. He has a knack for figuring things out involving YaBB's inner workings.
Don't you just love how I've volunteered his services?  Smiley

****************************************

Meanwhile, if others can be helped by the following:

In our own forum I tested YaBB SMTP Engine with the following error message:

Code
Select All
System Information
SMTP Error [535]: Authentication failed 


Regarding the error message shown above, I only changed the "Send Emails using" option, so I'm thinking that authentication should have worked.

When I tried the "Net::SMTP (Perl Module)" option, that was successful.

I wasn't able to test the "Net::SMTP::TLS (Perl Module)" option because it's evidently not installed.

In any case, I went back to using our "Unix/Linux Sendmail" option.

****************************************

For anyone having problems with sendmail since YaBB otherwise works fine with it, the best solution is to have one's host make sure it's working.

After all, as Dandello mentioned, "Occasionally a hosting service simply has configuration issues and/or security protocols in place that simply cannot be easily handled."

Years ago, I remember having sendmail problems, so I had to get our host to correct them. At least once if my memory serves me, "a new security protocol" was what caused the problem.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 
Topic Tools
 
  « Board Index ‹ Board  ^Top