Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Page jumps to footer after 20 seconds! (Read 6,335 times)
rooze
YaBB Newcomer
*
Offline



Posts: 16
Page jumps to footer after 20 seconds!
Nov 14th, 2012 at 5:29pm
Post Tools
This has been driving me (and my members) crazy.

When going to a page on my boards, after 20 seconds the page jumps down to the footer! It doesn't matter if you're just reading a post or writing a comment, the blasted thing jumps down to the bottom of the page after 20 secs.

You can see what I mean here - just scroll to the top of the page then wait 20 seconds - http://www.newaudiosociety.com/cgi-bin/yabb2/YaBB.pl?num=1262797778/77#77

This is happening in Firefox and other members have reported it in IE7 and 8.

Any ideas??
  
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Page jumps to footer after 20 seconds!
Reply #1 - Nov 14th, 2012 at 5:46pm
Post Tools
Confirmed in:
IE9
FFox
Chrome

Our resident coders will be along shortly with a solution  Smiley
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #2 - Nov 14th, 2012 at 7:42pm
Post Tools
rooze wrote on Nov 14th, 2012 at 5:29pm:
When going to a page on my boards, after 20 seconds the page jumps down to the footer!

This is actually supposed to happen just as you described it, but hopefully faster than 20 seconds. In other words, your browser will go to whatever address that shows up in the address bar. In your case, the browser will, and should refresh to the actual url that you've used.

So if you were to go to this post in your forum, the browser will stay exactly where it is; not to the footer.

This is good.  Smiley
« Last Edit: Nov 14th, 2012 at 8:16pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #3 - Nov 14th, 2012 at 8:13pm
Post Tools
Hi Bill,

It's not good, trust me Smiley

It jumps to the bottom of the page every 20 seconds, repeatedly, over and over.

So I land on the page and start reading the first post. 20 seconds later it jumps to the bottom of the page when I'm half way through reading the first post...not good.
So then I use the scroll bar and find the point in the first post at which I was so rudely interrupted. I then start reading again and 20 seconds later....bump. I'm back down at the bottom of the page again  Cheesy

Rooze
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #4 - Nov 14th, 2012 at 8:18pm
Post Tools
Rooze, in your case specifically, your forum appears to reload because of the Google ads that you run. So each time that a Google ad is swapped out, it will refresh whatever is showing in your browser's address bar.

Edited:
Bill Myers wrote on Nov 15th, 2012 at 7:37am:
Your forum appears to be operating properly without any unnecessary refreshing. Congratulations!

Not to throw a monkey wrench in the monkeying around that you had to do to get things working again, but according to my notes about Google ads, the rotation of ads shouldn't be refreshing your page. So you might want to put that back in, and see if your forum still operates the way that it should.

Good luck! You have a great looking forum.  Smiley

In our forum, I now only include static ads.

In any case, this is the way browsers operate.
« Last Edit: Nov 15th, 2012 at 7:42am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #5 - Nov 14th, 2012 at 8:34pm
Post Tools
Hi Bill,

I'd removed the ads whilst trying to eliminate the problem and it didn't change anything so I put them back.

I've now removed them again, there are no ads on the forum page.

But the problem persists.

Bill, I'm thinking you must not be seeing what I'm describing as you wouldn't say this is normal if you could see it. Perhaps you're not waiting the full 20 seconds. Depablo sees it - he confirmed the issue and said coders would be along to resolve it in the post above.

Again, it cannot be normal operation. Imagine reading a post then 20 seconds in it disappears...
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #6 - Nov 14th, 2012 at 8:44pm
Post Tools
rooze wrote on Nov 14th, 2012 at 8:34pm:
Bill, I'm thinking you must not be seeing what I'm describing as you wouldn't say this is normal if you could see it.

Yes, I'm getting the same thing. But when I do it, there's only the one refresh going on. After that, everything seems to be fine. Before when you had the Google ads swapping out about every 20 seconds it seems, refreshing of the page kept happening.

The source page of your YaBB.pl file didn't have any refresh commands, so I don't know that could be happening. So it's good that you came here. Somebody will surely come along to figure this out.

Generally speaking, and it applies to the forum I operate, if a particular page is being held up because it hasn't fully loaded, then while I'm scrolling after having started out in a specific place, the page will reload to where I started. But this only happens one time unless of course I manually refresh the page myself.

Hang in there. Help will be on the way.  Wink

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #7 - Nov 14th, 2012 at 8:52pm
Post Tools
Thanks Bill,

I'm glad we're on the same page with it, I was beginning to question my sanity  Smiley

Rooze
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #8 - Nov 14th, 2012 at 8:59pm
Post Tools
rooze wrote on Nov 14th, 2012 at 8:52pm:
Thanks Bill,

I'm glad we're on the same page with it, I was beginning to question my sanity  Smiley

Rooze

You're good. Wink

Interestingly, I'm still only getting that one refresh, and then everything is fine. No more refreshing of the page no matter where I'm scrolling. To me, that says something on the page hadn't fully loaded.

At least your pages aren't constantly refreshing any more; at least not with meSmiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #9 - Nov 14th, 2012 at 9:14pm
Post Tools
Bill Myers wrote on Nov 14th, 2012 at 8:59pm:
[quote author=726F6F7A65000 link=1352914180/7#7 date=1352926366]At least your pages aren't constantly refreshing any more; at least not with me.  Smiley


You are correct sir!

Now there's just the one refresh for me too. It actually doesn't appear like a refresh, it's more like using an anchor link/tag on the same page, it just jumps.

Hmmm....It's odd that removing the ads has stopped the multiple jumps but not that first one...

Rooze
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #10 - Nov 14th, 2012 at 9:26pm
Post Tools
rooze wrote on Nov 14th, 2012 at 9:14pm:
Hmmm....It's odd that removing the ads has stopped the multiple jumps but not that first one...

That is odd. The usual reason for that to happen is because a page hasn't fully loaded. But from what I can see, it is fully loading!

Now I think I'm going crazy! Roll Eyes

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,492
Location: Earth

YaBB 2.6.1
Re: Page jumps to footer after 20 seconds!
Reply #11 - Nov 14th, 2012 at 10:13pm
Post Tools
First, run your page through an html validator (You'll have to do it using the output of 'View Source' from your browser.) You have two divs that aren't closed or are improperly nested. Ditto some table cells.and rows.

Code
Select All
<div id="art-main">
        <div class="art-Sheet"> 


aren't closed.

There are other errors as well, like two different character encoding declarations, two different language values.

Fix the html nesting and closures and chances are page will load properly
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Page jumps to footer after 20 seconds!
Reply #12 - Nov 14th, 2012 at 10:27pm
Post Tools
to add to what Dandello has posted you also have 4 items 404=missing

1. http://newaudiosociety.com/yabbfiles/newashtml/script.js
2. http://newaudiosociety.com/yabbfiles/newashtml/style.css
3. /cgi-bin/yabb2/style.ie7.css
4. http://www.apneatic.com/feed/
  

404show.jpg ( 907 KB | 83 Downloads )
404show.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #13 - Nov 14th, 2012 at 10:34pm
Post Tools
Thank you very much! That did it.  Smiley

I was wading through scripts looking for a timer or something....duh.  Embarrassed

Rooze
  
Back to top
 
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #14 - Nov 14th, 2012 at 10:35pm
Post Tools
xnoddyx wrote on Nov 14th, 2012 at 10:27pm:
to add to what Dandello has posted you also have 4 items 404=missing

1. http://newaudiosociety.com/yabbfiles/newashtml/script.js
2. http://newaudiosociety.com/yabbfiles/newashtml/style.css
3. /cgi-bin/yabb2/style.ie7.css
4. http://www.apneatic.com/feed/



Thanks! Hadn't noticed those, will investigate now.

Cheers

Rooze
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools