Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Page jumps to footer after 20 seconds! (Read 5,619 times)
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,608
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #23 - Nov 17th, 2012 at 4:04am
Post Tools
From Carsten's Subject Line here in his YaBB forum on Thursday, November 15, 2012 at 6:51 p.m. (his forum's date and time):

Quote:
Somebody whispered in my ear pointing my attention to a discussion on yabbforum.com about unwanted page jump in topic display when referred to with an anchor: http://www.yabbforum.com/community/YaBB.pl?num=1352914180

Could be considered a bug in the image (avatar) resize javascript.

In YaBB.js find and remove:

Code
Select All
	// To prevent window from jumping to other place because
	// of image resize after window is set to the ancor this is needed:
	} else if (location.hash) {
		location.href = location.hash; 


I fail to see the reason for this - in the actual case it'll have the opposite effect of the comment added.
« Last Edit: Nov 17th, 2012 at 4:05am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,608
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #22 - Nov 16th, 2012 at 7:43am
Post Tools
xnoddyx wrote on Nov 15th, 2012 at 11:53am:
this have will probably been down to some java script overlap also it may have just been down to a bug that Firefox has with the cursor disappearing and its been about for a bit and i still don't think it is fixed https://bugzilla.mozilla.org/show_bug.cgi?id=226301

Thanks for the reminder. I had forgotten about that bug.
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Page jumps to footer after 20 seconds!
Reply #21 - Nov 15th, 2012 at 11:53am
Post Tools
rooze wrote on Nov 15th, 2012 at 1:13am:
I took the avatar out, and it seems to be behaving. I could've swore that it happened all the time, not just on pages where Clive had posted....but I may be wrong of course....I'll get back in there and trawl around, but looking good  Cheers!


cool glad you are fixed  Wink

Bill Myers wrote on Nov 15th, 2012 at 12:15am:
Weird, but true: As memory serves me, the last mess I made was when I added a rotating ad script that works fine on the main pages of our site. However, for whatever reason my cursor would disappear while adding or editing posts in the forum while using Firefox or Chrome (but Internet Explorer was fine).I still don't understand what actually caused the problem, but it was solved when I replaced the ad rotation script with a static add. Then sales went up. Go figure.

this have will probably been down to some java script overlap also it may have just been down to a bug that Firefox has with the cursor disappearing and its been about for a bit and i still don't think it is fixed https://bugzilla.mozilla.org/show_bug.cgi?id=226301
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,608
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #20 - Nov 15th, 2012 at 7:37am
Post Tools
Your forum appears to be operating properly without any unnecessary refreshing. Congratulations!

Not to throw a monkey wrench in the monkeying around that you had to do to get things working again, but according to my notes about Google ads, the rotation of ads shouldn't be refreshing your page. So you might want to put that back in, and see if your forum still operates the way that it should.

Good luck! You have a great looking forum.  Smiley
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,266
Location: Earth

YaBB 2.6.0
Re: Page jumps to footer after 20 seconds!
Reply #19 - Nov 15th, 2012 at 4:00am
Post Tools
And to add to xnodyxx's observation: nothing should be looking for this: Quote:
3. /cgi-bin/yabb2/style.ie7.css
  There should be no css files in the cgi-bin and nothing should be looking for them.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #18 - Nov 15th, 2012 at 1:13am
Post Tools
Bill Myers wrote on Nov 15th, 2012 at 12:15am:
It's good to see the big guns coming out on this one ... just a matter of time now. Wink

********************************************************************

One of the great things about YaBB is that it can be easily edited in terms of including HTML language, etc. But as I've done it before, any given script or change can also mess things up.

Rule of thumb for me at least: After every change I make to YaBB, I check it out to make sure that everything is working like it should. But I don't always catch stuff. Even still, then I kind of take a forensic look at changes I've made, and I double check it all.

Weird, but true: As memory serves me, the last mess I made was when I added a rotating ad script that works fine on the main pages of our site. However, for whatever reason my cursor would disappear while adding or editing posts in the forum while using Firefox or Chrome (but Internet Explorer was fine).

I still don't understand what actually caused the problem, but it was solved when I replaced the ad rotation script with a static add. Then sales went up. Go figure.




Oh my  Shocked

Genius  Smiley

I took the avatar out, and it seems to be behaving. I could've swore that it happened all the time, not just on pages where Clive had posted....but I may be wrong of course....

I'll get back in there and trawl around, but looking good  Smiley

Cheers!
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,608
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #17 - Nov 15th, 2012 at 12:15am
Post Tools
It's good to see the big guns coming out on this one ... just a matter of time now. Wink

********************************************************************

One of the great things about YaBB is that it can be easily edited in terms of including HTML language, etc. But as I've done it before, any given script or change can also mess things up.

Rule of thumb for me at least: After every change I make to YaBB, I check it out to make sure that everything is working like it should. But I don't always catch stuff. Even still, then I kind of take a forensic look at changes I've made, and I double check it all.

Weird, but true: As memory serves me, the last mess I made was when I added a rotating ad script that works fine on the main pages of our site. However, for whatever reason my cursor would disappear while adding or editing posts in the forum while using Firefox or Chrome (but Internet Explorer was fine).

I still don't understand what actually caused the problem, but it was solved when I replaced the ad rotation script with a static add. Then sales went up. Go figure.

« Last Edit: Nov 15th, 2012 at 12:17am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Page jumps to footer after 20 seconds!
Reply #16 - Nov 14th, 2012 at 11:59pm
Post Tools
ok i think this may be down to the avatar for Clive not loading as the jump seems to happen at the same time as the time out for the avatar No image found
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #15 - Nov 14th, 2012 at 11:16pm
Post Tools
Oh boy.

Still jumping....will keep wading through the html  Sad
  
Back to top
 
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #14 - Nov 14th, 2012 at 10:35pm
Post Tools
xnoddyx wrote on Nov 14th, 2012 at 10:27pm:
to add to what Dandello has posted you also have 4 items 404=missing

1. http://newaudiosociety.com/yabbfiles/newashtml/script.js
2. http://newaudiosociety.com/yabbfiles/newashtml/style.css
3. /cgi-bin/yabb2/style.ie7.css
4. http://www.apneatic.com/feed/



Thanks! Hadn't noticed those, will investigate now.

Cheers

Rooze
  
Back to top
 
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #13 - Nov 14th, 2012 at 10:34pm
Post Tools
Thank you very much! That did it.  Smiley

I was wading through scripts looking for a timer or something....duh.  Embarrassed

Rooze
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Page jumps to footer after 20 seconds!
Reply #12 - Nov 14th, 2012 at 10:27pm
Post Tools
to add to what Dandello has posted you also have 4 items 404=missing

1. http://newaudiosociety.com/yabbfiles/newashtml/script.js
2. http://newaudiosociety.com/yabbfiles/newashtml/style.css
3. /cgi-bin/yabb2/style.ie7.css
4. http://www.apneatic.com/feed/
  

404show.jpg ( 907 KB | 81 Downloads )
404show.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,266
Location: Earth

YaBB 2.6.0
Re: Page jumps to footer after 20 seconds!
Reply #11 - Nov 14th, 2012 at 10:13pm
Post Tools
First, run your page through an html validator (You'll have to do it using the output of 'View Source' from your browser.) You have two divs that aren't closed or are improperly nested. Ditto some table cells.and rows.

Code
Select All
<div id="art-main">
        <div class="art-Sheet"> 


aren't closed.

There are other errors as well, like two different character encoding declarations, two different language values.

Fix the html nesting and closures and chances are page will load properly
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,608
Location: Los Angeles

YaBB 2.4
Re: Page jumps to footer after 20 seconds!
Reply #10 - Nov 14th, 2012 at 9:26pm
Post Tools
rooze wrote on Nov 14th, 2012 at 9:14pm:
Hmmm....It's odd that removing the ads has stopped the multiple jumps but not that first one...

That is odd. The usual reason for that to happen is because a page hasn't fully loaded. But from what I can see, it is fully loading!

Now I think I'm going crazy! Roll Eyes

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
rooze
YaBB Newcomer
*
Offline



Posts: 16
Re: Page jumps to footer after 20 seconds!
Reply #9 - Nov 14th, 2012 at 9:14pm
Post Tools
Bill Myers wrote on Nov 14th, 2012 at 8:59pm:
[quote author=726F6F7A65000 link=1352914180/7#7 date=1352926366]At least your pages aren't constantly refreshing any more; at least not with me.  Smiley


You are correct sir!

Now there's just the one refresh for me too. It actually doesn't appear like a refresh, it's more like using an anchor link/tag on the same page, it just jumps.

Hmmm....It's odd that removing the ads has stopped the multiple jumps but not that first one...

Rooze
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top