Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Path/Permission Problem (Read 1,928 times)
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: Path/Permission Problem
Reply #15 - Dec 8th, 2012 at 8:12pm
Post Tools
earthylad wrote on Dec 8th, 2012 at 7:48pm:
Such a stupid mistake to make as well Embarrassed. Particularly as I've been copying the server path all week, getting my sites back online. I owe xnoddyx a debt of gratitude.

Put it down to fatigue and general lack of attention. Roll Eyes


Its cool when you are looking for a forest sometimes you can't see it for the trees  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Path/Permission Problem
Reply #14 - Dec 8th, 2012 at 7:48pm
Post Tools
Such a stupid mistake to make as well Embarrassed. Particularly as I've been copying the server path all week, getting my sites back online. I owe xnoddyx a debt of gratitude.

Put it down to fatigue and general lack of attention. Roll Eyes
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,557
Location: Los Angeles

YaBB 2.4
Re: Path/Permission Problem
Reply #13 - Dec 8th, 2012 at 7:01pm
Post Tools
Yep! Check on the check list. Great idea indeed.  Smiley

I noticed with at least one other forum software that a check list of items comes up when there are any problems during an installation. Cool stuff! Maybe YaBB can one day have something like that.
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Path/Permission Problem
Reply #12 - Dec 8th, 2012 at 6:17pm
Post Tools
A check list would be great, Linux, windows, shared, VPS etc  Cool
Great stuff.

  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: Path/Permission Problem
Reply #11 - Dec 8th, 2012 at 6:00pm
Post Tools
this is now fixed it was a paths prob what was there
/vhost/vhost12/h/i/g/highlandpoultryadoption.co.uk/yabbfiles

fixed
/vhost/vhost12/h/i/g/highlandpoultryadoption.co.uk/www/yabbfiles

so was just missing /www/ so all good now  Grin

i need to remember to make a check list for this.
« Last Edit: Dec 8th, 2012 at 6:00pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Path/Permission Problem
Reply #10 - Dec 8th, 2012 at 9:52am
Post Tools
I always use a plain text editor, but always ensure I save the file using the correct extension. If you change the extension the file is useless.
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,557
Location: Los Angeles

YaBB 2.4
Re: Path/Permission Problem
Reply #9 - Dec 8th, 2012 at 8:14am
Post Tools
Uploading text files as ASCII versus binary is very important. I've inadvertently made that mistake myself. Maybe that is what happened if you edited a file locally, and then uploaded it to the server improperly.

I routinely edit text files locally using WordPad, and of course save them as a "Plain text document" (plain text without line breaks or formatting).

And again, because it's ASCII versus binary, I upload these files as plain text.

When I use the Ipswitch WS_FTP LE program, files with a css extension are already properly identified as ASCII, so that's not a problem.

When I use the WinSCP program, files with a css extension are also already properly identified as ASCII.

Whatever program you use, it's important to make sure files are saved as plain text, and uploaded as ASCII files (Text).

By the way, sometimes when a particular file isn't working as it should, uploading a backup copy of it gets it to work again. I think files can get corrupted from time to time, especially in cases of moving files from one host to another.
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,129
Location: Earth

YaBB 2.6.0
Re: Path/Permission Problem
Reply #8 - Dec 8th, 2012 at 1:44am
Post Tools
That top picture looks like the code was edited and saved out of notepad - the line ends are messed up. (Maybe it was uploaded as binary? That can do weird things to ascii files.)

Do you have file editing capabilities through your host's file manager? If you can open it there and edit it and make sure it's saved as ascii you might be okay.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: Path/Permission Problem
Reply #7 - Dec 8th, 2012 at 1:19am
Post Tools
Bill Myers wrote on Dec 8th, 2012 at 12:54am:
How ironically funny is that? There I was mentioning the same thing by one of YaBB's resident experts without me knowing that he was getting to it.So yes, what he stated worked for me.  

lol it is  Grin

ok back OT

when i say 'but the setout of the hpa.css dont look how it should do'
have a look at the pic of the downloaded css files from your site

Edited:
earthylad wrote on Dec 8th, 2012 at 1:16am:
Thanks guys, tried making copies and renaming them, but nothing gives on this weird error.


ok can you send me admin info for the forum and ftp login info in a pm and i will have a look for you  Smiley
« Last Edit: Dec 8th, 2012 at 1:21am by xnoddyx »  

cssh.jpg ( 193 KB | 51 Downloads )
cssh.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Path/Permission Problem
Reply #6 - Dec 8th, 2012 at 1:16am
Post Tools
Thanks guys, tried making copies and renaming them, but nothing gives on this weird error.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,557
Location: Los Angeles

YaBB 2.4
Re: Path/Permission Problem
Reply #5 - Dec 8th, 2012 at 12:54am
Post Tools
earthylad wrote on Dec 8th, 2012 at 12:24am:
I've checked the path again, and again, it seems to be correct.

Confirmed! Your hpa.css file is definitely there, and so too is your default.css file.

Like Dandello mentioned, that file is really only opened to edit the file itself (and other css files). If it's any consolation, I've had the same error message when trying to edit a different css file. It just won't save. Nobody was able to figure it out, so we just stuck with our default.css file.

What I ended up doing was editing our default.css file, duplicating that file as another name, and I uploaded both files to our server (I didn't want people to use one file over the other ... wanted the rendering of our forum to be the same). Of course, our default.css file is the only one I can use anyway, so that's pretty much why I did what I did. Whatever works.

If it's any consolation, other than being in maintenance mode as I post this, your forum looks great.  Wink


Edited:
xnoddyx wrote on Dec 8th, 2012 at 12:54am:
ok i dono if this may be the prob or not but the setout of the hpa.css dont look how it should do
http://highlandpoultryadoption.co.uk/yabbfiles/Templates/Forum/hpa.css

but your default.css looks ok
http://highlandpoultryadoption.co.uk/yabbfiles/Templates/Forum/default.css

so if you can make a copy of hpa.css then make a copy of default.css then rename default.css to hpa.css and then see if it will work

How ironically funny is that? There I was mentioning the same thing by one of YaBB's resident experts without me knowing that he was getting to it.

So yes, what he stated worked for me.  Smiley

« Last Edit: Dec 8th, 2012 at 1:00am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: Path/Permission Problem
Reply #4 - Dec 8th, 2012 at 12:54am
Post Tools
ok i dono if this may be the prob or not but the setout of the hpa.css dont look how it should do
http://highlandpoultryadoption.co.uk/yabbfiles/Templates/Forum/hpa.css

but your default.css looks ok
http://highlandpoultryadoption.co.uk/yabbfiles/Templates/Forum/default.css

so if you can make a copy of hpa.css then make a copy of default.css then rename default.css to hpa.css and then see if it will work
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Path/Permission Problem
Reply #3 - Dec 8th, 2012 at 12:24am
Post Tools
I've checked the path again, and again, it seems to be correct. I've  also checked that the file is actually there, also chmod 644 (as suggested), still no luck.

Any more pointers anyone?
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: Path/Permission Problem
Reply #2 - Dec 8th, 2012 at 12:08am
Post Tools
earthylad wrote on Dec 7th, 2012 at 9:16pm:
Error: Unable to open /vhost/vhost12/h/i/g/highlandpoultryadoption.co.uk/yabbfiles/Templates/Forum/hpa
.css

did you check that the file is there and that it has a CHMOD of 644
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,129
Location: Earth

YaBB 2.6.0
Re: Path/Permission Problem
Reply #1 - Dec 7th, 2012 at 9:46pm
Post Tools
Double check that path. About the only time it's used is when opening things to edit, but I'm betting there's a misspelling or a capitalization issue  or something like that in there.

  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top