Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Re: 500 Error during installation (Read 4,524 times)
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Fixing YaBB's problems in a timely fashion
Reply #16 - Dec 19th, 2012 at 5:43pm
Post Tools
depablo wrote on Dec 19th, 2012 at 9:54am:
Bill
Have you had any resource allocation problems on your 2.4 forum? I take it the length of time you have been running, it has a fairly large membership?

John, I don't believe I've ever had any resource allocation problems in our forum, and ours is a pretty decent size (our current stats below).

Quote:
We have 7748 registered members.
Our users have made 12841 Posts within 1828 Topics.
Most Users ever online were 3709 on December 1, 2012 at 8:02pm.
Most Members ever online were 44 on October 15, 2012 at 4:16pm.
Most Guests ever online were 3676 on December 1, 2012 at 8:02pm.
Most Search Engine inquiries on-line were 536 on August 22, 2012 at 5:43am.

Plus, spammers hit our forum all the time in large numbers, and that can hog resources as well. Still, our forum operates quite nicely; no resource allocation problems for our 2.4 forum.

There have been discussions in this forum about YaBB being unable to handle larger forums, most notably from The Boy in your neck of the woods who was compelled to move his forum away from YaBB (but his forum is far bigger and busier than the one I operate).

I should point out that he's still a big supporter of YaBB as am I.

****************************************

WestwegoMan wrote on Dec 19th, 2012 at 4:34pm:
... ...

I know! How many times does this support forum need to be notified of a problem before it does anything about it? Roll Eyes

On the other hand, thankfully, support in this forum has been top notch for its members, so the staff's lack of action to fix things around here can be excused to just one of those things. Besides, evidently behind the scenes, a lot of great work is being done, and that's to be applauded.

Meanwhile, it would be great for the public to have this particular forum operate in a way that's a great showcase for YaBB. I'm looking forward to it. One step at a time.

« Last Edit: Dec 19th, 2012 at 5:45pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
westwegoman
Ex Member
**




None
Re: 500 Error during installation
Reply #15 - Dec 19th, 2012 at 4:34pm
Post Tools
Sorry, I just have to....



Grin Grin Grin
  
<div class=
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: 500 Error during installation
Reply #14 - Dec 19th, 2012 at 9:54am
Post Tools
Bill
Have you had any resource allocation problems on your 2.4 forum? I take it the length of time you have been running, it has a fairly large membership?
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: YaBB's fresh start
Reply #13 - Dec 19th, 2012 at 8:18am
Post Tools
xnoddyx wrote on Dec 19th, 2012 at 3:01am:
... there is no pretend that YaBB is starting up freshly again ...

Yes, I know this, and thanks for your illustration to remind us of one of the ways that YaBB is starting up freshly again. This is one of the reasons that I was renewed with excitement about YaBB. I still feel this same excitement.
Smiley Keep up the great work! Smiley

****************************************

Ironically, YaBB has never really had a problem with its forum software. It's generally been pretty outstanding. In fact, it was so good that it was forked off to another forum software that's taken the lead in popularity, and enhancements. But for me personally, I still favor the original YaBB.

A long time ago YaBB gained a bad reputation because of problems with its Perl-based software (YaBB was attributed to causing resource allocation problems on many systems). I'm not a tech guy, so I don't know about this kind of stuff. All I know is that our forum has always run quite nicely to compliment one of our most popular sites.

But even reported "resource allocation problems" can be mitigated; that is, if developers will stick around to stay on top of things. Unfortunately, many developers left. Worse yet, a great many people using YaBB also left.

I don't know enough about the problems developers had, but I do know about the problems that bothered many of its users.

For one, it was not at all uncommon for users to be treated with disrespect, and unprofessional behavior. There was a gang mentality that pushed a lot of people away. Currently, this no longer seems to be a problem, but then, relatively speaking there aren't a lot of us left.

YaBB used to be the biggest, and the best. It doesn't have to be the biggest any longer, but it should become the best again. I think 3 simple things will put YaBB back on top, including the possibility that it can once again be the biggest.

1. Be professional and courteous to everyone no matter what the circumstances are.

2. Operate this forum with a stable version of YaBB that can showcase YaBB's great software.

3. Continue to work on YaBB's core to improve its features, and to address issues such as resource allocation problems. However, it's best to offer updated versions of YaBB only after it's been tested for stability, and it's relatively bug free (the forum software is working as it should).

If YaBB will take care of the basics, it will be primed for an incredibly bright future. It's already had a great past, and that legacy deserves to enjoy a proud future.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 500 Error during installation
Reply #12 - Dec 19th, 2012 at 3:01am
Post Tools
Bill Myers wrote on Dec 18th, 2012 at 7:40pm:
Actually, at least 3 of YaBB's current team members have been staffers longer than July 2012. Maybe you joined them back then, and it seems that a previous staffer is now back, but it's still pretty much the same team.

yes there are old team members on the new team but their roles and positions have changed Bill Myers wrote on Dec 18th, 2012 at 7:40pm:
pretend that YaBB is starting up freshly again.

there is no pretend that YaBB is starting up freshly again it is there is alot of code streamlining and cleaning going on this is why the 2.5 code was used for 2.5.2 -> 2.5.4 and so on you can see most of the RoadMap here

although i think there may have been some edits to it,
but even the redundant versions of YaBB like what is running here that some code will be used from will go threw the code streamlining and cleaning and making it more user friendly so by the end of it yabb will be where most of the users of yabb want it to be then next will be streamlining and cleaning and then on the road to the next big need of yabb  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Fixing YaBB's problems in a timely fashion
Reply #11 - Dec 18th, 2012 at 7:40pm
Post Tools
xnoddyx wrote on Dec 18th, 2012 at 6:42pm:
new team est July 2012 and on.

Actually, at least 3 of YaBB's current team members have been staffers longer than July 2012. Maybe you joined them back then, and it seems that a previous staffer is now back, but it's still pretty much the same team.

Thankfully, however, with good people like you on the team, and older team members once again being professionally supportive of the rest of us YaBBers, I've been quite happy with the results.

People will say that nothing's really changed, but I think it has in very good ways, so I hope I'm not wrong about this.

In any case, even if you were correct about a new team having gotten together in July, it's not good that these problems still exist.

But let's once again pretend that YaBB is starting up freshly again. Let's pretend that these problems are only now being discovered, and that there's some kind of schedule to get them fixed.

Let's see how long it takes this time. I'll be hopeful about it.  Wink
« Last Edit: Dec 18th, 2012 at 7:41pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 500 Error during installation
Reply #10 - Dec 18th, 2012 at 6:42pm
Post Tools
Bill Myers wrote on Dec 18th, 2012 at 5:47pm:
Just so you're up to speed on this, these spaces have been watched for a couple of years

sorry but i have to correct you on that, the team that is working now is not the same team as was working then and in the short spaces of time this team has been together there has been a lot of discussion on what if, how, when, some rethinking, and so on at the same time a learning curve for some of us also working out some kinks and all in all i think it has been a good job even with some of the setbacks that there has been.

new team est July 2012 and on.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Fixing this forum's problems one step at a time
Reply #9 - Dec 18th, 2012 at 5:47pm
Post Tools
xnoddyx wrote on Dec 18th, 2012 at 2:24pm:
ah ok i think when you say topic link you mean breadcrumb navigation.

Ah yes. That's the ticket.

****************************************

xnoddyx wrote on Dec 18th, 2012 at 2:24pm:
as to the YaBB showcase there is work going on to replace it as it is just a matter of watch this spaces.

as to the Codex this may or may not be updated or may be replaced agen it is just a matter of watch this spaces.

Just so you're up to speed on this, these spaces have been watched for a couple of years (since at least last February regarding the Codex), and neither problem has been fixed in all of that time. We can watch all we want, but nothing will change unless somebody - anybody - makes the effort to fix these reported problems.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 500 Error during installation
Reply #8 - Dec 18th, 2012 at 2:24pm
Post Tools
Bill Myers wrote on Dec 18th, 2012 at 8:19am:
Try clicking the topic link above of "Installation and Setup on Linux, UNIX, Mac, and BSD Servers" and see what you get. The correct link should be here.The example above is pretty much what happens throughout this forum. A number of us have mentioned these bad links over the last year or two, but nothing has ever been done about it.

ah ok i think when you say topic link you mean breadcrumb navigation.

Bill Myers wrote on Dec 18th, 2012 at 8:19am:
It makes no sense at all for YaBB to showcase its forum like this. It's embarrassing.

as to the YaBB showcase there is work going on to replace it as it is just a matter of watch this spaces. and when i say work going on i don't mean 9 -5 i mean a mind blowing amount of work going on and that is just scratching the surface.

and this is why we need as much help with bug finding and testing as we can get.

Bill Myers wrote on Dec 18th, 2012 at 8:19am:
Similarly, (particularly while using Firefox), the YaBB Codex here on this page still renders incorrectly even after it had been reported numerous times over the last year and a half or so.


as to the Codex this may or may not be updated or may be replaced agen it is just a matter of watch this spaces.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: 500 Error during installation
Reply #7 - Dec 18th, 2012 at 8:19am
Post Tools
xnoddyx wrote on Dec 17th, 2012 at 7:46pm:
Bill Myers wrote on Dec 17th, 2012 at 6:11pm:
I still wish this forum's topic links would work correctly,

when you say that what do you mean?.

Try clicking the topic link above of "Installation and Setup on Linux, UNIX, Mac, and BSD Servers" and see what you get. The correct link should be here.

The example above is pretty much what happens throughout this forum. A number of us have mentioned these bad links over the last year or two, but nothing has ever been done about it.

It makes no sense at all for YaBB to showcase its forum like this. It's embarrassing. Embarrassed


Similarly, (particularly while using Firefox), the YaBB Codex here on this page still renders incorrectly even after it had been reported numerous times over the last year and a half or so.

The saddest part of all is that the rendering problem can be fixed within a few minutes at most. All that's needed are the correct image references to the language icons (it really is that easy). I figured this out myself a long time ago (and tested it locally), but evidently nobody on YaBB's staff who can make those edits seems to care enough to fix what is a really quick and easy fix.

These kind of otherwise small things are two of the reasons that I've suggested holding off on letting the public at large know that YaBB is back on track with a great future as I still believe it is. YaBB's showcase forum should show the public what YaBB can do; not show them the bad stuff.

What I finally learned to do was to kind of laugh about it, and just chalk it off to the idiosyncrasies of human nature. You have to admit that this is kind of funny. And beyond that, it's almost too hard to believe. Not fixing these relatively small issues defies explanation.
The last couple of years have kind of been like living in YaBB's Bizarro WorldSmiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: 500 Error during installation
Reply #6 - Dec 17th, 2012 at 7:46pm
Post Tools
Bill Myers wrote on Dec 17th, 2012 at 6:11pm:
In that case, then so too has this subject been corrected; at least from this point. 

there you go all fixed for you  Wink

Bill Myers wrote on Dec 17th, 2012 at 6:11pm:
I still wish this forum's topic links would work correctly,

when you say that what do you mean?.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: 500 Error during installation
Reply #5 - Dec 17th, 2012 at 6:11pm
Post Tools
xnoddyx wrote on Dec 17th, 2012 at 12:47pm:
This Topic was moved from this Topic.

In that case, then so too has this subject been corrected; at least from this point.  Wink

I still wish this forum's topic links would work correctly, but then, that's another topic altogether. Pretty please.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Generating Interest
Reply #4 - Dec 17th, 2012 at 12:47pm
Post Tools
This Topic was moved from this Topic.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Generating Interest
Reply #3 - Dec 17th, 2012 at 5:23am
Post Tools
xnoddyx wrote on Dec 17th, 2012 at 2:26am:
i have run a setup similar to this before so you may want to ask your host how your cgi-bin is setup especially if the only .pl scripts that will run are in your /cgi-bin/yabb2 directory  Wink

I think I got all of that, so I believe what you've explained makes sense to me. I'll have to check these things out when I get the chance.
Smiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Generating Interest
Reply #2 - Dec 17th, 2012 at 2:26am
Post Tools
Bill Myers wrote on Dec 17th, 2012 at 12:12am:
I've been pretty good about location,

yes you may have been but when i say
Quote:
look at 1.Location.


i am referring to this part
xnoddyx wrote on Dec 16th, 2012 at 9:37pm:
Others will only run it when it is installed in a particular directory. It is not just a matter of creating a "cgi-bin" directory - for example, some hosts configure the server so that it will run scripts only from a particular directory outside the web directory structure (for security reasons). Your web page will still call the script "/cgi-bin/script.pl" but the server maps it to the actual directory.


1a. so it may just be that your server is setup to run scripts only from your yabb2 directory and thats why setting up a new forum outside of here won't work for you.

2.a but also at the same time it may be that only your yabb2 directory is set to run .cgi and .pl but that your root cgi-bin is only setup to run .cgi.

also as 1a but the root cgi-bin is not the same as your yabb2 /cgi-bin/yabb2 directory as your root cgi-bin may be a maped directory e.g.

say you have /home/a-d/username/host/username/www/public_html
and /home/a-d/username/host/username/www/cgi-bin
and the root ftp login is /home/a-d/username/host/username here you will also have /logs/ and so on, so your server is setup to run .cgi from /home/a-d/username/host/username/www/cgi-bin
but set to run .cgi and .pl from /home/a-d/username/host/username/www/cgi-bin/yabb2
also at the same time it may have a /home/a-d/username/host/cgi-bin and this is set to run .cgi and .pl and is also maped to www.mysite.co/cgi-bin but as the root ftp login is /home/a-d/username/host/username you cannot access this.

i have run a setup similar to this before so you may want to ask your host how your cgi-bin is setup especially if the only .pl scripts that will run are in your /cgi-bin/yabb2 directory  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top