Page Index Toggle Pages: 1
Topic Tools
Locked Topic Error after running setup.pl latest download 2.5.2 (Read 2,681 times)
CSK
YaBB Newcomer
*
Offline



Posts: 6

None
Error after running setup.pl latest download 2.5.2
Dec 19th, 2012 at 1:55pm
There are no actions to perform.
This is a clean install, no old version on server.

I ran the setup... all seemed fine right to the end then after url shows ..../Setup.pl?action=setup3
I click continue and get a page without any links on it ?? No log in, nothing... nothing just pictures...

If I run the ...../YaBB.pl I get an error

The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

Don't make sense to me as all the modules were validated as ok earlier in the setup.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Error after running setup.pl latest download 2.5.2
Reply #1 - Dec 19th, 2012 at 3:30pm
There are no actions to perform.
Hi CSK

can you PM me the url to your forum also ftp info as well if you can and i will have a look for you  Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
CSK
YaBB Newcomer
*
Offline



Posts: 6

None
Re: Error after running setup.pl latest download 2.5.2
Reply #2 - Dec 19th, 2012 at 4:52pm
There are no actions to perform.
I can't do that - Forum does not allow me to PM you.

I just tried running setup.pl again and it came up ...
You are running the YaBB 2.5.2 Converter.

Clearly something seems to be very wrong. PERL should not need to be running some weird compression.

Also FYI I marked this thread as 'let me know of replies' ....  That don't seem to work either as I got no notification of your post.
  
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Error after running setup.pl latest download 2.5.2
Reply #3 - Dec 19th, 2012 at 5:02pm
There are no actions to perform.
CSK wrote on Dec 19th, 2012 at 4:52pm:
I can't do that - Forum does not allow me to PM you.

Email him the details.
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
CSK
YaBB Newcomer
*
Offline



Posts: 6

None
Re: Error after running setup.pl latest download 2.5.2
Reply #4 - Dec 19th, 2012 at 5:29pm
There are no actions to perform.
That would not be polite. He/She did not request that approach. However they are free to contact me by that method should they wish to.

Also There is no FTP as my server is housed on the network. I would need to set up an account on the server and allow FTP to the account.  Files are transferred across the network. This has never caused issues with PHP, PERL, SQL, AJAX, Java, Javascript or other languages/protocols.

The script is NOT being called direct over the network, it is called over the Internet (I have IP Nat loopback enabled) so perl runs fine from my workstation --> Internet --> Server -->Internet -->Workstation.  I host a few sites for friends and have no problem with any other perl scripts and have several running without any issues.
  
Back to top
 
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: Error after running setup.pl latest download 2.5.2
Reply #5 - Dec 19th, 2012 at 5:36pm
There are no actions to perform.
CSK wrote on Dec 19th, 2012 at 5:29pm:
That would not be polite.
He/She did not request that approach.

This is a very friendly place, xnoddyx is a great support person that is why he displays his email link in his profile.

We also need to look at why new users cannot send PM's due to post count, many folk facing problems have a low post count. I will raise this with other support people shortly  Smiley
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
CSK
YaBB Newcomer
*
Offline



Posts: 6

None
Re: Error after running setup.pl latest download 2.5.2
Reply #6 - Dec 19th, 2012 at 5:57pm
There are no actions to perform.
I am going to assume that somewhere in one of the files something such as

ob_start("ob_gzhandler" );

or equilavent is being used.

If that is the reason then the error I am getting may be resolved by altering that line to

ob_start();

But I am not going to search through the miriad of files to try to find it and I am not sure that altering the perl is legal under the copyright
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,028
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Error after running setup.pl latest download 2.5.2
Reply #7 - Dec 19th, 2012 at 8:32pm
There are no actions to perform.
How to turn off gzip compression manually -

Edit /yabb2/Variables/Settings.pl:

Search for:

Code (Perl)
Select All
$gzcomp = 1;                                      # GZip compression: 0 = No Compression, 1 = External gzip, 2 =
                                                  #  Zlib::Compress
 


Set to

Code (Perl)
Select All
$gzcomp = 0; 



Save.

The reason the Conversion was triggered is that if Setup.pl is invoked after /yabb2/Variables/setup.lock exists, the system assumes it is a 'version update conversion'.

I don't think the installer should have assumed that the gzip filter was present. I would be interested to know what that setting is when you look at it. As you can see Zlib::Compress is also supported.

I think the case is that if the *nix gzip is not in the default location, YaBB is using a fixed path - I ran into that with the Backup.pl while working on a fix. My recollection is that it looks in /usr/bin (I don't know if that is true in the output routine also)

Good Luck
Wink



  

I find your lack of faith disturbing.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Error after running setup.pl latest download 2.5.2
Reply #8 - Dec 20th, 2012 at 12:14am
There are no actions to perform.
CSK wrote on Dec 19th, 2012 at 4:52pm:
Also FYI I marked this thread as 'let me know of replies' ....  That don't seem to work either as I got no notification of your post.

have you checked in your spam box? as it may be in ther happens to my hotmail email all the time.

CSK wrote on Dec 19th, 2012 at 5:29pm:
That would not be polite. He/She did not request that approach. However they are free to contact me by that method should they wish to.

as
depablo wrote on Dec 19th, 2012 at 5:36pm:
This is a very friendly place, xnoddyx is a great support person that is why he displays his email link in his profile.

sorry for any inconvenience caused i will have to make my self more clear in the future.

and JonB has posted the answer you are looking for  Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools