Page Index Toggle Pages: 1 [2] 
Topic Tools
Very Hot Topic (More than 25 Replies) spellcheck broken (Read 4,689 times)
freediver
Senior Member
****
Offline



Posts: 521
Re: spellcheck broken
Reply #15 - Dec 24th, 2012 at 1:45am
Post Tools
Thanks.

Quote:
Did you fix the shebang line in that module???


I don't understand what this means. Is there a bug I need to fix?
  

Founding member of . I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,492
Location: Earth

YaBB 2.6.1
Re: spellcheck broken
Reply #16 - Dec 24th, 2012 at 2:54am
Post Tools
It may not be a problem with the shebang (Which for freediver, the shebang is the first line in an executable Perl file and gives the path to perl on the server. The default for the SpellChecker is
Code
Select All
#!/usr/bin/perl --
 

But if perl is in a different place, this line needs to point to where Perl really is - just like you did with YaBB.pl and AdminIndex.pl, assuming you needed to.)

I managed to catch the error via FireBug and it points to a possible AJS.js issue or script mismatch. (There was one concerning QuickLinks that cropped up in 2.5.4 alpha.)

« Last Edit: Dec 24th, 2012 at 2:57am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
freediver
Senior Member
****
Offline



Posts: 521
Re: spellcheck broken
Reply #17 - Dec 24th, 2012 at 3:15am
Post Tools
The shebang line is identical to the one in YaBB. I assume this is an absolute path?

I have version 0.64 of Crypt::SSLeay installed as a 'system perl module'.
« Last Edit: Dec 24th, 2012 at 3:18am by freediver »  

Founding member of . I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,492
Location: Earth

YaBB 2.6.1
Re: spellcheck broken
Reply #18 - Dec 24th, 2012 at 4:36am
Post Tools
After much head scratching I have determined that the spellchecker doesn't work on one of my test servers at all. BUT, the other problem was that SpellChecker.pl really does have to be CHMODed to 755 on *nix systems.  Embarrassed
« Last Edit: Dec 24th, 2012 at 4:40am by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
westwegoman
Ex Member
**




YaBB 2.5.2
Re: spellcheck broken
Reply #19 - Dec 24th, 2012 at 11:03am
Post Tools
Just wanted to let you all know that it is also working on my sites.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,492
Location: Earth

YaBB 2.6.1
Re: spellcheck broken
Reply #20 - Dec 24th, 2012 at 2:27pm
Post Tools
I am currently betting it's a CHMOD issue - but I swear they were all okay on my sites and spellcheck was working until I uploaded some changes to other files.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: spellcheck broken - But it's not needed
Reply #21 - Dec 24th, 2012 at 3:15pm
Post Tools
Being that Googiespell works in some forums, and not in others, and people knowledgeable about computer issues know what they're doing, this issue is very possibly related to respective host servers than anything else.

Like Dandello pointed out, and I'm paraphrasing, it's got to be a permissions issue.

Thankfully, for those of us who haven't enabled this spellchecker option in our forums, people can use the spellcheckers in the different browsers.

I use this feature all the time. Otherwise, my speling woudd be horible! Cheesy

Hint: Right-click any misspelled word in a text box (in any of the most popular browsers)!  Smiley

« Last Edit: Dec 24th, 2012 at 3:17pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
freediver
Senior Member
****
Offline



Posts: 521
Re: spellcheck broken
Reply #22 - Dec 25th, 2012 at 7:41am
Post Tools
CHMOD SpellChecker.pl to 755 fixed it for me.

I agree with Bill. If more knowledgeable people know things then it opens up all sorts of possibilities.
  

Founding member of . I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
Back to top
WWW  
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: spellcheck broken
Reply #23 - Dec 25th, 2012 at 8:17am
Post Tools
freediver wrote on Dec 25th, 2012 at 7:41am:
CHMOD SpellChecker.pl to 755 fixed it for me.

Can confirm it now works for me also  Wink

Quote:
I agree with Bill.

So do I, host's have a lot to answer for. Although on this occasion I am not sure CHMOD is a host issue?
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Re: spellcheck broken
Reply #24 - Dec 25th, 2012 at 8:23am
Post Tools
freediver wrote on Dec 25th, 2012 at 7:41am:
CHMOD SpellChecker.pl to 755 fixed it for me.

Edited:
depablo wrote on Dec 25th, 2012 at 8:17am:
Can confirm it now works for me also   Wink

Thanks for letting us know. As you can see below, it seems that Dandello was correct about what the problem was.

Dandello wrote on Dec 24th, 2012 at 2:27pm:
I am currently betting it's a CHMOD issue

If I understood her correctly, in the following post she actually let us know that CHMOD 755 was the answer.

Dandello wrote on Dec 24th, 2012 at 4:36am:
SpellChecker.pl really does have to be CHMODed to 755 on *nix systems.

If I'm a little foggy on this, it may be because I opened too many presents this Christmas Eve (well, it's Christmas now as I type this). So perhaps Dandello can make any corrections about all of this the next time she appears.

« Last Edit: Dec 25th, 2012 at 8:26am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
depablo
YaBB Moderators
YaBB Next Team
Beta Testers
***
Offline



Posts: 577
Location: UK

None
Re: spellcheck broken
Reply #25 - Dec 25th, 2012 at 8:27am
Post Tools
Yup, Dandello was spot on  Grin

Merry xmas Bill to you and your family, hope you have a brilliant day  Smiley
  

Taking a peek behind the mask Wink
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,737
Location: Los Angeles

YaBB 2.4
Now fixed it seems! - Re: spellcheck broken
Reply #26 - Dec 25th, 2012 at 8:34am
Post Tools
Dandello usually is correct about these things. Actually, I don't remember a time when she's ever been wrong about computer stuff.

Merry Christmas to you and your family as well John. My wife and I are going to a 3D screening of The Hobbitt this Christmas day, and we're looking forward to it.

« Last Edit: Dec 25th, 2012 at 8:42am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,492
Location: Earth

YaBB 2.6.1
Re: spellcheck broken
Reply #27 - Dec 26th, 2012 at 3:09am
Post Tools
The requirement for SpellCheck.pl to be CHMODed to 755 was inadvertently left out of the QuickGuide for 2.5.2. Oddly enough, RSS.pl should probably also be CHMODed to 755 but that seems to run okay at 644.
Edited:
Basically, if you need to change the shebang to get it to work, it should be CHMODed to 755.


What threw me into thinking it something more complicated was that SpellCheck also stopped working on one of my Windows servers. Still haven't got that sorted out, but I'm pretty sure it's because although I have XAMPP on the laptop the YaBB files are being pulled from the NAS.

The other cases where my SpellCheck cut out - the files had been CHMODed to 644 (I suspect my new FTP program but my bad in not double-checking.)
« Last Edit: Dec 28th, 2012 at 10:09pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools