Page Index Toggle Pages: [1] 2 3 4
Topic Tools
Very Hot Topic (More than 25 Replies) Admin Control Panel is accessible, but ADVANCE SETTINGS is not (Read 8,149 times)
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Dec 23rd, 2012 at 8:56am
Post Tools
Hello,

I've recently install 2.5.2.  I can modify the FORUM SETTINGS and able to save.

However, when I click on ADVANCE SETTINGS, all I have displayed is simply the SAVE button.

Is something broken or is there an incorrect permission?

Running Windows 2003 Server.

http://hawaiiancommunity.net/yabb/YaBB.pl

The above link is the YABB forum.

Thank you,

Irwin
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,919
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #1 - Dec 23rd, 2012 at 2:12pm
Post Tools
Hi -

I was going to say, "That is a 'somewhat known issue' on Windows Servers, you could upgrade to 2.5.2".  When I say 'somewhat known', I mean it happens very rarely (rarely being we have maybe 10-20 reports) on Server 2003 and XP.  I have worked on dozens, maybe over a hundred, of 2003/XP installs. And I saw it 'live' for the first time myself this year while testing 2.5.2. 

The problem code is in \yabb2\Admin\Settings_Advanced.pl.  The proximate cause is a disk checking routine designed to only run on Linux, that is sometimes triggered on XP and Server 2003.  We do not know the trigger.

Discussion:
http://www.yabbforum.com/community/YaBB.pl?num=1348259619/16

Here is the link for a patched Settings_Advanced.pl.

http://www.yabbforum.com/community/YaBB.pl?action=downloadfile;file=Settings_Adv...

Just rename or move your old file \Admin\Settings_Advanced.pl and replace it with the patched file.  Be sure to fix your NTFS permissions,

Good Luck
Cool
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #2 - Dec 23rd, 2012 at 4:06pm
Post Tools
http://www.ctrlaltdel-usa.net/superman/forum/yabb/attachments/121223_Yabb_Advanc...

Screenshot....

Hi JonB,

I downloaded the file, renamed the original in the ADMIN folder to *.org, then copied this new Settings_Advanced.pl

Still the same result.

Permissions were set in NTFS on both "modify" and "Full control" on ADMIN, and Settings_Advanced.pl
« Last Edit: Dec 23rd, 2012 at 4:07pm by ExhaultedRuler »  

121223_Yabb_Advance_Screenshot.jpg ( 67 KB | 80 Downloads )
121223_Yabb_Advance_Screenshot.jpg

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #3 - Dec 23rd, 2012 at 4:09pm
Post Tools
To note, I run these boards too

http://www.superman808.com ;  (2.1)

http://www.damien1981.com/yabb/YaBB.pl (2.4)

...and they are working perfectly.
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #4 - Dec 23rd, 2012 at 10:13pm
Post Tools
To note - I unzipped the 2.5.2 again, wiped out the entire cgi-bin folder, and copied the files into the folder.

I've set the permissions on the cgi-bin folder to "FULL CONTROL, Read/Write/Modify", everything except special access for ISUSR.

...at this point, same result...

then I copied that patched Settings_Advance.pl file in the the ADMIN folder, and nada.
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,919
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #5 - Dec 24th, 2012 at 1:18am
Post Tools
At this point, it's impossible to say what has happened on your install. I do have some relevant questions:

A. Is this your server or a hosted one?

B. Is this a completely new install? Did you make any modifications at all before running into this problem?

C. If you worked directly on the server, when you worked with the extracted file 'Settings_Advanced.pl' did you use a 'move' operation or a 'copy' operation to get the file into the cgi-bin\yabb2\Admin folder? (yes it matters - 'move' breaks Inheritance on permissions)

D. I'm guessing the answer is 'yes', but I will ask - are the two other forums you mention on the same physical server? (We can actually totally dismiss the 2.1 server from the discussion as it does not have the same codebase. The 2.4 server does uses an earlier version of the same code).  Recall that I said we do not know the trigger, so we may need a workaround.

E. Tomorrow some time I will make a clean install on one of my W2K3 servers, to see if I can replicate your problem.

I'll also be looking for your answers as they may provide a clue. Ok?

Happy Holidays.
Wink
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #6 - Dec 24th, 2012 at 7:58am
Post Tools
JonB wrote on Dec 24th, 2012 at 1:18am:
At this point, it's impossible to say what has happened on your install. I do have some relevant questions:

A. Is this your server or a hosted one?

B. Is this a completely new install? Did you make any modifications at all before running into this problem?

C. If you worked directly on the server, when you worked with the extracted file 'Settings_Advanced.pl' did you use a 'move' operation or a 'copy' operation to get the file into the cgi-binyabb2Admin folder? (yes it matters - 'move' breaks Inheritance on permissions)

D. I'm guessing the answer is 'yes', but I will ask - are the two other forums you mention on the same physical server? (We can actually totally dismiss the 2.1 server from the discussion as it does not have the same codebase. The 2.4 server does uses an earlier version of the same code).  Recall that I said we do not know the trigger, so we may need a workaround.

E. Tomorrow some time I will make a clean install on one of my W2K3 servers, to see if I can replicate your problem.

I'll also be looking for your answers as they may provide a clue. Ok?

Happy Holidays.
Wink



Merry Christmas JonB!!

A - This is my server.  I have 60+ other hosted websites on this machine.

B & C - In both instances, a complete new install.  No modifications, just ran "Setup.pl" immediately after files were copied from one folder to the next, which is a cgi-bin folder that sits outside of the root to the website.  Within IIS, I have a virtual directory that points to the folder

D - yes the 2 other forums are on the same server, here are the foldernames

cgi-bin\yabb_2_1_superman  http://www.superman808.com
cgi-bin\yabb_damien  http://www.damien1981.com/yabb/YaBB.pl
cgi-bin\yabb_2_5_2_hawaiicom  http://hawaiiancommunity.net/yabb/YaBB.pl

The NTFS permissions are the same for each folder.  I believe, every option in the Admin control panel is accessible, except the ADVANCE SETTINGS.

E.. freakin' awesome....Santa!!

Thank you for your time!! Smiley

Irwin
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,919
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #7 - Dec 26th, 2012 at 1:22am
Post Tools
Hello there:

I think there may be a problem with the javascript that is controlling that section (I looked on your server). I am going to see if I can replicate the problem now.


Thanks and Happy Holidays
Wink

« Last Edit: Dec 26th, 2012 at 1:28am by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #8 - Dec 26th, 2012 at 4:59am
Post Tools
thanks man!!!
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #9 - Dec 31st, 2012 at 4:36am
Post Tools
bump...Happy New Year!!
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,919
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #10 - Dec 31st, 2012 at 3:11pm
Post Tools
Sorry ExhaultedRuler

Last week's Server attack blew me out for almost three days (we were down for about a day).  Good News- we fixed all the code without having to re-tread back to our last backup!  Wink

Then I had to work Saturday & part of Sunday to recoup my 'real-life' work.  I'll do the load this afternoon after I get some new machines attached to a clients network this afternoon.

Cool

Edited:
I did discuss it with Dandello, she is of a different opinion as to the cause. No matter the proximate cause, what you describe has not been seen before.
« Last Edit: Dec 31st, 2012 at 3:14pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #11 - Dec 31st, 2012 at 6:06pm
Post Tools
Thanks Jon.  I know what it's like balancing the stuff you'd like to do, and real work.

Bummer on the server attack.

Please let me know if you need any other additional info.

BTW, I'm using perl, v5.10.1
http://hawaiiancommunity.net/yabb/version.pl

The server is x86 32-bit

Click the link for more info.
« Last Edit: Dec 31st, 2012 at 6:11pm by ExhaultedRuler »  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #12 - Dec 31st, 2012 at 6:29pm
Post Tools
Thinking that it may be Active Perl, I installed the latest version 5.16.1.

No change Sad
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
ExhaultedRuler
Full Member
***
Offline



Posts: 164
Location: Honolulu, HI

None
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #13 - Dec 31st, 2012 at 9:26pm
Post Tools
Aiyah!!  After installing Perl 5.16.1, the YABB 2.1 & 2.4 boards no longer worked!!

We're back to 5.10.1
  

Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,388
Location: Earth

YaBB 2.6.1
Re: Admin Control Panel is accessible, but ADVANCE SETTINGS is not
Reply #14 - Dec 31st, 2012 at 10:17pm
Post Tools
Yeah - there's code in the older versions of YaBB that are deprecated in Perl 5.16, ActiveState 5.12 works okay with the older YaBB versions.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: [1] 2 3 4
Topic Tools
 
  « Board Index ‹ Board  ^Top