YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
YaBB SMTP Problems on IIS (Read 1,882 times)
 Jan 2nd, 2013 at 4:23am
There are no actions to perform.  

ExhaultedRuler 
Full Member
***
Offline
Posts: 164
Honolulu, HI


YaBB 2.5
YaBB SMTP Problems on IIS
There's another problem though...the YABB SMTP mailer doesn't work.  My 2 other boards work fine, just this 2.5.2 doesn't.

I'll start another thread tomorrow.
 
... Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
WWW irwin.santos.12  
IP Logged  
 Reply #1 - Jan 2nd, 2013 at 4:51am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,859
Earth


YaBB 2.5
Re: YaBB SMTP Problems on IIS
Except for the version numbers, Smtp.pl is the same for 2.4, 2.5AE, and 2.5.2.
 
WWW  
IP Logged  
 Reply #2 - Jan 2nd, 2013 at 5:40am
There are no actions to perform.  

westwegoman 
Ex Member
*


YaBB 2.5
Re: YaBB SMTP Problems on IIS
Dandello wrote on Jan 2nd, 2013 at 4:51am:
Except for the version numbers, Smtp.pl is the same for 2.4, 2.5AE, and 2.5.2.

I don't run a windoes server, so if i'm missing something... Forgive me but....

So far, I do not have problems with mail on my version of 2.5.2.

Edited:
Forgot to do a spell check Smiley
« Last Edit: Jan 2nd, 2013 at 6:07am by westwegoman »  
Never use both feet to test the depth of the water
 
IP Logged  
 Reply #3 - Jan 2nd, 2013 at 5:50am
There are no actions to perform.  

ExhaultedRuler 
Full Member
***
Offline
Posts: 164
Honolulu, HI


YaBB 2.5
Re: YaBB SMTP Problems on IIS
Dandello wrote on Jan 2nd, 2013 at 4:51am:
Except for the version numbers, Smtp.pl is the same for 2.4, 2.5AE, and 2.5.2.


The SMTP configuration in the 2.5.2 Advanced Settings is the same for for my 2.4 and 2.1 boards.

Sad

Another anomaly.  I'll go double check the permissions
 
... Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
WWW irwin.santos.12  
IP Logged  
 Reply #4 - Jan 2nd, 2013 at 6:20am
There are no actions to perform.  

ExhaultedRuler 
Full Member
***
Offline
Posts: 164
Honolulu, HI


YaBB 2.5
Re: YaBB SMTP Problems on IIS
The contents of Settings.pl is quite different from 2.1 and 2.5.2.

Meaning in 2.1

$smtp_server = "192.168.1.21";

...and in 2.5.2

$smtp_server = "192\.168\.1\.21";

was the above structure intentional?

My SMTP server IP within the LAN is 192.168.1.21
 
... Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
WWW irwin.santos.12  
IP Logged  
 Reply #5 - Jan 2nd, 2013 at 6:33am
There are no actions to perform.  

ExhaultedRuler 
Full Member
***
Offline
Posts: 164
Honolulu, HI


YaBB 2.5
Re: YaBB SMTP Problems on IIS
Here's something to add in.  At the bottom of this REPLY window, there is "Notify of replies:"  and the box is CHECKED, and the following line "Check thi sif you wish to be notified of replies to this topic."

I've never received an email notifying me of the update to this thread!!
 
... Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
WWW irwin.santos.12  
IP Logged  
 Reply #6 - Jan 2nd, 2013 at 6:34am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,859
Earth


YaBB 2.5
Re: YaBB SMTP Problems on IIS
You can try removing the slashes in that IP address in Settings.pl. - however, all they're doing is escaping the dots in the IP address. I'm just guessing, but I suppose IIS might have an issue with the escaping characters.

Edited:
As to the notices -  have you got 'Notify me of new Notifications by eMail?' set to 'yes' in your User CP?  Roll Eyes
 
« Last Edit: Jan 2nd, 2013 at 6:37am by Dandello »  
WWW  
IP Logged  
 Reply #7 - Jan 2nd, 2013 at 7:01am
There are no actions to perform.  

ExhaultedRuler 
Full Member
***
Offline
Posts: 164
Honolulu, HI


YaBB 2.5
Re: YaBB SMTP Problems on IIS
Dandello wrote on Jan 2nd, 2013 at 6:34am:
You can try removing the slashes in that IP address in Settings.pl. - however, all they're doing is escaping the dots in the IP address. I'm just guessing, but I suppose IIS might have an issue with the escaping characters.

Edited:
As to the notices -  have you got 'Notify me of new Notifications by eMail?' set to 'yes' in your User CP?  Roll Eyes
 


I've modified the Settings.pl as "192.168.1.21"

As for the notification, I didn't recall setting that to "no".  It's been awhile since I've visit the YABB forum...at least 3 years, up till now to troubleshoot my initial problem.  Anyway, I flipped it to "yes".
 
... Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
WWW irwin.santos.12  
IP Logged  
 Reply #8 - Jan 2nd, 2013 at 7:11am
There are no actions to perform.  

ExhaultedRuler 
Full Member
***
Offline
Posts: 164
Honolulu, HI


YaBB 2.5
Re: YaBB SMTP Problems on IIS
RESOLVED!!

In 2.1 & 2.4, this is selected:
YaBB SMTP Engine

In 2.5.2, I changed it to this:
Net::SMTP (Perl Module)

Perhaps somewhere in the 2.5.2 documentation you may mention this for those that are upgrading from earlier versions on IIS platform?
 
... Irwin's Superman Adventures Message Boards - Everything you ever wanted to know about the Hawaiian Superman!
WWW irwin.santos.12  
IP Logged  
 Reply #9 - Jan 2nd, 2013 at 9:41am
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,623
Land of the Blazing Sun!


None
Re: YaBB SMTP Problems on IIS
This Topic was moved here from Installation and Setup on Windows Servers by JonB.
 
I find your lack of faith disturbing.
 
IP Logged  
 Reply #10 - Jan 2nd, 2013 at 4:06pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,859
Earth


YaBB 2.5
Re: YaBB SMTP Problems on IIS
We still need to look at what's going on with Mailer.pl/Smtp.pl in 2.5.2/IIS as those files haven't changed since 2.4 and possibly before. (Which indicates the problem is either further 'upstream' or there's a configuration that's been missed.)

At least there are other options.  Wink
 
WWW  
IP Logged  
 Reply #11 - Jan 2nd, 2013 at 7:00pm
There are no actions to perform.  

Gomez Addams 
YaBB Newbie
*
Offline
Posts: 5


YaBB 2.5
Re: YaBB SMTP Problems on IIS
I'm not sure if this is the problem, but perl has an obscure feature  that will bite you if you try to put an IP address in a quoted string. See the "Version Strings" in perldata
 
 
IP Logged  
 Reply #12 - Jan 2nd, 2013 at 7:23pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,859
Earth


YaBB 2.5
Re: YaBB SMTP Problems on IIS
I suspect that the Version Number issue is why the IP addresses have escaped periods in them in the newer versions of Settings.pl.

But I'm not sure this is the issue here simply because smtp works for earlier YaBB versions on the same server - under ActiveState Perl 5.10.1 - and the earlier versions are using unescaped IP addresses.


 
WWW  
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.