YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
Forum suddenly not available (Read 1,000 times)
 Jan 7th, 2013 at 2:13pm
There are no actions to perform.  

Jkulin 
Junior Member
**
Offline
Posts: 59
Staffs. UK


None
Forum suddenly not available
Hi All,

I went to view the error log this morning and add some more IP addresses into the banned function and the server became unavailable with "The error we are experiencing is Apache Server at www.velonuts.co.uk Port 80"

After contacting webfusion asking for assistance, they suggested I talk to you and have provided the error log from their end.

Can any one suggest a remedy?

Many Thanks
 
error_log.txt (18 KB | 92 )
 
IP Logged  
 Reply #1 - Jan 7th, 2013 at 2:38pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,554
UK:Scotland/livingston


YaBB 2.5
Re: Forum suddenly not available
ok from what i can tell from the log is that the YaBB.pl is missing or that it dont have a CHMOD 755
Code Select All
File does not exist: /websites/LinuxPackage01/ve/lo/nu/velonuts.co.uk/public_html/cgi-bin/yabb2/yabb.pl 


i also tryed to load AdminIndex.pl and looks the same
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #2 - Jan 7th, 2013 at 2:51pm
There are no actions to perform.  

Jkulin 
Junior Member
**
Offline
Posts: 59
Staffs. UK


None
Re: Forum suddenly not available
Thanks,

How do you think they could have gone missing?

Do I just need to restore those two files? What files attributes do I need to reset on the files?

Thanks again.

 
 
IP Logged  
 Reply #3 - Jan 7th, 2013 at 3:00pm
There are no actions to perform.  

Jkulin 
Junior Member
**
Offline
Posts: 59
Staffs. UK


None
Re: Forum suddenly not available
Just checked and all the files exist with the correct attributes?
 
 
IP Logged  
 Reply #4 - Jan 7th, 2013 at 3:38pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,554
UK:Scotland/livingston


YaBB 2.5
Re: Forum suddenly not available
ok Quote:
I went to view the error log this morning and add some more IP addresses into the banned
did you enter any IP's into the ban list when this happend? can you send me ftp login info in a PM so i can take a look for you.
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #5 - Jan 7th, 2013 at 4:15pm
There are no actions to perform.  

Jkulin 
Junior Member
**
Offline
Posts: 59
Staffs. UK


None
Re: Forum suddenly not available
xnoddyx wrote on Jan 7th, 2013 at 3:38pm:
ok Quote:
I went to view the error log this morning and add some more IP addresses into the banned
did you enter any IP's into the ban list when this happend? can you send me ftp login info in a PM so i can take a look for you.


Yep, I had just entered some more IP addresses intot he banned list, it took a while to save, then came up with the error, so I wonder if the .htaccess file has become corrupt?

I've sent you the login data via PM.

Many Thanks.
 
 
IP Logged  
 Reply #6 - Jan 7th, 2013 at 4:48pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,554
UK:Scotland/livingston


YaBB 2.5
Re: Forum suddenly not available
Hi Jkulin ok that is you back up and running it was one of the items you had added to the ban list
Code Select All
\.\,\(91\.207\."; # IP banlist 

 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #7 - Jan 7th, 2013 at 9:51pm
There are no actions to perform.  

Jkulin 
Junior Member
**
Offline
Posts: 59
Staffs. UK


None
Re: Forum suddenly not available
Many Thanks xnoddyx, any ideas why that particular IP address should bring it down?

My IP address is totally different?
 
 
IP Logged  
 Reply #8 - Jan 7th, 2013 at 9:55pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,554
UK:Scotland/livingston


YaBB 2.5
Re: Forum suddenly not available
i don't know how it got there but it was the ( that stoped the forum from loading.
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #9 - Jan 7th, 2013 at 9:56pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online
Posts: 1,873
Earth


YaBB 2.5
Re: Forum suddenly not available
I can answer that - a badly conformed IP address will do bad things to Settings.pl. When that happens, Settings.pl will either not load or will load crap. Either way, the forum won't load because Settings.pl isn't  loading properly.

Edited:
And in this case a single parenthesis constitutes crap - Perl was looking for the mate and didn't find it so gave up.


« Last Edit: Jan 7th, 2013 at 9:58pm by Dandello »  
WWW  
IP Logged  
 Reply #10 - Jan 7th, 2013 at 9:56pm
There are no actions to perform.  

Jkulin 
Junior Member
**
Offline
Posts: 59
Staffs. UK


None
Re: Forum suddenly not available
Thanks, I need to watch that when copying and pasting too quickly.

I really appreciate your help.
 
 
IP Logged  
 Reply #11 - Jan 7th, 2013 at 10:29pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,554
UK:Scotland/livingston


YaBB 2.5
Re: Forum suddenly not available
Jkulin wrote on Jan 7th, 2013 at 9:56pm:
Thanks, I need to watch that when copying and pasting too quickly.

I really appreciate your help.

it's cool just glad to be of help and that your forum is up and running again  Grin
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.