YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 3 4 
Topic Tools
 
threads not updating (Read 6,205 times)
 Reply #45 - Jun 17th, 2013 at 11:11am
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
Quote:
Your server is not using Fastcgi at this time as it is using suphp. Also as Yabb is a perl script. We show no signs that mod_fcgid is causing an issue with the script. As by default the server is not configured to run perl scripts under fastcgi.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #46 - Aug 2nd, 2013 at 12:08am
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
I have discovered that you can bump the thread and then delete the extra posts. This appears to correct to the issue with the thread.

On another note, I am getting more complaints about the site being slow. However I am not sure how to interpret these as the site seems OK to me. Can anyone recommend a good ping tester or similar?

I am still planning on finding a new host when I get time.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #47 - Aug 2nd, 2013 at 12:47am
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: threads not updating
freediver wrote on Aug 2nd, 2013 at 12:08am:
ping tester

you can do that from the cmd on windows but for speed testing a website this is the item you are looking for is http://tools.pingdom.com it is best to run the test 3 - 4 times this is a website speed test you can also do the same from IE developer tools as well just now with http://tools.pingdom.com I get this for your forum
Quote:
http://www.ozpolitic.com/forum/Y…

Tested from New York City, New York, USA on August 2 at 01:32:46

Page size519.1kB Load time 2.25s Requests 104 Perf. grade 75/100 Your website is faster than 65% of all tested websites
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #48 - Aug 2nd, 2013 at 11:51am
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
Thanks. my site is down right now.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #49 - Aug 9th, 2013 at 9:18am
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
I leaned on hostgator a bit more and they seem to have fixed it. The error with the number of unread PMs has disappeared - no idea how, I did not do any maintenance. I am not aware of any remaining "thread not updating" issues and have asked the members to keep an eye out.

Some details below - they could not track to cause of the missing google ad code.



I noticed a couple of issues while investigating your VPS. Allow me to address them with you at this time.

1) The resolvers for the server that were set in your /etc/resolv.conf file were not correct for the network your server is hosted on. I have updated this file at this time.

root@web [/home/ozpolit]# diff /etc/resolv.conf{,.bak}
1,6c1,2
< options timeout:1
< options rotate
< nameserver 8.8.8.8
< nameserver 8.8.4.4
< nameserver 209.244.0.3
< nameserver 209.244.0.4
---
> nameserver 4.2.2.2
> nameserver 4.2.2.3
root@web [/home/ozpolit]#


2) I have optimized the Apache service on the server by adding the following to the apache configuration:
HostnameLookups off
KeepAlive On
KeepAliveTimeout 2
MaxKeepAliveRequests 102

ServerLimit 2
MaxClients 128
MinSpareThreads 64
MaxSpareThreads 128
ThreadLimit 64
ThreadsPerChild 64
ThreadStackSize 2097152
MaxRequestsPerChild 0

The biggest CPU usage comes from the following script on the server:
root@web [/home/ozpolit/public_html]# cat YaBB.pl
#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "
<p>
You have followed a broken link.
Please let the admin know where you followed this link from. We have been trying to track down the source of this error.
</p><p>
You can <a href=http://www.ozpolitic.com/contact.html>contact the admin here</a>, where you will also see a working link to our forum, if that's what you are looking for.
</p>
";root@web [/home/ozpolit/public_html]#

This appears to be called from errors caused by missing Googe Ads or other ad software on the page. Please see the attached screen shot for confirmation. If you require further assistance with this issue please let us know.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #50 - Aug 9th, 2013 at 1:56pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: threads not updating
Thanks for the update. Cool

Particularly when a YaBB forum suddenly has problems after it's been operating just fine, it seems that there is an issue with the host.

Your host seems to be very responsive. Smiley

 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #51 - Aug 9th, 2013 at 11:26pm
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
I had a "page not updating" problem reported this morning, then ran forum maintenance and that fixed it. I think that previously when I ran forum maintenance it did not make any difference.

I am paying US$110 per month at the moment for hosting, which I think should get me pretty good service.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #52 - Sep 8th, 2013 at 5:18am
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
I think we might be getting somewhere now:

Quote:
Reviewing the logs which I am only seeing a few time outs do to the following.

[Sat Sep 07 13:15:29 2013] [error] [client 157.56.93.187] (2)No such file or directory: unable to connect to cgi daemon after multiple tries: /home/ozpolit/public_html/forum/YaBB.pl
[Sat Sep 07 13:15:29 2013] [error] [client 5.10.83.58] (2)No such file or directory: unable to connect to cgi daemon after multiple tries: /home/ozpolit/public_html/forum/YaBB.pl
[Sat Sep 07 13:15:30 2013] [error] [client 199.16.186.98] (2)No such file or directory: unable to connect to cgi daemon after multiple tries: /home/ozpolit/public_html/forum/YaBB.pl
[Sat Sep 07 13:15:31 2013] [error] [client 66.249.74.191] (2)No such file or directory: unable to connect to cgi daemon after multiple tries: /home/ozpolit/public_html/forum/YaBB.pl

This is around the time that your server was under a large amount of requests. Which with a perl script it can time out if there is enough requests to the specific request in a fast amount of time, as the connection gets overloaded for the cgi daemon.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #53 - Sep 8th, 2013 at 7:15am
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
Hopefully this fixes it:

Quote:
You got that because the server was handling as many requests as it was set up to and new ones were timing out.

I have reviewed the load on your server at the time and determined that it is safe to increase the limits for httpd and cgi. I have increased these to allow more connections while still protecting the server stability. Please keep an eye on your server and let us know if you have any further issues.
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
 Reply #54 - Sep 8th, 2013 at 12:07pm
There are no actions to perform.  

freediver 
Senior Member
****
Offline
Posts: 515


None
Re: threads not updating
Does anyone understand this? I asked them how much they had increased the settings on the two occasions they changed them, and how much further I can go.

Quote:
Hello,

The settings that were raised are below, these settings can be raised to higher values, but the more httpd threads and cgi processes being spawned brings you closer to your memory limit. When that happens it is best to move up to a higher level VPS or Dedicated.

Thank you.

---------------------------------------------------------------
ServerLimit 4
MaxClients 256
MinSpareThreads 64
MaxSpareThreads 128
ThreadLimit 64
ThreadsPerChild 64
ThreadStackSize 2097152
MaxRequestsPerChild 0

<IfModule mod_fcgid.c>
FcgidMaxRequestLen 1073741824
FcgidIdleTimeout 360
FcgidBusyTimeout 180
FcgidProcessLifeTime 3600
FcgidMaxProcesses 64
</IfModule>
 
Founding member of .... I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
WWW  
IP Logged  
Pages: 1 2 3 4 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.