Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Untrapped Error (Read 1,726 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,202
Location: Earth

YaBB 2.6.0
Re: Untrapped Error
Reply #16 - Jan 23rd, 2013 at 11:10pm
Post Tools
I think we've seen this before.  Huh
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Untrapped Error
Reply #15 - Jan 23rd, 2013 at 11:21am
Post Tools
Quote:
Weird, weird, weird . . . . . . and weird again.

Decided to do a complete re-upload of all files and away she went. No errors.  All I can think is that there was a file corrupted on the first upload.

Thanks again

that's good to here Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Derek Bullock
Ex Member


Re: Untrapped Error
Reply #14 - Jan 23rd, 2013 at 7:28am
Post Tools
Weird, weird, weird . . . . . . and weird again.

Decided to do a complete re-upload of all files and away she went. No errors.  All I can think is that there was a file corrupted on the first upload.

Thanks again
  
Back to top
 
IP Logged
 
Derek Bullock
Ex Member


Re: Untrapped Error
Reply #13 - Jan 23rd, 2013 at 4:13am
Post Tools
By the way, thanks for everything so far Smiley
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,202
Location: Earth

YaBB 2.6.0
Re: Untrapped Error
Reply #12 - Jan 22nd, 2013 at 11:22pm
Post Tools
Quote:
Would it be clever to remove all of the banned data from the old Settings.pl


Removing the banned data from Settings.pl might be a good idea - there maybe some bad data hiding in there.

The extra lines in @ext_prof_fields is correct (at least it shouldn't hurt anything.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Derek Bullock
Ex Member


Re: Untrapped Error
Reply #11 - Jan 22nd, 2013 at 11:11pm
Post Tools
I found this oddity for extended profile fields.  Note all the spaces between (&).  Could this affect things???

Code
Select All
@ext_prof_fields = (

);                                                # Settings of the extendes profiles fields. 

  
Back to top
 
IP Logged
 
Derek Bullock
Ex Member


Re: Untrapped Error
Reply #10 - Jan 22nd, 2013 at 11:02pm
Post Tools
Been right through the old Settings.pl line for line and nothing like as suggested that I can find like this
Code
Select All
=
#"";
 



Here is the banlist area with all content removed so that looks ok
Code
Select All
$ip_banlist = ""; # IP banlist
$email_banlist = ""; # EMAIL banlist
$user_banlist = ""; # USER banlist 



Will have another look at it tonight, my time, and see what I can do.

This bugga ain't going to beat me Smiley

Would it be clever to remove all of the banned data from the old Settings.pl
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,202
Location: Earth

YaBB 2.6.0
Re: Untrapped Error
Reply #9 - Jan 22nd, 2013 at 10:26pm
Post Tools
If it's happening in more than one Admin screen then the problem is likely to be a glitch in Settings.pl. Open ./Variables/Settings.pl and make sure there's nothing like
Code
Select All
=
#""; 


happening.

One thing I've noticed is that if one line is glitched up, then glitch doesn't self-correct - it just gets worse. It's possible there is a glitchy line in the old Settings.pl that worked okay or was ignored in 2.4 and isn't being processed correctly when updated by the 2.5.2 NewSettings.pl. If it can be found and corrected, you may be okay.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Untrapped Error
Reply #8 - Jan 22nd, 2013 at 10:14pm
Post Tools
Quote:
Weird.  I have updated so many forums before but this is the first 2.5.2

As Tony said there were no mods.

I loaded everything in accordance with the Quick Guide.

I ran the all of the maintenance functions and everything looked good.  Went into the forum settings and every time I went to save a page I was logged off the forum and the error occurred and I couldn't get back in.

This also happened when changing either Security Settings or antispam settings.

Current 2.4 forum was working ok on 755 and 644 permissions.

I would have been using the old settings.pl as Quick Guide says to copy all variables files to new forum.

I am very patient so what to do next????

i dono on all tests and 1x to 2.5.2 and 2.5 to 2.5.2 also 2 2.4 to 2.5.2 i have never had a Untrapped Error :
can you have a look at the server logs and see if that has any more info in it
also if it is ok can i attempt the update for you.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Derek Bullock
Ex Member


Re: Untrapped Error
Reply #7 - Jan 22nd, 2013 at 9:32pm
Post Tools
Weird.  I have updated so many forums before but this is the first 2.5.2

As Tony said there were no mods.

I loaded everything in accordance with the Quick Guide.

I ran the all of the maintenance functions and everything looked good.  Went into the forum settings and every time I went to save a page I was logged off the forum and the error occurred and I couldn't get back in.

This also happened when changing either Security Settings or antispam settings.

Current 2.4 forum was working ok on 755 and 644 permissions.

I would have been using the old settings.pl as Quick Guide says to copy all variables files to new forum.

I am very patient so what to do next????
  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 3,790
Location: Land of the Blazing Sun!

YaBB 2.6.0
Re: Untrapped Error
Reply #6 - Jan 22nd, 2013 at 6:00pm
Post Tools
Xnoddyx is correct on the permissions issue.

For files in cgi-bin on Apache servers, you can look at it this way:

Only the Perl files (.pl) that have 'shebang lines' (the ones you have to edit) are actually directly executed. That's a '755'  permission - the owner can read, write and execute, everyone can read and execute.  The rest of the files can normally be '644' - Owner can read and write, everyone else read only.  The other files are actually 'read-in' as includes to extend the scripts that are executed. Smiley

http://www.webmasterworld.com/forum40/113.htm

http://www.onlineconversion.com/html_chmod_calculator.htm

The more restrictive you make the permissions, the more secure the installation.  Sometimes server configuration errors force more permissive settings such as '666' on 'read files', this or the need to set a file to '777' is an almost-for-sure sign the permissions of the logged in user that is maintaining YaBB are incorrect or that the Apache User and Group are wrong.

Wink
« Last Edit: Jan 22nd, 2013 at 6:17pm by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,202
Location: Earth

YaBB 2.6.0
Re: Untrapped Error
Reply #5 - Jan 22nd, 2013 at 4:37pm
Post Tools
The spoofing alert appears to come from the cookies  (possibly). The fix for Setup generally was to force a complete logout - but that doesn't seem to work properly in FixFile.

The untrapped error in Security.pl refers to a problem with reading usernames being used to register or login and comparing them to the banned list.

Which means there may be a problem in Settings.pl in the ban section.

Open Settings.pl and look for
Code
Select All
$ip_banlist = "";                                 # IP banlist
$email_banlist = "";                              # EMAIL banlist
$user_banlist = "";                        # USER banlist
 



That's what they're supposed to look like (with your banned strings inside the quotes), but chances are one or more of them looks something like
Code
Select All
$user_banlist =
#"";                                # USER banlist
 



Were you using your old Settings.pl?
« Last Edit: Jan 22nd, 2013 at 4:41pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
TonyL
Junior Member
**
Offline



Posts: 99
Location: Ontario, Canada

None
Re: Untrapped Error
Reply #4 - Jan 22nd, 2013 at 4:25pm
Post Tools
No mods on the 2.4 forum.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Untrapped Error
Reply #3 - Jan 22nd, 2013 at 3:14pm
Post Tools
i just ran a test on a small 2.4 forum i have with 408 Posts within 233 Topics and updated this to 2.5.2 with out any probs apart from i forgot to logout of the old forum first  Embarrassed so i got a ALERT!! Form Spoofing Detected coming from IP address:
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Untrapped Error
Reply #2 - Jan 22nd, 2013 at 2:22pm
Post Tools
Quote:
Guys

Just installed a 2.5.2 forum.  Set it all up, migrated the files.  Ran the maintenance functions and the forum logged me out. Went to log back in and get the following error

Quote:
Untrapped Error :
Quantifier follows nothing in regex; marked by <-- HERE in m/* <-- HERE .cn/ at ./Sources/Security.pl line 147.


Help!!!!!!!!!!!

was this update using the Convert dir or was it path to the 2.4 forum also
Edited:
sorry one of thows days where you have lots to do  Embarrassed

was it a moded 2.4? if it was what mods?

Edited:
Quote:
Why is there a significant difference between CHMOD on 2.5AE and 2.5.2. as seen in the Quick Guides.Just for instancecgi-bin/yabb2/Admin/* (all files)  In 2.5AE they are 755 and in 2.5.2 they are 644cgi-bin/yabb2/Sources/* (all files)  In 2.5AE they are 755 and in 2.5.2 they are 644Many others are different as well.


are now 644 as most files are loaded in by YaBB.pl or AdminIndex.pl so dont need to execute as YaBB.pl and AdminIndex.pl are the execute files in saying that /Sources/RSS.pl can be used outside of YaBB on its own so this can be set to 755 just remember to Check/Change the shebang on this if you use it as a standalone
« Last Edit: Jan 22nd, 2013 at 2:41pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top