YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 
Topic Tools
 
Where to put the link to favicon? (Read 10,056 times)
 Feb 7th, 2013 at 5:36pm
There are no actions to perform.  

Homer J. S. 
God Member
*****
Offline
Posts: 1,949
Germany


YaBB 2.5
Where to put the link to favicon?
I have a problem with Y2.5.2 and my favicon. I added the link to the favicon to the html file of my template.

The favicon is displayed - also in threads. But only if the url does not contain an anchor to an specific post. If the url contains a # the favicon is not displayed in the forum's tab for some reason (tried with different browsers).

How can that be? Do I have to put the favicon link somewhere else?

Examples...

Favicon visible:
http://www.retrogamerwelt.de/forum/YaBB.pl?num=1360253283

Favicon invisible (same thread with anchor to post #1):
http://www.retrogamerwelt.de/forum/YaBB.pl?num=1360253283/1#1
« Last Edit: Feb 7th, 2013 at 5:48pm by Homer J. S. »  
My Homer is not a communist. He may be a liar, a pig, an idiot, a communist, but he is not a porn star.

www.silenthill-forum.de (YaBB 1.3.1 with 150+ mods)
www.retrogamerwelt.de (YaBB 2.5.2)
WWW 87313348  
IP Logged  
 Reply #1 - Feb 7th, 2013 at 8:01pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: Where to put the link to favicon?
Add a 'base href' to your default.html header
Code Select All
<base href="http://retrogamerwelt.de/forum/YaBB.pl" /> 



At least that's what's in other software where the favicon works as you're expecting.
 
WWW  
IP Logged  
 Reply #2 - Feb 7th, 2013 at 8:37pm
There are no actions to perform.  

Homer J. S. 
God Member
*****
Offline
Posts: 1,949
Germany


YaBB 2.5
Re: Where to put the link to favicon?
Doesn't change anything.
 
My Homer is not a communist. He may be a liar, a pig, an idiot, a communist, but he is not a porn star.

www.silenthill-forum.de (YaBB 1.3.1 with 150+ mods)
www.retrogamerwelt.de (YaBB 2.5.2)
WWW 87313348  
IP Logged  
 Reply #3 - Feb 7th, 2013 at 8:49pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Where to put the link to favicon?
Homer J. S. wrote on Feb 7th, 2013 at 8:37pm:
Doesn't change anything.

? it is working for me  Wink see pic
 
iconshow.jpg (31 KB | 63 )
iconshow.jpg
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #4 - Feb 7th, 2013 at 11:01pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: Where to put the link to favicon?
For some browsers, once it's decided what the favicon is for a bookmark or site, it won't change without some work. (Firefox is notorious for that.)
 
WWW  
IP Logged  
 Reply #5 - Feb 8th, 2013 at 12:54am
There are no actions to perform.  
Derek Bullock 
Ex Member


None
Re: Where to put the link to favicon?
Dandello wrote on Feb 7th, 2013 at 8:01pm:
Add a 'base href' to your default.html header
Code Select All
<base href="http://retrogamerwelt.de/forum/YaBB.pl" /> 



At least that's what's in other software where the favicon works as you're expecting.


Thanks for that. My favicon has never worked properly on all pages.

Does now Smiley
 
 
IP Logged  
 Reply #6 - Feb 8th, 2013 at 3:19am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Where to put the link to favicon?
Homer J. S. wrote on Feb 7th, 2013 at 8:37pm:
Doesn't change anything.

Actually, if you follow Danello's instructions, your anchor to a specific post will resolve back to the main page of your forum, which of course isn't what you want to have happen. You'll want your anchor to stay anchored.

So
do not
use the following:


Code Select All
<base href="http://retrogamerwelt.de/forum/YaBB.pl" /> 


Test it out yourself to see what I mean. Wink

Disclaimer
: I tested this with the 2.4 version of YaBB.

Edited:
Also tested in YaBB 2.5 AE! with the same result (while using the latest version of Firefox).

« Last Edit: Feb 8th, 2013 at 3:41am by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #7 - Feb 8th, 2013 at 3:24am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Where to put the link to favicon?
Quote:
Thanks for that. My favicon has never worked properly on all pages.

Does now Smiley

My apologies for this double post, but you'll want to reverse Danello's instructions as soon as possible (see my previous post for the reason).

In case you're wondering, I just tested what happens in your forum. Your anchors no longer stay anchored, but they instead resolve to the main page of your forum.

Check it out yourself. Wink

Edited:
If it's any consolation, Internet Explorer works fine. It's Firefox that has the problem I've reported. Roll Eyes

Uh, oh! But then, your favicon doesn't always appear (mostly on, but sometimes off). Just the IE icon appears.

By the way, and I don't know if this is related or not, but you might want to make note that your "View the most recent posts on the forum" option is throwing up an error even from inside of your forum.

Oh yeah, a lof of forums including our own states, "View the most recent posts of this forum." Might that be your preference as well? I thought you should know in case you haven't noticed it.

Interestingly, this forum also has the grammar a bit off; the same as you have it.

BoardMod's forum and Carsten's forum have theirs listed correctly.


« Last Edit: Feb 8th, 2013 at 4:55am by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #8 - Feb 8th, 2013 at 5:33am
There are no actions to perform.  
Derek Bullock 
Ex Member


None
Re: Where to put the link to favicon?
Thanks for that
 
 
IP Logged  
 Reply #9 - Feb 8th, 2013 at 5:54am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: Where to put the link to favicon?
Obviously the forum that was using the base href attribute has something else going on as well - their favicons work right - but I can't see it in their code.
Edited:
Of course, you could do like some of us do - name the favicon 'favicon' and put it in the root. Which is where the browser is looking for it first.  Roll Eyes
« Last Edit: Feb 8th, 2013 at 6:03am by Dandello »  
WWW  
IP Logged  
 Reply #10 - Feb 8th, 2013 at 7:25am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Where to put the link to favicon?
Dandello wrote on Feb 8th, 2013 at 5:54am:
Of course, you could do like some of us do - name the favicon 'favicon' and put it in the root. Which is where the browser is looking for it first.  Roll Eyes

Right, and that's where it should be anyway. Reportedly, modern browsers don't need either of the following on any of your pages to find your favicon (I've kept both references on our site anyway):

Code Select All
<LINK REL="BOOKMARK ICON" HREF="http://www.YourSiteName.com/favicon.ico">

<LINK REL="SHORTCUT ICON" HREF="http://www.YourSiteName/favicon.ico">
 


However, if you don't reference this in your forum's template, your favicon won't show up. So in between <head> and </head> you need the following:

Code Select All
<LINK REL="SHORTCUT ICON" HREF="http://www.YourSiteName/favicon.ico">
 


That's why this forum's favicon doesn't show up in the forum.

Even then, your icon will disappear whenever you use an anchor in your address bar.

That's just the way it is. Roll Eyes

« Last Edit: Feb 8th, 2013 at 7:34am by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #11 - Feb 8th, 2013 at 7:33am
There are no actions to perform.  
Derek Bullock 
Ex Member


None
Re: Where to put the link to favicon?
 
 
IP Logged  
 Reply #12 - Feb 8th, 2013 at 7:37am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Where to put the link to favicon?
Quote:
No wonder our favicon disppeared from the address bar of Firefox. That is interesting. Smiley

 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #13 - Feb 8th, 2013 at 12:43pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Where to put the link to favicon?
there was one missed out for Firefox
Code Select All
<link rel="icon" href="animated_favicon.gif" type="image/gif" > 



after having a look at this

Quote:


and did a test it don't work now oh well and another one bites the dust.
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #14 - Feb 8th, 2013 at 1:48pm
There are no actions to perform.  

Homer J. S. 
God Member
*****
Offline
Posts: 1,949
Germany


YaBB 2.5
Re: Where to put the link to favicon?
Dandello wrote on Feb 8th, 2013 at 5:54am:
Of course, you could do like some of us do - name the favicon 'favicon' and put it in the root. Which is where the browser is looking for it first.  Roll Eyes


Well, that works if I put the icon into the first folder of the domain. But if I habe some other project some time which uses the same domain but not the same folder it won't work anymore. Because if I put the icon into the folder "forum" it's not recognized.

I'm still interested in WHY the icon does only work if the url has no anchor.
« Last Edit: Feb 8th, 2013 at 1:53pm by Homer J. S. »  
My Homer is not a communist. He may be a liar, a pig, an idiot, a communist, but he is not a porn star.

www.silenthill-forum.de (YaBB 1.3.1 with 150+ mods)
www.retrogamerwelt.de (YaBB 2.5.2)
WWW 87313348  
IP Logged  
Pages: 1 2 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.