Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) Where to put the link to favicon? (Read 825 times)
Derek Bullock
Ex Member


Re: Where to put the link to favicon?
Reply #8 - Feb 8th, 2013 at 5:33am
Post Tools
Thanks for that
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,618
Location: Los Angeles

YaBB 2.5
Re: Where to put the link to favicon?
Reply #7 - Feb 8th, 2013 at 3:24am
Post Tools
Quote:
Thanks for that. My favicon has never worked properly on all pages.

Does now Smiley

My apologies for this double post, but you'll want to reverse Danello's instructions as soon as possible (see my previous post for the reason).

In case you're wondering, I just tested what happens in your forum. Your anchors no longer stay anchored, but they instead resolve to the main page of your forum.

Check it out yourself. Wink

Edited:
If it's any consolation, Internet Explorer works fine. It's Firefox that has the problem I've reported. Roll Eyes

Uh, oh! But then, your favicon doesn't always appear (mostly on, but sometimes off). Just the IE icon appears.

By the way, and I don't know if this is related or not, but you might want to make note that your "View the most recent posts on the forum" option is throwing up an error even from inside of your forum.

Oh yeah, a lof of forums including our own states, "View the most recent posts of this forum." Might that be your preference as well? I thought you should know in case you haven't noticed it.

Interestingly, this forum also has the grammar a bit off; the same as you have it.

BoardMod's forum and Carsten's forum have theirs listed correctly.

« Last Edit: Feb 8th, 2013 at 4:55am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,618
Location: Los Angeles

YaBB 2.5
Re: Where to put the link to favicon?
Reply #6 - Feb 8th, 2013 at 3:19am
Post Tools
Homer J. S. wrote on Feb 7th, 2013 at 8:37pm:
Doesn't change anything.

Actually, if you follow Danello's instructions, your anchor to a specific post will resolve back to the main page of your forum, which of course isn't what you want to have happen. You'll want your anchor to stay anchored.

So do not use the following:

Code
Select All
<base href="http://retrogamerwelt.de/forum/YaBB.pl" /> 


Test it out yourself to see what I mean. Wink

Disclaimer: I tested this with the 2.4 version of YaBB.

Edited:
Also tested in YaBB 2.5 AE! with the same result (while using the latest version of Firefox).

« Last Edit: Feb 8th, 2013 at 3:41am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Derek Bullock
Ex Member


Re: Where to put the link to favicon?
Reply #5 - Feb 8th, 2013 at 12:54am
Post Tools
Dandello wrote on Feb 7th, 2013 at 8:01pm:
Add a 'base href' to your default.html header
Code
Select All
<base href="http://retrogamerwelt.de/forum/YaBB.pl" /> 



At least that's what's in other software where the favicon works as you're expecting.


Thanks for that. My favicon has never worked properly on all pages.

Does now Smiley
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,274
Location: Earth

YaBB 2.6.1
Re: Where to put the link to favicon?
Reply #4 - Feb 7th, 2013 at 11:01pm
Post Tools
For some browsers, once it's decided what the favicon is for a bookmark or site, it won't change without some work. (Firefox is notorious for that.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Where to put the link to favicon?
Reply #3 - Feb 7th, 2013 at 8:49pm
Post Tools
Homer J. S. wrote on Feb 7th, 2013 at 8:37pm:
Doesn't change anything.

? it is working for me  Wink see pic
  

iconshow.jpg ( 31 KB | 64 Downloads )
iconshow.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Homer J. S.
God Member
*****
Offline



Posts: 1,949
Location: Germany

None
Re: Where to put the link to favicon?
Reply #2 - Feb 7th, 2013 at 8:37pm
Post Tools
Doesn't change anything.
  

My Homer is not a communist. He may be a liar, a pig, an idiot, a communist, but he is not a porn star.
www.silenthill-forum.de (YaBB 1.3.1 with 150+ mods)
www.retrogamerwelt.de (YaBB 2.5.2)
Back to top
WWWICQ  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,274
Location: Earth

YaBB 2.6.1
Re: Where to put the link to favicon?
Reply #1 - Feb 7th, 2013 at 8:01pm
Post Tools
Add a 'base href' to your default.html header
Code
Select All
<base href="http://retrogamerwelt.de/forum/YaBB.pl" /> 



At least that's what's in other software where the favicon works as you're expecting.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Homer J. S.
God Member
*****
Offline



Posts: 1,949
Location: Germany

None
Where to put the link to favicon?
Feb 7th, 2013 at 5:36pm
Post Tools
I have a problem with Y2.5.2 and my favicon. I added the link to the favicon to the html file of my template.

The favicon is displayed - also in threads. But only if the url does not contain an anchor to an specific post. If the url contains a # the favicon is not displayed in the forum's tab for some reason (tried with different browsers).

How can that be? Do I have to put the favicon link somewhere else?

Examples...

Favicon visible:
http://www.retrogamerwelt.de/forum/YaBB.pl?num=1360253283

Favicon invisible (same thread with anchor to post #1):
http://www.retrogamerwelt.de/forum/YaBB.pl?num=1360253283/1#1
« Last Edit: Feb 7th, 2013 at 5:48pm by Homer J. S. »  

My Homer is not a communist. He may be a liar, a pig, an idiot, a communist, but he is not a porn star.
www.silenthill-forum.de (YaBB 1.3.1 with 150+ mods)
www.retrogamerwelt.de (YaBB 2.5.2)
Back to top
WWWICQ  
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools
 
  « Board Index ‹ Board  ^Top