YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
Crypt::SSLeay for Google Spell (Read 1,389 times)
 Feb 11th, 2013 at 6:55pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Crypt::SSLeay for Google Spell
Hi:  I asked my provider to install the Crypt::SSLeay module and they said they have placed it on the sever. However; the module check program in the Admin Centre (Yabb 2.4) doesn't see it.  See attachment.  I'm thinking he doesn't have it in the proper directory; but, am only guessing.  Jon or others, do you have any ideas I could pass on to the provider to get this working?

Thanks Bruce Hall
 
Modules.JPG (65 KB | 54 )
Modules.JPG
WWW  
IP Logged  
 Reply #1 - Feb 11th, 2013 at 7:51pm
There are no actions to perform.  

JonB 
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 3,617
Land of the Blazing Sun!


None
Re: Crypt::SSLeay for Google Spell
Hi -

I would agree with you (not in the right place).  That also surprises me, its pretty hard for a host/ISP to get Perl 'wrong' (could also be permissions maybe).

I would send the same info you attached here to their help desk.  I guess you could also ask "Okay, then WHERE did you put that module?"

If they can't fix, then we can go the 'roll your own' route using the ./Modules folder.  Gee, I have not done that in a loooong time...  Shocked

Good Luck
Cool
« Last Edit: Feb 11th, 2013 at 7:52pm by JonB »  
I find your lack of faith disturbing.
 
IP Logged  
 Reply #2 - Feb 12th, 2013 at 5:54pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
Well here's one for you Jon.  Crypt::SSLeay is now loaded and the Module Checker in Admin can see it.  I can now select GoogleSpell in the Admin, Forum Settings, Posting and the Google spelling icon along with the language selection is displayed while editing a message. The permissions are selected for 755.  The problem: Even if there are spelling mistakes, google speller comes back that everything is ok. Smiley  I'm running 2.4 with lots of mods.  is there a newer spellchecker.pl

Bruce
 
WWW  
IP Logged  
 Reply #3 - Feb 12th, 2013 at 6:08pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
greydane wrote on Feb 12th, 2013 at 5:54pm:
Well here's one for you Jon.  Crypt::SSLeay is now loaded and the Module Checker in Admin can see it.  I can now select GoogleSpell in the Admin, Forum Settings, Posting and the Google spelling icon along with the language selection is displayed while editing a message. The permissions are selected for 755.  The problem: Even if there are spelling mistakes, google speller comes back that everything is ok. Smiley  I'm running 2.4 with lots of mods.  is there a newer spellchecker.pl

Thanks Bruce


PS: I tried the SpellChecker.pl in yabb 2.52 and had the same results.  Shebang is ok also  #!/usr/bin/perl --
Problem with not seeing Crypt::SSLeay was a permissions issue.
 
WWW  
IP Logged  
 Reply #4 - Feb 12th, 2013 at 6:48pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online
Posts: 1,856
Earth


YaBB 2.5
Re: Crypt::SSLeay for Google Spell
That's the newest (only) version of SpellChecker - it calls on the database at GoogieSpell, so it's not an issue with the SpellChecker itself.

Let me do some other checking.

Edited:
Just Registered on your board for testing.

« Last Edit: Feb 12th, 2013 at 6:53pm by Dandello »  
WWW  
IP Logged  
 Reply #5 - Feb 12th, 2013 at 7:07pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
Yes, seen you. You have been activated. Smiley  If you require admin level I will PM. Thanks appreciate this.

Bruce
 
WWW  
IP Logged  
 Reply #6 - Feb 12th, 2013 at 7:47pm
There are no actions to perform.  

Derek Barnstorm 
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline
Posts: 1,269
United Kingdom


YaBB 2.5
Re: Crypt::SSLeay for Google Spell
I used to have exactly the same issue with my old host - modules were installed and everything appeared to work, but it wouldn't find any spelling errors. Before I was on support I asked the same question on more than one occasion myself, and nobody seemed to know. I also know that a few people had the same issue when it was still a mod, but there was never a solution for it. Unfortunately, I still don't know why.
 
 
IP Logged  
 Reply #7 - Feb 12th, 2013 at 8:09pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
Hi Derek:
 That's not a good sign.  The good thing, is I was just talking with the Provider and they stated, "They would keep working on the Issue until it was resolved."   Actually, it was the owner, a really nice guy.  So, any hints, recommendations, or logical guesses that I can pass on to the provider to take care of this will be appreciated.

Thanks Guys and Gals

Bruce
 
WWW  
IP Logged  
 Reply #8 - Feb 12th, 2013 at 8:50pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online
Posts: 1,856
Earth


YaBB 2.5
Re: Crypt::SSLeay for Google Spell
This is the response the javascript came back with
Code Select All
Can't verify SSL peers without knowing which Certificate Authorities to trust

This problem can be fixed by either setting the PERL_LWP_SSL_CA_FILE
envirionment variable or by installing the Mozilla::CA module.

To disable verification of SSL peers set the PERL_LWP_SSL_VERIFY_HOSTNAME
envirionment variable to 0.  If you do this you can't be sure that you
communicate with the expected peer. 



on the Testbed the same input brought back
Code Select All
<?xml version="1.0" encoding="UTF-8"?><spellresult error="0" clipped="0" charschecked="22"><c o="5" l="4" s="0">ta st	ta-st	taste	tasty	toast</c><c o="10" l="4" s="0">to st	to-st	toast	tots	tot</c></spellresult> 

(And a lot of javascript errors that don't appear to affect how SpellChecker works and which you wouldn't see except when doing diagnostics.)
 
WWW  
IP Logged  
 Reply #9 - Feb 12th, 2013 at 9:12pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
Hi Dandello:  Not sure I understand.
 The first is the error from my Site?
 The second is the correct response from your testbed?

 If true,  the the Provider has to set the PERL_LWP_SSL_CA_FILE envirionment variable to fix the problem?

Also, what did you use in Firefox to see that error?

Thanks Bruce
 
WWW  
IP Logged  
 Reply #10 - Feb 12th, 2013 at 9:30pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online
Posts: 1,856
Earth


YaBB 2.5
Re: Crypt::SSLeay for Google Spell
I have FireBug installed and had it running on the FireBug Console Screen setting with Persist turned on while clicking on SpellChecker.

Basically, there's something wrong with how your Server/site/SSL certificates identify themselves to GoogieSpell and it's rejecting the request to connect. Your hosting people should understand the message.

And yes, the first message came from your site.
« Last Edit: Feb 12th, 2013 at 9:32pm by Dandello »  
WWW  
IP Logged  
 Reply #11 - Feb 12th, 2013 at 11:42pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
Thank-you Dandello.  I appreciate all the help.  I've passed the information to my Provider and they will look at the problem tomorrow.

Bruce


 
WWW  
IP Logged  
 Reply #12 - Feb 15th, 2013 at 8:50pm
There are no actions to perform.  

greydane 
Junior Member
**
Offline
Posts: 61
Windsor, Nova Scotia


YaBB 2.4
Re: Crypt::SSLeay for Google Spell
Ok, everything is working great with Google Spell.  The Provider moved our Forum on to their new servers running the latest php and Apache software.Thanks Dandello, that was excellent information you gave me.  I'm going to start using firefox myself.  It really provides a lot of good data when running firebug.  In fact, without those errors, I believe this problem may have been a difficult one to resolve.

Thanks Again
Bruce
 
WWW  
IP Logged  
 Reply #13 - Feb 15th, 2013 at 11:09pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online
Posts: 1,856
Earth


YaBB 2.5
Re: Crypt::SSLeay for Google Spell
Excellent news.  Smiley
 
WWW  
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.