Page Index Toggle Pages: 1 [2] 
Topic Tools
Very Hot Topic (More than 25 Replies) SMTP error from remote mail server (Read 7,512 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,449
Location: Earth

YaBB 2.6.1
Re: SMTP error from remote mail server
Reply #15 - Feb 15th, 2013 at 12:07am
Post Tools
The fact the the 2.4 MailMembers.pl behaved the same as the 2.5AE version indicates the problem may not be specific to that file.

And since Bill has been operating a quite active forum, he is probably correct in noting that some major email servers simply won't take automated emails from YaBB.

As an experiment, maybe you could try using Admin/MailMembers.pl AND Sources/Mailer.pl from http://yabb.svn.sourceforge.net/viewvc/yabb/branches/2.5.2/cgi-bin/yabb2/. There are some bug fixes in both those and it's just possible the bug fix in Mailer.pl will do the trick. (Mailer is the script that formats all the automated emails.)

  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
forumguy99
Junior Member
**
Offline



Posts: 96
Re: SMTP error from remote mail server
Reply #16 - Feb 15th, 2013 at 4:31am
Post Tools
Thanks Dan. I tried it, but it didn't work. I checked returned e-mails (those working properly) from those registering, asking for passwords, and I noticed a difference. The return path says: Received: from mywebsitedomain.com
But the ones not being sent say...
Received: from myname by server.mywebsitedomain.com with local (Exim 4.80)
So in YaBB AE the "e-mail members" is being sent differently than from yabb 2.4

The Admin/MailMembers.pl AND Sources/Mailer.pl change didnt help. I'm wondering if I upgraded to 2.5.2 from 2.5.2AE it would be the same.
  
Back to top
 
IP Logged
 
forumguy99
Junior Member
**
Offline



Posts: 96
Re: SMTP error from remote mail server
Reply #17 - Feb 15th, 2013 at 4:38am
Post Tools
Also tried Admin/MailMembers.pl AND Sources/Mailer.pl from yann 2.4. Didnt help.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,449
Location: Earth

YaBB 2.6.1
Re: SMTP error from remote mail server
Reply #18 - Feb 15th, 2013 at 5:18am
Post Tools
try these files from 2.5.2 (the ones with the bug fixes). I'm guessing the problem may be with how the to/from information is sent. And that's in Mailer.pl


  

mailer252.zip ( 6 KB | 39 Downloads )

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,006
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: SMTP error from remote mail server
Reply #19 - Feb 15th, 2013 at 5:31am
Post Tools
I have been watching this. I need to see if I have not run into this last year when I updated a mailserver.  I had used a YaBB mail method that had worked fine on that server and forum. I did the update and the mailserver could not find the messages. In the end the mailserver folks could not help me, so I tinkered with YaBB's mail methods and how I referred to my local SMTP server. It was done because I wanted to make my server ready for roundmail and an IPv6 conversion possibly.

I'll look in the AM and see if I can find all the info/notes.

Good Luck
Wink

Edited:
OK _ found what I changed - I had been using the YaBB SMTP engine & 'localhost' - I changed to the Net::SMTP Perl Module & 127.0.0.1 and things went back to working.


« Last Edit: Feb 15th, 2013 at 5:35am by JonB »  

I find your lack of faith disturbing.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,449
Location: Earth

YaBB 2.6.1
Re: SMTP error from remote mail server
Reply #20 - Feb 15th, 2013 at 6:02am
Post Tools
What's boggling me is that apparently it sends mail through okay on singletons from Register but not through MailMembers. But MailMembers and Register simply send the message and the 'to' parameters to Mailer. Also, if it was sending email through properly in 2.4, those files haven't really changed. (The differences are style rather than substance.)  I would expect it to be an all or nothing situation, email gets sent through or it doesn't, not "if it's sent from this window it fails but not from this other one." (Unless Bill is right and multiple emails are coming in close together and being flagged as spam by these specific servers.)
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,715
Location: Los Angeles

YaBB 2.4
Re: SMTP error from remote mail server
Reply #21 - Feb 15th, 2013 at 7:18am
Post Tools
Dandello wrote on Feb 15th, 2013 at 6:02am:
Unless Bill is right and multiple emails are coming in close together and being flagged as spam by these specific servers.

To be clear, I'm just guessing this is what's happening, but it makes logical sense.

Both AOL and Yahoo have stringent anti-spam controls, so it's understandable that their email servers would block automated messages from our forum; from any forum really - not just from YaBB.

Think about it. If an admin sends all of their members a broadcast message, I can see how that can be considered as spam, and therefore blocked en masse.

I should qualify this by stating I never use our forum's "Email Your Members" option, so what I've explained, if accurate, doesn't apply to our forum. However, AOL and Yahoo may consider automated messages from forums to be spam even when a member requests the "Password Reset" option, or when they first register in the forum, and await their email confirmation with their pertinent message.

Obviously, when I send email to people on behalf of the domain our forum represents, that email is being sent through the ISP I use even when I use the same email address that our forum uses. Actually in our case for a variety of reasons, I use Gmail's outgoing mail server.

Our forum sends emails using the "Unix/Linus Sendmail" program.

In any case, any messages sent en masse no matter how they're sent can evidently be flagged as spam. This is probably what's going on, even as individual messages are evidently going through in your forum.

What to do?

Maybe your problem can be solved by doing what Jon did, i.e., he evidently "changed to the Net::SMTP Perl Module & 127.0.0.1 and things went back to working."

In other words, use your ISP's email server. But if you do, I would recommend using an email address specifically for your forum just in case it later gets flagged as spam. Or use Gmail's outgoing mail server (using a specific email address).

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
forumguy99
Junior Member
**
Offline



Posts: 96
Re: SMTP error from remote mail server
Reply #22 - Feb 15th, 2013 at 10:19pm
Post Tools
OMG! These companies should be sued! for blocking e-mails with their spam filters!
It looks like it was some kind of spam block. I changed the title of the e-mail. I was using [name] in the title so each member gets their name in the title. But then it worked with [name] with a new e-mail title. Then I put it back in with the orginal e-mail title and it didn't work. I changed (deleted) one word of the original e-mail title with [name] and the same body of the message and it worked! Guess what the word was blocked? "chat" as in chat members I had in the title. I ended up deleting a bunch of members thinking their e-mails were dead. These companies with their spam filters... stink!!!

  
Back to top
 
IP Logged
 
JonB
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 4,006
Location: Land of the Blazing Sun!

YaBB 2.6.1
Re: SMTP error from remote mail server
Reply #23 - Feb 15th, 2013 at 10:28pm
Post Tools
I'm very glad the problem is not YaBB

Grin
  

I find your lack of faith disturbing.
Back to top
IP Logged
 
forumguy99
Junior Member
**
Offline



Posts: 96
Re: SMTP error from remote mail server
Reply #24 - Feb 15th, 2013 at 10:51pm
Post Tools
Glad its not YaBB also. Thanks for all the help. Its ridiculous that they could so carelessly block a word even when it blocks legitimate e-mails. I even sent them a message and they didnt say why it was blocked but their standard help page for bulk senders. What do they think they have a spam file for? Yet my yahoo e-mail account gets many spam's every day. They should be able to block real spammers. Time, money, they dont care. Someone should sue them.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,449
Location: Earth

YaBB 2.6.1
Re: SMTP error from remote mail server
Reply #25 - Feb 15th, 2013 at 11:11pm
Post Tools
And I'm betting the difference between the 2.4 and 2.5AE emails was that one word. Shocked
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
forumguy99
Junior Member
**
Offline



Posts: 96
Re: SMTP error from remote mail server
Reply #26 - Feb 15th, 2013 at 11:15pm
Post Tools
Yep.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,715
Location: Los Angeles

YaBB 2.4
Re: SMTP error from remote mail server
Reply #27 - Feb 16th, 2013 at 12:02am
Post Tools
forumguy99 wrote on Feb 15th, 2013 at 10:19pm:
It looks like it was some kind of spam block. I changed the title of the e-mail. I was using [name] in the title so each member gets their name in the title. But then it worked with [name] with a new e-mail title.

Thank you very much for updating this issue. It helps a lot. I'm glad you got it straightened out; excellent! Smiley
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools
 
  « Board Index ‹ Board  ^Top