Page Index Toggle Pages: 1
Topic Tools
Normal Topic Problems registering (Read 3,691 times)
freediver
Senior Member
****
Offline



Posts: 521
Problems registering
Feb 26th, 2013 at 11:43am
Post Tools
Some people are having trouble registering on my forum. They get the following error message:

Quote:
System Information

Oops - we don't serve your kind here.


I think this is a custom error message I added a while back for spambots. Only problem is, I cannot find the text string for this anywhere. I cannot reproduce the error message. I have tried downloading all the code from the site and searching it, which didn't turn up anything. Of course this could be because windows 7 search was designed to be the most frustrating experience on earth. I have checked all the setting against these tips and they all seem to be correct.

http://windows.microsoft.com/en-US/windows7/Improve-Windows-searches-using-the-i...

Any suggestions?
« Last Edit: Feb 26th, 2013 at 11:44am by freediver »  

Founding member of . I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
Back to top
WWW  
IP Logged
 
Derek Barnstorm
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline



Posts: 1,269
Location: United Kingdom

None
Re: Problems registering
Reply #1 - Feb 26th, 2013 at 3:06pm
Post Tools
Hi,

freediver wrote on Feb 26th, 2013 at 11:43am:
Only problem is, I cannot find the text string for this anywhere.

Have you looked in Register.lng and Error.lng?
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,489
Location: Earth

YaBB 2.6.1
Re: Problems registering
Reply #2 - Feb 26th, 2013 at 3:33pm
Post Tools
That text string is in Error.lng and what's happening is that they're triggering the honeypot - probably through an autofill function in their browser. (Or the honeypot field in registration is not hidden through css as it should be but I think you'd see that.  Roll Eyes)

In Register.pl find the honeypot code you added and inside the
Code
Select All
<input type="text" 

section add
Code
Select All
autocomplete="off" 



That should stop the browser from auto-filling the input.

  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Problems registering
Reply #3 - Feb 26th, 2013 at 3:36pm
Post Tools
i tryed registering on your forum trying some errors out but did not get that one.
but i did find that you are missing http://www.ozpolitic.com/yabbfiles/Templates/Forum/brown/check.png
from the reg screen. also if you want i can have a look at your files to see where the error message is in. or you can do
freediver wrote on Feb 26th, 2013 at 11:43am:
I have tried downloading all the code from the site and searching it, which didn't turn up anything. Of course this could be because windows 7 search was designed to be the most frustrating experience on earth. I have checked all the setting against these tips and they all seem to be correct.http://windows.microsoft.com/en-US/windows7/Improve-Windows-searches-using-the-i... suggestions?

as for windows 7 search the default don't find items like the old search in xp you will have to edit some settings for that goto computer open it up then hit the Alt key then click on Tools > Folder Options > then click on the Search tab in (What to search) check Always search file names and contents. can tame more time on searches

next (How to search) check box 1, 2, 4 and uncheck box 3

next check all boxs in (When searching non-indexed locations)

then click Apply then ok more to edit now for the last part
goto Start and find the Search box enter search then look for Change How Windows Searches click on this then Click the Advanced button just below the list of indexed locations now click on the File Types tab then in the Add new extension to list add lng if it is in the list it will jump to it and then set it to
check (Index Properties and File Contents)
and do this for some more of the yabb file extensions and windows 7 search will work more or less like xp search now.

or you have FileSearchEX here http://goffconcepts.com/products/filesearchex/
this will work just like like xp search but in win 7 as well  Wink but you will have to add yabb file extensions to it's look inside of files list.


Edited:
i was taking that long to post you two got it before me  Grin
« Last Edit: Feb 26th, 2013 at 3:42pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,489
Location: Earth

YaBB 2.6.1
Re: Problems registering
Reply #4 - Feb 26th, 2013 at 4:17pm
Post Tools
I should add - if the last two characters in the names of these people who can't register are random and capitalized - those are spammers and you don't want them anyway.  Roll Eyes

But make sure the 'autocomplete="off"' is inside the honeypot form field and that should fix it for real people.
« Last Edit: Feb 26th, 2013 at 4:19pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
freediver
Senior Member
****
Offline



Posts: 521
Re: Problems registering
Reply #5 - Mar 2nd, 2013 at 4:49am
Post Tools
Thanks for the tips everyone.

1) I have made the change to register.pl - no way of telling whether this works, but I have checked that it is not broken at least.

2) I have copied check.png into the brown folder. I am a bit confused about this. I thought that the software automatically checks in the default folder if it can't find an image in the specified template folder. I actually have very few images in the brown folder - most of them are only in default. I think I started a thread about this a while back.

3) I finally got search working on my computer. Thanks for the detailed instructions x. It always surprises me how badly microsoft can stuff up the simple things. I couldn't find that info via google either.
  

Founding member of . I recently upgraded from YaBB 2.2.1 to 2.5 AE to 2.5.2.
Back to top
WWW  
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: Problems registering
Reply #6 - Mar 2nd, 2013 at 3:54pm
Post Tools
freediver wrote on Mar 2nd, 2013 at 4:49am:
2) I have copied check.png into the brown folder. I am a bit confused about this. I thought that the software automatically checks in the default folder if it can't find an image in the specified template folder. I actually have very few images in the brown folder - most of them are only in default. I think I started a thread about this a while back.

it is supposed to it is on my list of to look at to see why it don't work sometimes.

freediver wrote on Mar 2nd, 2013 at 4:49am:
3) I finally got search working on my computer. Thanks for the detailed instructions x. It always surprises me how badly microsoft can stuff up the simple things. I couldn't find that info via google either.

yes they are good at that i don't see what was wrong with the search on xp to me all it was needing was a update not a whole new search system that works like a man in a blindfolded in a darkened room looking for a black box, but the search part aside from it i like win 7 just don't ask me what i think of vista or win 8 let's just say it needs a bin lol.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools