YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 
Topic Tools
 
Setup fails (Read 2,664 times)
 Mar 4th, 2013 at 4:35pm
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Setup fails
I am trying to update my forum and have moved the old one out of the way ready to install the new one. Everything is in place and CHModed, but when I run Setup.pl I get his error:

Can't locate ./Sources/Subs.pl in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 . /etc/httpd ./Modules) at /var/www/vhosts/scalesoaring.co.uk/httpdocs/yabb/yabb2/Setup.pl line 69

Sources is there and the associated Subs.pl

For your consideration, This is a slightly non standard installation with an alias from my servers 'built-in' cgi-bin pointing to the yabb2 folder in my site which worked with the previous forum
 
 
IP Logged  
 Reply #1 - Mar 4th, 2013 at 5:17pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Setup fails
VinceC wrote on Mar 4th, 2013 at 4:35pm:
alias

sorry i need the full path ok when you say alias is that
/var/www/vhosts/scalesoaring.co.uk/cgi-bin/yabb/yabb2 so on url it shows as scalesoaring.co.uk/cgi-bin/yabb/yabb2 and yabbfiles is scalesoaring.co.uk/httpdocs/yabbfiles/ that loads as scalesoaring.co.uk/yabbfiles/

what is the full path to the alias dir what is the alias name that it resolves to is it the dir name of cgi-bin

you can also look in the old forums Paths.pl and this may give you the answer also at the same time this may just be down to CHMOD permissions as well

if you want i can also have a look for you if you pm me ftp login info.
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #2 - Mar 4th, 2013 at 9:22pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Setup fails
thats your new forum up and running it was just a standard installation i did use the most up to date version of YaBB 2.5.2 from the svn for you that is here http://yabb.svn.sourceforge.net/viewvc/yabb/branches/2.5.2/
but your forum is ready for you  Smiley
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #3 - Mar 4th, 2013 at 10:20pm
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
Thanks a bunch xnoddyx, great work.

I see you put it in the earlier CGI bin where the alias was. I take it I just need to copy the data folders across to complete, is this correct?
 
 
IP Logged  
 Reply #4 - Mar 4th, 2013 at 10:30pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Setup fails
VinceC wrote on Mar 4th, 2013 at 10:20pm:
Thanks a bunch xnoddyx, great work.

I see you put it in the earlier CGI bin where the alias was. I take it I just need to copy the data folders across to complete, is this correct?

i thought that was what you was wanting give me a min and i will test to see if you can run .pl in a dir in the root for you

Edited:
yes you can so do you want the dir to be yabb or yabb2 or forum
« Last Edit: Mar 4th, 2013 at 10:32pm by xnoddyx »  
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #5 - Mar 4th, 2013 at 10:36pm
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
This was the old access address. If that can be used it would help peolple get back on-line quicker

http://scalesoaring.co.uk/cgi-bin/yabb/yabb2/YaBB.pl
 
 
IP Logged  
 Reply #6 - Mar 4th, 2013 at 11:25pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Setup fails
ok on your cgi-bin when i go to make a dir yabb i get a ftp error 550 yabb: File exists when i make yabb1 then goto rename it to yabb i get error 550 Rename yabb: Not a directory so i am thinking in /var/www/vhosts/scalesoaring.co.uk/cgi-bin/ that there is a dir with the name yabb but is owned by someone else or the main account owner and set so that i can't edit it or see it if you login with ftp can you see any file or dir with the name yabb
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #7 - Mar 4th, 2013 at 11:30pm
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
There was a folder in there called yabb, but it always showed an error when I tried to access it. Now I see yabb as an alias fold, yabb1 and yabb2
 
 
IP Logged  
 Reply #8 - Mar 4th, 2013 at 11:32pm
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
I have transferred my files over to the new board
 
 
IP Logged  
 Reply #9 - Mar 5th, 2013 at 12:17am
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
yabb is owned by 'root' and I cannot change it. Have you quit for the nigh?
 
 
IP Logged  
 Reply #10 - Mar 5th, 2013 at 4:55am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Setup fails
Please excuse me for the interruption, but in case you didn't know it, your YaBB forum is still in maintenance mode. I've mentioned this in case it wasn't intentional.

Edited:

Ah, but as of this edit your forum's bringing up a 404 error.

VinceC wrote on Mar 5th, 2013 at 6:47am:
Here we are in the morning to finalise it.

Got it. Good luck! Wink


« Last Edit: Mar 5th, 2013 at 7:50am by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #11 - Mar 5th, 2013 at 6:47am
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
Thanks Bill. I left it in that state before I went to bed. Here we are in the morning to finalise it.
 
 
IP Logged  
 Reply #12 - Mar 5th, 2013 at 7:52am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Setup fails
Got it. Good luck! Wink
 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #13 - Mar 5th, 2013 at 9:54am
There are no actions to perform.  

VinceC 
Junior Member
**
Offline
Posts: 60


None
Re: Setup fails
Bill - The new location is

http://scalesoaring.co.uk/cgi-bin/yabb2/YaBB.pl

although there are a few tiny problems to resolve
 
 
IP Logged  
 Reply #14 - Mar 5th, 2013 at 2:10pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Success! - Re: Setup fails
Your forum looks fabulous; great job! Smiley

Among the "few tiny problems to resolve" ... one that can be easily fixed ... is editing the tab forum link on the 1st page of your site so that people will go to your forum when they click that link.

Oh yeah, and fixing the link for your banner ... I'm guessing you'll want it go to the 1st page of your site. As of this post, it's linked to this forum.

« Last Edit: Mar 5th, 2013 at 2:16pm by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
Pages: 1 2 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.