YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
Anti-Spam Questions - blank field (Read 2,419 times)
 Mar 6th, 2013 at 11:45am
There are no actions to perform.  

Imp_In_Training 
Junior Member
**
Offline
Posts: 91


None
Anti-Spam Questions - blank field
When Anti-spam questions are enabled for registrations, it spits out two questions at the end of the registration form.  The first one is derived from the list in the Admin section.  The second one is just a randomized personal question like 'occupation?' or 'zip code?'.

My problem is with the second question.  One of the questions has no prompt, just an empty field.  Is it supposed to be this way or is there something missing somewhere?  None of these questions seem to have anything to do with my user profile information (excluding location), so I'm thinking they're in some .pl file or a variable somewhere that can be easily edited.
 
Capture_005.JPG (68 KB | 97 )
Capture_005.JPG
 
IP Logged  
 Reply #1 - Mar 6th, 2013 at 3:52pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,861
Earth


YaBB 2.5
Re: Anti-Spam Questions - blank field
That field is the honeypot and isn't even supposed to show on the screen - it's supposed to be hidden through css.

If you upgraded from an earlier version of YaBB did you add
Code Select All
.green {display:none;} 

 to your style sheet?
« Last Edit: Mar 6th, 2013 at 3:52pm by Dandello »  
WWW  
IP Logged  
 Reply #2 - Mar 6th, 2013 at 4:30pm
There are no actions to perform.  

Derek Barnstorm 
Support Team
YaBB Next Team
Development Team
Beta Testers
****
Offline
Posts: 1,269
United Kingdom


YaBB 2.5
Re: Anti-Spam Questions - blank field
I'm getting a malware warning when clicking on that attachment...
 
 
IP Logged  
 Reply #3 - Mar 6th, 2013 at 7:07pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,861
Earth


YaBB 2.5
Re: Anti-Spam Questions - blank field
And I'm getting a corrupt greybox image file warning
 
WWW  
IP Logged  
 Reply #4 - Mar 6th, 2013 at 7:45pm
There are no actions to perform.  

Imp_In_Training 
Junior Member
**
Offline
Posts: 91


None
Re: Anti-Spam Questions - blank field
What the heck is a honeypot?  Do I look like pooh-bear?

Wait, so you're saying that second question shouldn't even be showing up?  Why would a field with questions like "What is your occupation?" "What is your Zip Code?" etc. be hidden?  It is pointless code if that's the case, just taking up space.

It was a fresh install of YaBB 2.5.2, so no upgrade.  However, another moderator has been working with our default template so it's hard to say if that was added to the CSS.  If it was, I have no idea why it would have been.

The attachment is a .jpg ... hard to believe it could be seen as malware.  Maybe whatever program you have by default opening jpg files is malware.  I'm not getting any such alerts.

Now ... corrupt greybox, if you're talking about the beta site, I suppose that is possible.  I might have uploaded in the wrong format.  But I haven't seen any errors when I access the forum.  Where does the corrupt greybox image file warning show up?  Would that cause the problem?
 
 
IP Logged  
 Reply #5 - Mar 6th, 2013 at 8:02pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,861
Earth


YaBB 2.5
Re: Anti-Spam Questions - blank field
The honeypot catches spambots - they will fill in that part of the form but human users won't fill in because they shouldn't see it - only the spambots see it.

And the corrupted image issue isn't with your attachment. It's an issue here.
 
WWW  
IP Logged  
 Reply #6 - Mar 7th, 2013 at 10:47am
There are no actions to perform.  

Imp_In_Training 
Junior Member
**
Offline
Posts: 91


None
Re: Anti-Spam Questions - blank field
Ok... thanks for the explanation.

So the problem seems to be something in the template then?  It's entirely possible.  What we are doing is using a fresh install YaBB and trying to bring as much of our old template in to give it the same feel.  They might have copied source code that crippled the invisibility of the honeypot.
 
 
IP Logged  
 Reply #7 - Mar 7th, 2013 at 12:02pm
There are no actions to perform.  

Imp_In_Training 
Junior Member
**
Offline
Posts: 91


None
Re: Anti-Spam Questions - blank field
Ok... cool... adding that code to the style sheet works.  I was just trying to wrap my head around the issue.  Now I understand.  Thanks so much.

BTW - the template I used was BlackNoir - available at BoardMod 2.5 templates... that's where the code is missing from the stylesheet.  I checked that template as well as the one we've been tinkering with.  They both have issues.  I'll leave a message at BoardMod on that thread so they know.
 
 
IP Logged  
 Reply #8 - Mar 7th, 2013 at 2:26pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Anti-Spam Questions - blank field
Imp_In_Training wrote on Mar 7th, 2013 at 12:02pm:
Ok... cool... adding that code to the style sheet works.  I was just trying to wrap my head around the issue.  Now I understand.  Thanks so much.

BTW - the template I used was BlackNoir - available at BoardMod 2.5 templates... that's where the code is missing from the stylesheet.  I checked that template as well as the one we've been tinkering with.  They both have issues.  I'll leave a message at BoardMod on that thread so they know.

this info is in the YaBB 252 Quick-Guide that was in the YaBB 2.5.2 download
see http://testbed.dandello.net/Quick-Guide_252/English/extras/upgradeY24.php
Quote:
◦If you have any special template files, you may wish to upload those files also, but they may need some modification before they will work properly with YaBB 2.5.2.
The honeypot anti-spam feature requires
.green {
display:none;
}
be added to the template/css file. If you have a preexisting class with that name, it will need to be renamed. Custom 2.5AE Templates should need no other editing. Do not add this class to the Admin/default.css.
2.4 Templates. As with the 2.5AE stylesheet, the 'green' class must be added to any forum stylesheets. In addition, in ./Templates/default.html, the tag {yabb syntax_js} must be added immediately beneath {yabb style} to allow for additional display functions within the [code] tag.

as the BlackNoir template is for 2.5AE not 2.5.2.
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
 Reply #9 - Mar 10th, 2013 at 11:00pm
There are no actions to perform.  

Imp_In_Training 
Junior Member
**
Offline
Posts: 91


None
Re: Anti-Spam Questions - blank field
Yeah... they don't have a YaBB 2.5.2 template section, I just assumed they were close enough and that some sort of special actions to make templates work right might be a major change, thus requiring a step from 2.4 to 2.5.  

Still learning... thanks again.
 
 
IP Logged  
 Reply #10 - Mar 13th, 2013 at 11:31pm
There are no actions to perform.  

xnoddyx 
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline
Posts: 1,552
UK:Scotland/livingston


YaBB 2.5
Re: Anti-Spam Questions - blank field
Imp_In_Training wrote on Mar 10th, 2013 at 11:00pm:
Yeah... they don't have a YaBB 2.5.2 template section, I just assumed they were close enough and that some sort of special actions to make templates work right might be a major change, thus requiring a step from 2.4 to 2.5.  

Still learning... thanks again.

it's cool also most of the mods for 2.5 also work on 2.5.2 with some edits you may also want to check out Carsten's YaBB Mod Forum here http://www.carsten-dalgaard.dk/cgi-bin/yabb2/YaBB.pl he is having some hosting issues just now so the forum may 404 or a 5xx error on you and hopes to have it fixed soon.
 
YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
WWW xnoddyx xnoddyx1  
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.