Page Index Toggle Pages: 1
Topic Tools
Normal Topic When attaching attachments and download avatar Error 500 (Read 1,299 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,169
Location: Earth

YaBB 2.6.0
Re: When attaching attachments and download avatar Error 500
Reply #9 - Mar 10th, 2013 at 4:22am
Post Tools
Excellent.  Smiley
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Scorpion65
YaBB Newcomer
*
Offline



Posts: 19

YaBB 2.5.2
Re: When attaching attachments and download avatar Error 500
Reply #8 - Mar 10th, 2013 at 12:07am
Post Tools
Dandello wrote on Mar 9th, 2013 at 9:42pm:
And this was brought to my attention by a very nice person: http://www.carsten-dalgaard.dk/cgi-bin/yabb2/YaBB.pl?num=1267043548

Big, big thanks for the link, it is the one to solve the problem happened  Smiley Smiley
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,169
Location: Earth

YaBB 2.6.0
Re: When attaching attachments and download avatar Error 500
Reply #7 - Mar 9th, 2013 at 9:42pm
Post Tools
And this was brought to my attention by a very nice person: http://www.carsten-dalgaard.dk/cgi-bin/yabb2/YaBB.pl?num=1267043548
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,169
Location: Earth

YaBB 2.6.0
Re: When attaching attachments and download avatar Error 500
Reply #6 - Mar 9th, 2013 at 8:03pm
Post Tools
Drop xnoddyx a PM with your site particulars. He's very good with these sorts of issues.

Avatars and attachments are handled by different scripts, so if they're both acting up, chances are it isn't the scripts. I don't know about 2.3 but in newer versions of YaBB attachments are uploaded through 'Post.pl' and avatars are handled through 'Profile.pl'. What they do have in common is that both attachments and avatars are stored in yabbfiles outside of the cgi-bin.

It is possible that your new server configuration is not allowing files to be written outside of the cgi-bin. (I do have experience with one client that has this issue with his hosting service.)

One test - try to edit your css file via the admin center. If that throws an error or fails to save the file, then it's a server configuration issue that's keeping YaBB from writing to those folders.


  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Scorpion65
YaBB Newcomer
*
Offline



Posts: 19

YaBB 2.5.2
Re: When attaching attachments and download avatar Error 500
Reply #5 - Mar 9th, 2013 at 5:52pm
Post Tools
Now try to do the following sub-folders of the main forum made subfolders test forum, checked online test script is loaded everything is fine, then damaged the main forum script code that is responsible for downloading attachments and avatars. Please tell me where is the code which files to check?
  
Back to top
 
IP Logged
 
Scorpion65
YaBB Newcomer
*
Offline



Posts: 19

YaBB 2.5.2
Re: When attaching attachments and download avatar Error 500
Reply #4 - Mar 9th, 2013 at 4:25pm
Post Tools
and what is strange, I have the same test is hosting a forum Powered YaBB 2.2.3 and it all works without problems, but on the main forum experience this, what do you do?
  
Back to top
 
IP Logged
 
Scorpion65
YaBB Newcomer
*
Offline



Posts: 19

YaBB 2.5.2
Re: When attaching attachments and download avatar Error 500
Reply #3 - Mar 9th, 2013 at 4:19pm
Post Tools
In these folders are 777 CHMODed
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,169
Location: Earth

YaBB 2.6.0
Re: When attaching attachments and download avatar Error 500
Reply #2 - Mar 9th, 2013 at 4:13pm
Post Tools
Make sure the permissions on the yabbfiles folder (the one NOT in the cgi-bin), the avatar folder and all its sub folders and the attachments folder are all CHMODed to 755. If that doesn't work, try 766. If you need to use 777 on those folders, somebody goofed during the upgrade.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Scorpion65
YaBB Newcomer
*
Offline



Posts: 19

YaBB 2.5.2
When attaching attachments and upload avatar Error 500
Reply #1 - Mar 9th, 2013 at 4:00pm
Post Tools
Hello,
Powered Yabb 2.3.1, Forum worked for several years with no problems after the upgrade version of Apache to 22 following problem: Stopped attachments to messages and upload avatars, with these actions, users get an error. How can I fix it?
  

screen1_002.jpg ( 35 KB | 65 Downloads )
screen1_002.jpg
Back to top
 
IP Logged
 
Scorpion65
YaBB Newcomer
*
Offline



Posts: 19

YaBB 2.5.2
When attaching attachments and download avatar Error 500
Mar 9th, 2013 at 3:58pm
Post Tools
Hello,
Powered Yabb 2.3.1, Forum worked for several years with no problems after the upgrade version of Apache to 22 following problem: Stopped attachments to messages and upload avatars, with these actions, users get an error. How can I fix it?
  

screen1_001.jpg ( 35 KB | 55 Downloads )
screen1_001.jpg
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top