Page Index Toggle Pages: 1
Topic Tools
Normal Topic Boards empty after different Rebuilds (Read 1,459 times)
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,629
Location: Los Angeles

YaBB 2.5
Re: Boards empty after different Rebuilds
Reply #8 - Mar 17th, 2013 at 6:55pm
Post Tools
Thanks for letting us know how you solved it; very helpful.

Regarding backups, I know from experience that I keep more than I need for our forum, but I like to have them for "just in case scenarios," so I usually keep 4-5 backups at any given time (each one newer as the forum is backed up).

I currently have 11 backups not including a 12th one that's being backed up while I'm typing this post ... should delete a few of those older backups.

So far at least, I don't remember needing to retrieve any more than the 2nd oldest backup, so again, I have more backups than I need. One of the reasons for me doing this is that I know there are times when I surely must be backing up corrupted files from time to time, so obviously, those files won't do me any good.

One thing I often forget about is to regularly back up our yabbfiles folder because it's not in the cgi-bin folder. But then, our server automatically backs up each and every domain on it every single day, so I guess it's not that big of a deal. Still, having local backups are very convenient if or when they're needed.

Well ... okay, so here I go after this post, backing up a local copy of that yabbfiles folder just because you got me thinking about it. Roll Eyes

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
HaCo
YaBB Newcomer
*
Offline



Posts: 5

YaBB 2.6.0
Re: Boards empty after different Rebuilds
Reply #7 - Mar 17th, 2013 at 6:32pm
Post Tools
Thanks  Cheesy

How I solved it:
- Opened the textfile on the FTP server and deleted the wrong line in it 'ex-member'.
- Opened the thread with the id of the text-file.
- Moved the thread to it's original subject where it appears again.


A big 'oooof'. I had no backups or anything, backing up as we speak Smiley
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,629
Location: Los Angeles

YaBB 2.5
Solved! - Re: Boards empty after different Rebuilds
Reply #6 - Mar 17th, 2013 at 6:22pm
Post Tools
So I'll presume you're all good again. Cool

You're a very attentive webmaster, and obviously a problem solver. Way to go! Smiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
HaCo
YaBB Newcomer
*
Offline



Posts: 5

YaBB 2.6.0
Re: Boards empty after different Rebuilds
Reply #5 - Mar 17th, 2013 at 6:18pm
Post Tools
I have found the textfile (and thus the number) of the thread.
  
Back to top
 
IP Logged
 
HaCo
YaBB Newcomer
*
Offline



Posts: 5

YaBB 2.6.0
Re: Boards empty after different Rebuilds
Reply #4 - Mar 17th, 2013 at 6:11pm
Post Tools
One thread seems to be missing, the one with the post from the 'ex-member'.

Is there a way to recover it?
« Last Edit: Mar 17th, 2013 at 6:12pm by HaCo »  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,629
Location: Los Angeles

YaBB 2.5
Re: Boards empty after different Rebuilds
Reply #3 - Mar 17th, 2013 at 6:07pm
Post Tools
Thank for letting us know. I'm glad you got it figured out, and all on your own, too. Smiley

This is something that commonly happens. Happily as you already knew to do, this kind of problem can be fixed. It's good to see your forum operational again, and no longer in maintenance mode.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
HaCo
YaBB Newcomer
*
Offline



Posts: 5

YaBB 2.6.0
Re: Boards empty after different Rebuilds
Reply #2 - Mar 17th, 2013 at 5:42pm
Post Tools
I was indeed out of space and was working on it before your reply. And now rebuild again and... solved!

Thanks, very usefull!
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,629
Location: Los Angeles

YaBB 2.5
Re: Boards empty after different Rebuilds
Reply #1 - Mar 17th, 2013 at 5:33pm
Post Tools
HaCo wrote on Mar 17th, 2013 at 4:43pm:
So, what can I do from here?

It seems to me that you may have run out of room on your server; or close to it. A lot of times this happens when automated backups of a forum or the site itself adds one backup after another until there's not enough room on the server.

Suggestion: FTP into your server to see if you have multiple backups. If you do, download those backups to your computer, and then delete them from the server. Then rebuild your forum again to see if that was the problem.

Good luck!

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
HaCo
YaBB Newcomer
*
Offline



Posts: 5

YaBB 2.6.0
Boards empty after different Rebuilds
Mar 17th, 2013 at 4:43pm
Post Tools
I run Yabb 2,3 on a server and a user contacted me because he was suddenly 'ex-member'.
I checked his user status and everything seemed normal (active User). His last post although was on a new page of a thread. Clicking on the last page of that thread (to see the last post), the thread was shown, but without any post. Getting back to the previous post of that thread showed the last posts and an empty post, with the users username next to it and showed as 'ex-member'.
So I went on starting to rebuild messages, recount board totals, rebuild member lists, recount membership, ... all the rebuilds available in hoping this would solve the problem.
Instead, some boards were empty, so I did it over again, a few times (wishful thing I guess) and now all my boards are empty.
The files on the server still display the boards as .txt in the 'Boards' folder, but these txt files are empty.
The 'Messages' still holds the last messages (it looks like that at least), but the message of the user where I'm talking about is not there in the most recent file.

So, what can I do from here?
- Can I still restore the boards, and how?
- Can I start from a clean install, with the files I recovered, maybe with the last stable build?

Thanks in advance!
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top