YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Pages: 1 2 
Topic Tools
 
Lost Boards (Read 2,521 times)
 Mar 30th, 2013 at 8:29am
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Lost Boards
Hi Guys,

don't laugh but I accidently deleted a couple of boards in haste and wonder if the is a mechanism to put them back? I have a backup and uploaded the .ttl, .txt and .mail files but I'm obviously missing something else? Can anyone point me in the right direction please?


Cheers,
Anz
 
WWW  
IP Logged  
 Reply #1 - Mar 30th, 2013 at 2:42pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,852
Earth


YaBB 2.5
Re: Lost Boards
Your forum.control and forum.master need to be replaced from backup as well.
 
WWW  
IP Logged  
 Reply #2 - Mar 30th, 2013 at 3:53pm
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Re: Lost Boards
Thankyou Dandello that brought the boards back but the last post comes up as N/A. I recounted the boards and message totals but none of the posts are showing. Having uploaded .ttl, .txt, forum.control and forum.master are there any other files or functions I have missed?

 
WWW  
IP Logged  
 Reply #3 - Mar 30th, 2013 at 4:03pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Lost Boards
This information is very helpful. Thanks Dandello! Smiley

As for boards that show N/A as the last post, I don't know if this will work in this circumstance, but when this has happened in our forum I simply added a post, and then subsequently deleted it to fix the problem.

 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #4 - Mar 30th, 2013 at 7:51pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,852
Earth


YaBB 2.5
Re: Lost Boards
Anz wrote on Mar 30th, 2013 at 3:53pm:
Thankyou Dandello that brought the boards back but the last post comes up as N/A. I recounted the boards and message totals but none of the posts are showing. Having uploaded .ttl, .txt, forum.control and forum.master are there any other files or functions I have missed?




the .ctb files that match the .txt files
 
WWW  
IP Logged  
 Reply #5 - Mar 31st, 2013 at 2:32am
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Re: Lost Boards
Bill Myers wrote on Mar 30th, 2013 at 4:03pm:
I simply added a post, and then subsequently deleted it to fix the problem

I tried that Bill but no go, thanks for your feed back.
 
WWW  
IP Logged  
 Reply #6 - Mar 31st, 2013 at 2:37am
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Re: Lost Boards
I found the .ctb files Dandello but they are numbered as opposed to the title. I don't want to overwrite the other boards so I guess I will have to go through them one by one. Is there an easier way because there are hundreds of messages?
« Last Edit: Mar 31st, 2013 at 2:45am by Anz »  
WWW  
IP Logged  
 Reply #7 - Mar 31st, 2013 at 5:14am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,852
Earth


YaBB 2.5
Re: Lost Boards
When the boards were removed, the messages  in them may also have been removed. So they will need to be replaced from your backup as well.
 
WWW  
IP Logged  
 Reply #8 - Mar 31st, 2013 at 8:23am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Lost Boards
Anz wrote on Mar 31st, 2013 at 2:32am:
I tried that Bill but no go, thanks for your feed back.

Got it! I guess it was worth a try.

Okay then; like Dandello mentioned, uploading backups of your messages may do the trick. Her instructions remind me of another time when I had N/A showing for one of our boards.

Somehow one of the message files must have gotten corrupted. That's what I thought had happened.

What I did was to upload the message file that was associated with the board showing N/A (such as 1330879027.txt) and that did the trick.

Also, if I'm remembering correctly, I had an entire board that seemed to have lost all of its topics, and showed the N/A listing. I hadn't deleted the board, but I had made some edits to it while testing a couple of options, and then switching back.

What I did in that case was to upload a backup of that board's text file (including the ones Dandello mentioned if I'm remembering correctly). In other words, a board called News has a text file of Boards/news.txt that lists the topics. That did the trick.

Important
: Whatever backup files you upload to your server,
before you do this
, download the current associated files onto your computer. That way, if the backups don't solve the problem, you can very quickly upload the original files you've overwritten.

Whatever works for you, please let us know so that your solution can help others. Thanks.

« Last Edit: Mar 31st, 2013 at 5:22pm by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #9 - Mar 31st, 2013 at 10:55am
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Re: Lost Boards
Unfortunately I haven't had any luck as yet Bill. I started going through the message files to get those missing but there are thousands that I have to open individually to find which board they are from so I gave up on that idea. I uploaded the few files I did have but still cannot see them.
 
WWW  
IP Logged  
 Reply #10 - Mar 31st, 2013 at 4:13pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,852
Earth


YaBB 2.5
Re: Lost Boards
The quick way - download your messages directory and then unzip the messages directory on the same machine (different directory). Then download a program called WinMerge (it's free).

Use WinMerge to compare the two directories. It will tell you which files are different and which files are missing from which directory. You'll be looking for the files that are present in the backup and not in the current. Then you can copy over the missing files and re-upload them to your server .

THEN run the message utilities on your forum.
 
WWW  
IP Logged  
 Reply #11 - Mar 31st, 2013 at 5:40pm
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Lost Boards
Anz wrote on Mar 31st, 2013 at 10:55am:
I started going through the message files to get those missing but there are thousands that I have to open individually to find which board they are from so I gave up on that idea.

The way to cheat this is to upload all of your messages onto your server. But that might be risky depending on how up to date your backups are. So ...

By following Dandello's earlier instructions, you let us know that you "brought the boards back but the last post comes up as N/A."

Does this mean with one board only that it's still showing N/A for its status? If so, then my suggestion is to click that board to open it, and then click the topic that shows N/A for its last post.

In your address bar you will see a topic identifier such as the following:

/YaBB.pl?num=1364632160/10

The number highligted in yellow is what you'll want to find, but this number will of course be different than what's in your forum for the N/A status.

With the example I've given, in our forum there are 3 files specifically associated with that topic's message as follows:

1364632160.ctb
1364632160.mail
1364632160.txt

Hopefully if you upload those files onto your server from backups, the N/A status will disappear. Unfortunately, as I've done it myself, it's possible that one or more of the backed up files you upload is also corrupted. This is one of the reasons I keep multiple backups.

Additionally, the 1364632160 identifier should also be listed in the file that's associated with that board. In other words, if the board is called News then it has a text file of Boards/news.txt that lists the topics. That 1364632160 identifier should be listed. You may need to upload that file as well.

By the way, Dandello's suggestion to download the WinMerge program may be a good idea since you can compare files. The thing is, it seems to me, the problem with N/A showing up in your forum should only be affecting very specific files that should be easily identified, relatively speaking.

Even though this has happened in your forum instead of mine, I'm feeling frustrated about it. As such, maybe you'll want to think of giving YaBB's resident expert on this a message so that he can take a look at it directly. His name is John, and he goes by the name of xnoddyx here in this support forum.

If you don't already know it, I should point that Dandello is an expert on YaBB, so following her instructions/suggestions is always highly recommended.

Note to John
: Yes, I once again volunteered your services because you're just so good at it!  Smiley

Edited:

Anz, unless I'm looking at the wrong forum, it appears that you fixed your N/A problem after all. Cool

And if I'm looking at the right forum, I'm impressed. It's beautiful looking. It's also one of the biggest and most active YaBB forums I've seen.



« Last Edit: Mar 31st, 2013 at 6:05pm by Bill Myers »  
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #12 - Apr 1st, 2013 at 2:51am
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Re: Lost Boards
Dandello wrote on Mar 31st, 2013 at 4:13pm:
The quick way - download your messages directory and then unzip the messages directory on the same machine (different directory). Then download a program called WinMerge (it's free).

Use WinMerge to compare the two directories. It will tell you which files are different and which files are missing from which directory. You'll be looking for the files that are present in the backup and not in the current. Then you can copy over the missing files and re-upload them to your server .

THEN run the message utilities on your forum.

Thankyou again Dandello and I will try this later and let you know how I got on.

Bill Myers wrote on Mar 31st, 2013 at 5:40pm:
Anz, unless I'm looking at the wrong forum, it appears that you fixed your N/A problem after all.

I have hidden the two boards in question Bill that's why you cannot see them. I have checked to see if there is any posts in the boards but it is like a clean new board.

Bill Myers wrote on Mar 31st, 2013 at 5:40pm:
And if I'm looking at the right forum, I'm impressed. It's beautiful looking. It's also one of the biggest and most active YaBB forums I've seen.

Thankyou for your kind words Bill I am very proud of our forum and it's very active membership. I have been with YaBB now for 10 years and think it is the best  Wink

http://www.fishsa.com/cgi-bin/yabb2/YaBB.pl
« Last Edit: Apr 1st, 2013 at 2:55am by Anz »  
WWW  
IP Logged  
 Reply #13 - Apr 1st, 2013 at 6:53am
There are no actions to perform.  

Bill Myers 
God Member
Beta Testers
*****
Offline
Posts: 1,482
Los Angeles


YaBB 2.4
Re: Lost Boards
Anz wrote on Apr 1st, 2013 at 2:51am:
I have hidden the two boards in question Bill that's why you cannot see them. I have checked to see if there is any posts in the boards but it is like a clean new board.

Got it!

As such, if you follow my instructions in regard to the actual board number identifiers, the N/A status for those boards should appear as normal again.

I'm keeping my fingers crossed for you. Wink

 
Morning, noon, or night, have a great one! ...
WWW BillHMyers  
IP Logged  
 Reply #14 - Apr 1st, 2013 at 6:54pm
There are no actions to perform.  

Anz 
YaBB Newbie
*
Offline
Posts: 20
South Australia


YaBB 2.4
Re: Lost Boards
Woohoo, thankyou again Dandello I downloaded Win merge and did as you instructed and then uploaded those files that were missing. Opened the forum and both Fly Fishing & Lures boards are back with all the posts and I couldn't be happier. Thanks to you to also Bill for your moral support and I wish good things to you both for your time and effort.

Anz is one happy chappy again  Smiley
 
WWW  
IP Logged  
Pages: 1 2 
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.