YaBB Community and Support Forum
YaBB Home About YaBB Download YaBB YaBB Support Customize Your Forum Development Contribute to the Project
  Welcome, Guest. Please Login or Register


 
Page Index Toggle Pages: 1
Topic Tools
 
Cannot activate "Anti-spam questions" due to config fault (Read 615 times)
 Apr 28th, 2013 at 8:37pm
There are no actions to perform.  

DEYJKARK 
YaBB Newbie
*
Offline
Posts: 13


None
Cannot activate "Anti-spam questions" due to config fault
Hello Yabbies!

Due to massive attacks of spammers I would like to activate the "Anti-spam questions" in YABB 2.5.2 but retrieve following message:

Quote:
Unable to open ./Languages/Deutsch_Du/spam.questions

With pre-2.5.2 I've driven the forum also in german/deutsch but nowadays run only englisch language support.

So, the question is: There must be a config value that leads to above - obsolete - path. But where can I find that value/path to correct it?

Thanx in advance
D.
« Last Edit: Apr 28th, 2013 at 8:38pm by DEYJKARK »  
 
IP Logged  
 Reply #1 - Apr 29th, 2013 at 3:36am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: Cannot activate "Anti-spam questions" due to config fault
It's looking for the anti-spam questions file in the Deutsch_Du Language directory -  you have 3 choices: Copy the English version of spam.questions into the Deutsch_Du folder, create a Deutsch_Du version of spam.questions or remove the Deutsch_Du language folder. YaBB actually detects the languages supported by reading the names of the sub folders in the Language Folder. There is no configuration value aside from the admin choosing which Language will be the initial default for visitors.

If you don't have a Deutsch_Du folder, check your Paths.pl file to make sure you're pointing to the proper Languages folder. You may have to put in an absolute path to the folder rather than the relative path that YaBB normally uses.

Also make sure you actually have a copy of spam.questions in your English folder. It's possible, however improbable, that YaBB can't find the file anywhere and is coming back with a weird error call rather than the correct one.
 
WWW  
IP Logged  
 Reply #2 - Apr 30th, 2013 at 7:29pm
There are no actions to perform.  

DEYJKARK 
YaBB Newbie
*
Offline
Posts: 13


None
Re: Cannot activate "Anti-spam questions" due to config fault
Hi Dandello,

thank you for your suggestions, I've checked all aspects:
  • htdocs/yabb2/cg-bin/Path.pl contains:
    $langdir = "./Languages";
  • htdocs/yabb2/Languages/English/spam.questions exists, file mask is 664
  • htdocs/yabb2/Languages/Deutsch_Du or any other language pack does not exist in ./Languages
Any other clues?

Regards
D.
« Last Edit: Apr 30th, 2013 at 7:43pm by DEYJKARK »  
 
IP Logged  
 Reply #3 - Apr 30th, 2013 at 7:57pm
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: Cannot activate "Anti-spam questions" due to config fault
Under 'average' configurations the Language directory should be in the cgi-bin/yabb2/ directory, parallel with Paths.pl and Yabb.pl and the Sources directory.

So based on what you've given it should be in 'htdocs/yabb2/cgi-bin/Languages/'

in this case I suggest adding the full path to the directory into Paths.pl - '$langdir = "htdocs/yabb2/Languages";' and see what happens. (Because YaBB is finding a Deutsch_Du folder somewhere.)
« Last Edit: Apr 30th, 2013 at 7:58pm by Dandello »  
WWW  
IP Logged  
 Reply #4 - May 1st, 2013 at 9:08pm
There are no actions to perform.  

DEYJKARK 
YaBB Newbie
*
Offline
Posts: 13


None
Re: Cannot activate "Anti-spam questions" due to config fault
I've got it!

The personal admin options have to be confirmed to fix it:
Go to "User CP", select "Profile", then select "Options" and confirm the language (e.g. English) supported by the board and then confirm with "save" button.

The language option "English" was already activated and selected in my admin profile. But after click on "save" the "Anti-spam questions" correctly appear in englisch language.

Dandello, thank you for your inspirations.

Regards
D.
 
 
IP Logged  
 Reply #5 - May 2nd, 2013 at 12:06am
There are no actions to perform.  

Dandello 
Global Moderator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline
Posts: 1,856
Earth


YaBB 2.5
Re: Cannot activate "Anti-spam questions" due to config fault
Normally for a forum with just one language pack installed, the admin doesn't have to worry about telling YaBB which language is the default. But now we have a fix for those who need it. Thanks for letting us know. Smiley
 
WWW  
IP Logged  
Page Index Toggle Pages: 1
Topic Tools
 

Get Yet another Bulletin Board at SourceForge.net. Fast, secure and Free Open Source software downloads Support This Project BoardMod - YaBB features and templates YaBB Codex - support on installation and usage YaBB Toolbar for your browser

YaBB Facebook Group Page

Vulnerability Scanner

Valid RSS Valid XHTML Valid CSS Powered by Perl
YaBB Chat and Support Community » Powered by YaBB 3.0 Beta!
YaBB Forum Software © 2000-2011. All Rights Reserved.