Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) possible javascript issue after upgrade from 2.1 (Read 2,910 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,165
Location: Earth

YaBB 2.6.0
Re: possible javascript issue after upgrade from 2.1
Reply #24 - Jun 18th, 2014 at 8:16pm
Post Tools
Assuming it's a standard 2.5.2 install and both notification checkboxes have been checked in the Admin Center:
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Jimboat
YaBB Newcomer
*
Offline



Posts: 38

YaBB 2.5.2
Re: possible javascript issue after upgrade from 2.1
Reply #23 - Jun 18th, 2014 at 5:59pm
Post Tools
Dandello wrote on Jun 14th, 2013 at 2:12pm:
The admin has to allow the sending of emails for it and the members/users have to activate it in their Options AND choose which boards/topics to get Notifications for.

Where does the user activate 'sending of emails' in their Options?  (Yabb 2.5.2)?
  

/Jim
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: possible javascript issue after upgrade from 2.1
Reply #22 - Jun 24th, 2013 at 12:38pm
Post Tools
Tom Gordon wrote on Jun 23rd, 2013 at 4:39pm:
Sorry, I was trying not to be too long-winded, so I skipped a step - you can hack the PogoPlug for use as a Linux server; see:

cool looks like it will be ok for a small forum.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Tom Gordon
YaBB Newcomer
*
Offline



Posts: 9
Location: NC
Re: possible javascript issue after upgrade from 2.1
Reply #21 - Jun 23rd, 2013 at 4:39pm
Post Tools
Sorry, I was trying not to be too long-winded, so I skipped a step - you can hack the PogoPlug for use as a Linux server; see:

http://archlinuxarm.org/platforms/armv5/pogoplug-series-4

I've installed Apache on it (might have had to put Perl on it too, don't remember), but it runs the website and my YaBB board just fine, and all in the space of about two decks of cards - well, almost, I keep trying to keep it up-to-date with the one currently running Network Solutions and mangling the files... but it's getting there!  I'll post and update when I get it all figured out, if ya'll are interested.
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: possible javascript issue after upgrade from 2.1
Reply #20 - Jun 22nd, 2013 at 5:56pm
Post Tools
Tom Gordon wrote on Jun 22nd, 2013 at 12:38am:
I'm moving it all to server I'm building on a PogoPlug 4 now, using an 8G flash drive.

sorry but you lost me on that i thought that the PogoPlug 4 was a Network Backup Device ? so yabb will not run on that.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Tom Gordon
YaBB Newcomer
*
Offline



Posts: 9
Location: NC
Re: possible javascript issue after upgrade from 2.1
Reply #19 - Jun 22nd, 2013 at 12:38am
Post Tools
What got me was that our board isn't busy at all - maybe a post once a week or so.  Mistake I made, I think, was turning them all on at once, including some with e-mails that no longer existed - probably triggered some kind of spam alert.  All it took was a post and a couple replies, and that apparently exceeded the max. e-mails, since I do have 400-500 registered users.

I'm moving it all to server I'm building on a PogoPlug 4 now, using an 8G flash drive.  It'll be in the broom closet of the clubhouse on a shelf next to the router  Cool.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,165
Location: Earth

YaBB 2.6.0
Re: possible javascript issue after upgrade from 2.1
Reply #18 - Jun 15th, 2013 at 12:18am
Post Tools
I'm not aware of a mod that will do that in YaBB. But if you ask Carsten over at http://www.carsten-dalgaard.dk/cgi-bin/yabb2/YaBB.pl very very nicely, he might figure out something for you.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
AztecGuy
YaBB Newcomer
*
Offline



Posts: 2

None
Re: possible javascript issue after upgrade from 2.1
Reply #17 - Jun 14th, 2013 at 2:23pm
Post Tools
Thanks for the quick response Dandello.

I was not suggesting having the admin force notifications, but I was expecting that, by the user setting 'Post and Board Notifications' to yes, that they would then be automatically subscribed for notification on any topic that they started.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,165
Location: Earth

YaBB 2.6.0
Re: possible javascript issue after upgrade from 2.1
Reply #16 - Jun 14th, 2013 at 2:12pm
Post Tools
That's how Notifications works.

The admin has to allow the sending of emails for it and the members/users have to activate it in their Options AND choose which boards/topics to get Notifications for.

There are (currently) no provisions for an admin to force users into accepting notification emails or for an admin to make global choices as to what Boards/Topics every one will get notifications on.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
AztecGuy
YaBB Newcomer
*
Offline



Posts: 2

None
Post notification problem. Related?
Reply #15 - Jun 14th, 2013 at 1:49pm
Post Tools
I am also having an issue with post notifications.  Mine is a new install of 2.5.2.  Even with 'Post and Board Notifications' set to yes under 'Options' users do not receive notification of new posts to a topic unless they explicitly request notification for that topic.

Admin Center - ForumSettings - > Personal Messages ->  'Allow users to enable e-mail notification when new PMs are received?' is enabled.

Any Ideas?
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,165
Location: Earth

YaBB 2.6.0
Re: possible javascript issue after upgrade from 2.1
Reply #14 - Jun 3rd, 2013 at 3:46pm
Post Tools
A recommendation was made to allow the admin to limit the number of topic and board notifications a user can have to stop exactly the problem you describe - too many emails going out on busy boards. Of course, implementing this on an existing board may cause issues for members who are used to getting e-mail notifications on every single board in the forum.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Tom Gordon
YaBB Newcomer
*
Offline



Posts: 9
Location: NC
Re: possible javascript issue after upgrade from 2.1
Reply #13 - Jun 3rd, 2013 at 2:36pm
Post Tools
The 'notify_me' is not in the member .vars files for YaBB 2.1, which is what I upgraded from, and this seems to default to empty or 0, so I had to run a script to turn these on.

Not recommended BTW, because Network Solutions shut me down for sending too many e-mails after I brought this online.  But I'll post about this somewhere else...
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,165
Location: Earth

YaBB 2.6.0
Re: possible javascript issue after upgrade from 2.1
Reply #12 - May 27th, 2013 at 7:17pm
Post Tools
Nothing in FixFile should have changed the 'notify_me' setting. What's being fixed in FixFile pretty much all relates to the NoPost membergroups.

Assuming the member had notifications turned on, that info should still be there and YaBB will handle it - but they won't get email or popups unless you have those turned on in the Admin center and the member also turns it on in their CP Options.
« Last Edit: May 27th, 2013 at 7:27pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Tom Gordon
YaBB Newcomer
*
Offline



Posts: 9
Location: NC
Re: possible javascript issue after upgrade from 2.1
Reply #11 - May 27th, 2013 at 5:17pm
Post Tools
One final follow-up: I re-did the upgrade (this time not making too many changes at once!) and everything seems fine.  The only issue I found was that the 'notify_me' entry in the .vars file for each member is new, and seems to default to blank after the upgrade.  Could be something missed in the upgrade process, or could just be something _I_ missed in the upgrade process Wink

Otherwise, the javascript is working just fine now.  Thanks for all your help!
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: possible javascript issue after upgrade from 2.1
Reply #10 - May 18th, 2013 at 2:32am
Post Tools
Tom Gordon wrote on May 17th, 2013 at 6:50pm:
Adding that line seem to fix that problem - thanks!  The "nav" class seems to not be in the css, but easy enough to fix.  That line didn't seem to be in the new default template, even from the files I downloaded, so I'm guessing that feature didn't make it to the new version?

is this in the top of the YaBB 2.5.2 default.css it will have
Code
Select All
/*--------------------------------------------------------*/
/*                      YaBB 2012                         */
/*--------------------------------------------------------*/
/*      Created by: YaBB http://www.yabbforum.com         */
/*--------------------------------------------------------*/
/*    You may adapt elements of this CSS in your own      */
/*   projects, but please give credit to yabbforum.com.   */
/*--------------------------------------------------------*/
/*   This is the css file for YaBB 2.5.2 default Template */
/*--------------------------------------------------------*/
/* $Revision: 1.0 $ */  


if not then you maybe using your old forum css
also at the end of the default.css it will have
Code
Select All
.green {
display:none;
}
.under, .u {
text-decoration:underline;
}
 


also here is a pic of the nav css code in the files
« Last Edit: May 18th, 2013 at 2:35am by xnoddyx »  

navcss.jpg ( 240 KB | 45 Downloads )
navcss.jpg

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top