Page Index Toggle Pages: 1
Topic Tools
Normal Topic Help for a numpty (Read 665 times)
Nat1983
YaBB Newcomer
*
Offline



Posts: 1
Help for a numpty
May 14th, 2013 at 7:46pm
Post Tools
Hi all,

First of all pleas accept my apologies for being such a numpty and having to post here, I know first hand how annoying it is to have to answer the same queries over and over again.

With the apology out of the way, I'm hoping there may be someone out there who may take pity on me  Embarrassed

I manage this forum scallywagsdogs.com/cgi-bin/yabb/YaBB.cgi and we're having issues with our Pm messages.

Quote:
Method Not Implemented

GET to /cgi-bin/yabb/YaBB.cgi not supported.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


I thought I would take this as an opportunity to upgrade to the latest version (current forum is 2.1) but I'm completely stuck. I've tried to follow the quick start and have installed 2.5.2 via Filezilla but I now have no idea what I'm doing  Cry

Can anyone help me please?

Thanks,
Nat
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,399
Location: Earth

YaBB 2.6.1
Re: Help for a numpty
Reply #1 - May 14th, 2013 at 9:47pm
Post Tools
Before anything, what did your host say about the 'GET not supported' error?

Second, what OS and server is being run on the host? IIS isn't the same as Apache and has different ways for how permissions are set up as well as the Path-to-Perl being different.

Make sure all the files uploaded to the cgi-bin went in as ASCII.

Assuming you're on a Linux/Unix based server running a recent version of Apache - make sure that YaBB.pl, AdminIndex.pl, Setup.pl, FixFile.pl and Sources/Spellcheck.pl are all CHMODed to 755 and all have the correct Path-to-Perl as the top line. (It should be the same as in the top line in your YaBB.cgi file)

All Folders and subfolders should be CHMOded to 755 and all files other than the ones mentioned above should be CHMODed to 644.

Run Setup.pl, making sure you have the proper paths for the 'path-finder' section.

Since your old forum had some sort of permissions issue with GET, once you have YaBB 2.5.2 set up and you've been able to login as admin, create a second account for yourself to test things like the PMs and other functions. Do this before you import anything from your old forum.

Once 2.5.2 is running properly, you can import your old members and messages using the instructions in the Quick-Guide (and we'll be here to help as well.)

Note: if things don't run CHMODed to 755 and 644, try 777 and 666 and tell your host that the server has not been set up properly for YaBB to run as it should - as the 'owner' of everything in the yabb2 directory and the yabbfiles directory.

« Last Edit: May 14th, 2013 at 9:48pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top