Page Index Toggle Pages: 1 [2] 3 4 ... 10
Topic Tools
Very Hot Topic (More than 25 Replies) Verbose: No such file or directory (Read 14,781 times)
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,276
Location: Earth

YaBB 2.6.1
Re: Verbose: No such file or directory
Reply #129 - Jul 11th, 2013 at 9:42pm
Post Tools
Knownhost is good (and not all that expensive) and there are some others that YaBB users have been happy with over in http://www.yabbforum.com/community/YaBB.pl?board=mods_admins

My forums are all on Knownhost and JonB has some there as well so I can certainly recommend them.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 527
Re: Verbose: No such file or directory
Reply #128 - Jul 11th, 2013 at 9:33pm
Post Tools
Dandello wrote on Jul 11th, 2013 at 7:25pm:
I know you don't want to hear this but I really think you should be looking at a different host.

Believe it or not I went to change my host earlier this year, what a disaster that was (Please don't ask me to mention Bluehost's name). Luckily I didn't close my old account and really didn't have much down time.  (I have a reseller account)

Moving doesn't scare me half as much as jumping into another bad situation. It seems that they are all the same lately and trying to figure out who is good is harder that then move itself.

I'm going to start by addressing my host and see what can be done while at the same time look for a new "trustworthly" host.

Thanks Dandello, you've been great with your time and your help.

Bill Myers wrote on Jul 11th, 2013 at 7:58pm:
As for anyone else who may be having this problem

Irrelevant.
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,276
Location: Earth

YaBB 2.6.1
Re: Verbose: No such file or directory
Reply #127 - Jul 11th, 2013 at 9:08pm
Post Tools
While opening registrations might work for some admins, it doesn't solve the underlying issue here - something is preventing YaBB from accessing files it needs to do its job OR messing up the user/filenames when they are being saved into the log files.

My feeling is that the problem with the .pre files is just one symptom of a larger issue. Unless the user is an Admin, the .pre files shouldn't even be looked at except for those few users who are still in pre-registration mode. For the Admin, the .wait and the .pre file names in /Members are read into an array for counting. So the number the Admin sees in the admin_alert should be an accurate count of how many files of each type (.wait and .pre) actually exist.

When opening the Registration Log, YaBB reads the Registration Log file which should contain a list of the new users, the date-time, the IP and a flag as to whether that user is activated, in pre-registration, or approved.

If there is a mismatch between the user name in the Registration log and the name on the .pre file or .wait file in Members OR YaBB can't open the .pre or .wait file, then YaBB will throw an error. YaBB also throws errors when 'encrypt user names' is turned on and the user name is only numbers (this is a known issue with the scramble/unscramble section.)

The fact that (apparently) users other than the Admin have had this problem indicates a larger issue with file permissions or name mismatches between the memberlist and the file names as well. The fact that the problem appears to be both random and self-healing indicates (to me) a serious server latency issue (as in files are not being written in a timely manner) OR a permissions issue on reading .pre files that a mechanism outside of YaBB is correcting since I'm not aware of any mechanism inside of YaBB that could do this.

Additionally, the newest error indicates YaBB was looking for a file that was simply named '.pre' - something that shouldn't be happening at all.  Shocked
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,620
Location: Los Angeles

YaBB 2.5
Re: Verbose: No such file or directory
Reply #126 - Jul 11th, 2013 at 7:58pm
Post Tools
Dandello wrote on Jul 11th, 2013 at 7:25pm:
... thinking this is a hosting issue of some nature.

That can very well be what's going on.

As for anyone else who may be having this problem since some admins may not realize this is actually a very easy problem to solve, an admin can skip past *.pre errors by selecting "Open registration without approvals" for their registration scheme.

Of if an admin is too skittish to be that user friendly with registrants, they can select "Pre-registration with Email membership activation" for their registration scheme.

As I've posted elsewhere when admins are able to benefit from guidance about how to solve the problem of spam-bot registrations, enabling ggn's Captcha hack will take care of that.

Good luck fellow admins. You do have the ability to stop spam bots cold! Smiley

« Last Edit: Jul 11th, 2013 at 8:01pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,276
Location: Earth

YaBB 2.6.1
Re: Verbose: No such file or directory
Reply #125 - Jul 11th, 2013 at 7:25pm
Post Tools
Since computer/server/application issues don't normally 'heal' themselves, I'm seriously thinking this is a hosting issue of some nature. A YaBB problem wouldn't heal itself - either it wrote the file or it didn't, either it can find the file or it can't. So if a file isn't there for ten minutes and suddenly it shows up - something delayed that file from being written, recognized, or made accessible.

I'm not a strong enough server person to say what that something could be but I'm really sure there's nothing in YaBB that could self-heal like that.  Undecided

I know you don't want to hear this but I really think you should be looking at a different host. (I'm basing this on knowing we have some really old, modded out, customized, and sketchy YaBB installs out there - not to mention some of us dev people are really good at breaking things -  and you appear to be the one person having this issue. And the biggest unique thing about your install(s) is the host and the fact that the problems started suddenly without you adding or doing anything that might precipitate an issue like this points in that direction as well. )

Edited:
Guardian had a reason for flagging them - they did something Guardian didn't like. Now what that was might be a little hard to figure out.  Roll Eyes
« Last Edit: Jul 11th, 2013 at 7:27pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 527
Re: Verbose: No such file or directory
Reply #124 - Jul 11th, 2013 at 5:00pm
Post Tools
Bummer

Quote:
Unable to open ./Members/.pre
Verbose: No such file or directory


Two members reported a 404 error for about 10 minutes while the forum was down for 10 minutes. The problem went away on its own.

Edited:
Two different issues - for some reason the Guardian picked off their IPs
« Last Edit: Jul 11th, 2013 at 7:08pm by ------ »  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,620
Location: Los Angeles

YaBB 2.5
Re: Verbose: No such file or directory
Reply #123 - Jul 9th, 2013 at 5:25pm
Post Tools
------ wrote on Jul 8th, 2013 at 11:22pm:
... why do you feel the need to remind me ...

I wasn't directing this towards you ... just wanted to remind admins that they don't have to endure the problems you're having if they simply follow the good advice that's been given here in this topic. I followed it, and it worked like a charm.

The following had been directed towards you:

Bill Myers wrote on Jul 3rd, 2013 at 3:14pm:
Hang in there. I wish you the best.  Smiley


*************************************

Maybe more importantly since I'm glad you're participating ...

------ wrote on Jul 8th, 2013 at 11:22pm:
... I do owe you a bit of gratitude ...

Smiley I feel the same when you're being positive.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 527
Re: Verbose: No such file or directory
Reply #122 - Jul 9th, 2013 at 12:49am
Post Tools
Thanks Dandello
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,276
Location: Earth

YaBB 2.6.1
Re: Verbose: No such file or directory
Reply #121 - Jul 8th, 2013 at 11:55pm
Post Tools
Go with
Code
Select All
m/[^a-zA-Z_]/sm  

- the 'g' means global and that doesn't matter as the first bad character should throw an error anyway.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 527
Re: Verbose: No such file or directory
Reply #120 - Jul 8th, 2013 at 11:22pm
Post Tools
Bill

I've had that fix in since the Dandello first brought it to my attention, why do you feel the need to remind me a few times per page. If you were following closely you would have noticed that. Please Review 

Your advice did accomplish something, me spinning my wheels. But I do want to thank you for your sincere concern because through all I did learn a few things about how the forum's software works. So I do owe you a bit of gratitude, I just wish there was less of it.

The latest step, while completely based on what Dandello and xnoddyx taught me was a slightly different approach, that is not allowing any numbers at all. Dandello approach was making sure all numbers wasn't a valid user name. But it did allow periods and numbers.

The bottom line is this, I still don't really know if the problem is caused by the server or spammers. With the latest fix and after a few days with it running we'll find out.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,620
Location: Los Angeles

YaBB 2.5
Re: Verbose: No such file or directory
Reply #119 - Jul 8th, 2013 at 10:26pm
Post Tools
xnoddyx wrote on Jul 8th, 2013 at 7:48pm:
That's what we like to see a happy admin  Smiley  Smiley

You and Dandello are amazing! It's reassuring that both of you know YaBB so well.  Cool

Dandello figured this out right from the start ... back on June 9th. Snap! Smiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,587
Location: UK:Scotland/livingston

None
Re: Verbose: No such file or directory
Reply #118 - Jul 8th, 2013 at 7:48pm
Post Tools
------ wrote on Jul 8th, 2013 at 3:39pm:
Edited: Picked off better then a dozen spammers so far trying to use characters other then letters

That's what we like to see a happy admin  Smiley  Smiley
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 527
Re: Verbose: No such file or directory
Reply #117 - Jul 8th, 2013 at 3:39pm
Post Tools
Dandello wrote on Jul 8th, 2013 at 12:41am:
Typos - some days my brain just doesn't wake up when the rest of me does. To just remove the period from allowed characters replace the first code with


LOL I have days like that to.

Will my change work?  If so and I get a .pre error with numbers I know the problem is my server

Edited:
Picked off better then a dozen spammers so far trying to use characters other then letters Smiley
« Last Edit: Jul 8th, 2013 at 7:41pm by ------ »  
Back to top
 
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 527
Re: Verbose: No such file or directory
Reply #116 - Jul 8th, 2013 at 3:30pm
Post Tools
Thanks again

I changed it so only text and the underscore is allowed

Code
Select All
m/[^a-zA-Z_]/gsm  

  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Online



Posts: 2,276
Location: Earth

YaBB 2.6.1
Re: Verbose: No such file or directory
Reply #115 - Jul 8th, 2013 at 12:41am
Post Tools
To get really restrictive (and to do what you're thinking) replace the
Code
Select All
/[^\w\+\-\.\@]/ 

with
Code
Select All
m/[^a-zA-Z0-9_\ ]/sm 


That should allow only letters, numbers, underscores and spaces to be used in user name.

Edited:
Typos - some days my brain just doesn't wake up when the rest of me does. To just remove the period from allowed characters replace the first code with
Code
Select All
/[^\w\+\-\@]/ 

« Last Edit: Jul 8th, 2013 at 3:30pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 4 ... 10
Topic Tools
 
  « Board Index ‹ Board  ^Top