Page Index Toggle Pages: [1] 2 
Topic Tools
 10 trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl (Read 2,746 times)
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #21 - Jul 1st, 2013 at 10:14pm
Post Tools
Okay thought about starting new thread - but I'll try in this one first as it contains relevant history (lol)

So I've had to move everything back into the original folders to maitain url integrity both on and off the forum.

That sort of worked.
I had weirs style sheet and template issues.
ie: different user names saw different templates. Weird but true. No amount of cookie killing or browser cache clearing made any difference.
And only those who saw the blue yabb template could also see pictures and use the quotes feature.
Also the admin section was telling me the attachments folder did not exist - I could see it so i knew that wasn't right.

At this point I had 2 yabbfile folders.
So, thnks I, I'll amalgamate the yabbfiles folders in the original folder position. So I'll only have one yabbfile directory and all the old paths and links will be identical.

So earlier this evening that's exactly what i did.

Instantly lost all styling - forum and admin page. Checked the paths file against the old paths file (all files are now - supposedly - right back where they used to be) changed  
the paths to the old settings and got styling back for the admin page while still not having it for the forum.

Okay I re-uploaded all the original and new template and .css files.

Now on the template sections I can see and select all the files. But While the css files appear to work on the style sheet section - nothing I pick on the main template page does anything. I'm just left with a blank background .

Attachment 1 shows what the style sheet editing page shows - ie: the correct style sheet.

Attachment 2 shows what I actually get on the template configuration page when I select the style sheet - or any style sheet for that matter. Absolutely bugger all.

Now if the paths were wrong surely I wouldn't see the style sheet in the style sheet editing tab.
So why can't I apply ANY style sheets to my forum now ?
I've checked chmods for all relevant and most irrelevant files and they are what i think they should be.  

It's doing my head in.
« Last Edit: Jul 1st, 2013 at 10:17pm by curious aardvark »  

slingnostyle2.jpg ( 87 KB | 31 Downloads )
slingnostyle2.jpg
slingingnostyle.jpg ( 70 KB | 26 Downloads )
slingingnostyle.jpg
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,088
Location: Earth

YaBB 2.6.0
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #20 - Jun 15th, 2013 at 7:55pm
Post Tools
Since you have FTP access - open Variables/Setup.pl and find '$maintenance = 1;'
and change it to '$maintenance = 0;'

That will turn off maintenance mode.

As to the problem with AdminIndex.pl, xnoddyx may need to look in on that. Since it was working before, it's obviously something that happened during the move to its new home.



  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #19 - Jun 15th, 2013 at 7:26pm
Post Tools
yep - well that's all gone titsup.

Everything points to the right place - but I can no longer access the administration page. Checked paths and chmods. they're okay and unchanged respectively. The right thing comes up in the browser url window.
But I can't get into the administration section.
When I click on admin it just cycles back to the forum homepage.
Every other button on that menu line works perfectly. Just the one I actually need is dead.  

And I suspect it might be stuck in maintenace mode for everyone else. (checks with different username)
Yep.
Nobody but me can login and I can't access the admin page to switch maintenance mode off.

Other than that it appears to have worked.

Any thoughts ?

***

panic over - I'd typed the paths in slightly wrong -weird that everything else wroked though.

Hopefully (lmao) that should be job done.

watch this space........................
« Last Edit: Jun 15th, 2013 at 7:42pm by curious aardvark »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,088
Location: Earth

YaBB 2.6.0
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #18 - Jun 15th, 2013 at 6:43pm
Post Tools
Paths.pl tells YaBB where everything it needs is - including itself  Grin
So when you move or rename things, you have edit Paths.pl to reflect the changes.

Good luck.  Smiley
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #17 - Jun 15th, 2013 at 4:58pm
Post Tools
haven't bothered with the honeypot thing - as I'm never again allowing self registration - we no longer get any spammers so antispam measures aren't necessary Smiley

Plus I like the personal touch of signing members up my own self.

Quote:
or better, note down the names of the old folders, delete them and rename your new folders to match the old ones - in most installs it will be just the 'cgi-bin/yabb2/ and the 'yabbfiles').


Not in ours - but as there's nothing else in cgi-bin but the new forum that could work too.
Okay I was just concerned nothing would be able to find anything.

Quote:
Remember to edit Paths.pl.


lol you're assuming I've got something to remember.
Not so. I didn't install the forum 10 years ago or update it 7 years ago. This is my first go round with this sort of stuff.
hence all the questions Smiley

So basically I can stick them anywhere and just tell paths.pl (when i find it) where stuff is ?
Okay I can try that Smiley
Don't need to move the yabbfiles folder - so maybe don't have to edit paths ?
we'll see.

Far as the news feature goes - I can probably just cut and paste the relevant html from the default template into my header.
Not the worlds best web writer but I can read html a bit Smiley
« Last Edit: Jun 15th, 2013 at 5:17pm by curious aardvark »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,088
Location: Earth

YaBB 2.6.0
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #16 - Jun 15th, 2013 at 2:08pm
Post Tools
Save all of your old forum to a safe place and then you should be able to move all your new files into the old folders (or better, note down the names of the old folders, delete them and rename your new folders to match the old ones - in most installs it will be just the 'cgi-bin/yabb2/ and the 'yabbfiles').

Remember to edit Paths.pl.

Remember in your default.css to add the '.green {display:none}' so the honeypot doesn't show.

Edited:
You're now the second person to ask about getting the old html newsfeeder to work. My current suggestion (short term) - Add an iframe to default.html at the place you want it to show and style it to not show borders, etc. and have it call 'newsfeeder.html'.

Then create a minimal newsfeeder.html file for it and put THAT in your yabb2/Templates/default/  That will be your new 'newsfeeder' file. And since it's in Templates/default, it can be edited under Forum Layout->Templates. And since it's a separate html page, it can be styled with html (in fact it can only be styled with html).

The better solution IMHO would be a javascript one as that won't involve iframes, but the general programming to make it easy to edit would be a bit hairier and beyond my personal current abilities in javascript.
« Last Edit: Jun 15th, 2013 at 2:25pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #15 - Jun 15th, 2013 at 12:23pm
Post Tools
well that 1% turned out to be a fairly serious issue.

Every single link both on the forum and the internet at large - is still pointing to the old forum.

Our forum is 10 years old and referenced pretty much anywhere slings are mentioned on the web.

Now I see two options.

1) work out some kind of automated routine to replace the old path with the new path. But this won't resolve the issue of any exterior links to the forum.

2) I can move the new forum into the folder the old forum used to occupy. I've got the entire contents of our server on my home machine so have no problems with wiping the old forum folder.

so 2 quextions.
1) If I just drop the new forum into the old folder wholesale - will it still work ?  

2) if not - what do I do to make it work. as I can't see any other practical alternative.
« Last Edit: Jun 15th, 2013 at 12:23pm by curious aardvark »  
Back to top
 
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #14 - Jun 15th, 2013 at 12:02pm
Post Tools
Ah ha - managed to add the old header and then I've just had both forums open and copied the old stylesheets settings across one at a time.
Although there are differences - it's looking a lot more like the old forum.

Now just got to figure out how to put the newsfeed back - I liked that Smiley

But on the whole I'd say we're 99% there.

many thanks guys
And if you fancy learning a thing or two about slings drop in Smiley
« Last Edit: Jun 15th, 2013 at 12:02pm by curious aardvark »  
Back to top
 
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #13 - Jun 15th, 2013 at 11:35am
Post Tools
that's creating a new template - I'm trying to use an existing older template.

The screen I think you are talking about is this one (first pic below):

What i want to do is use the existing template shown in the edit template screen in the second picture.
  

templateconfig1.jpg ( 77 KB | 34 Downloads )
templateconfig1.jpg
templatescreen2.jpg ( 94 KB | 37 Downloads )
templatescreen2.jpg
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,088
Location: Earth

YaBB 2.6.0
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #12 - Jun 15th, 2013 at 12:24am
Post Tools
In Manage Templates you have to create a 'template set'.

Under Template configuration choose the various template files and folders you want in the new set and then under 'Save As' type in the name for your new template set and save it. The new template set should now appear as one of the Template choices.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #11 - Jun 14th, 2013 at 7:42pm
Post Tools
Okay next question.
I,ve let the barabarians back into the forum - but without our old template it just doesn't feel like slinging.org

I followed the old template install instructions.
copied the html file to the templates directory in it's own folder and renamed it the same name as the folder.
even rerun fixfile - just in case. (not sure if this was a good idea or not - didn't seem to kill anytrhing)

But it still does not show up  as a choosable template.
I can't find a css file (don't know where to look more like) - is this the problem or is it something different ?  

Okay - If I click on the template option, under forum layout. I can see and edit my old template.
But when I click on template configuration - it's not there.

Think I'll call it a day - bugger all sleep last night.
Hopefully this is something simple that I'm just too tired to work out.
« Last Edit: Jun 14th, 2013 at 8:02pm by curious aardvark »  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #10 - Jun 13th, 2013 at 3:23pm
Post Tools
curious aardvark wrote on Jun 13th, 2013 at 2:03pm:
cheers - I actually remember banning that email suffix a few years ago when we were getting a lot of spam accounts from russia.
I'll try that Smiley

its cool just that when formatting ban for @email.xx it can ban all @ so some times it is best just to empty that list.

curious aardvark wrote on Jun 13th, 2013 at 2:10pm:
halley-freeking-yulah !

You sir are a scholar and a gentleman !

Right, lets see how long it tales for me to hit the next obstacle Smiley

thank you and you will be up and running in know time at all.  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #9 - Jun 13th, 2013 at 2:10pm
Post Tools
halley-freeking-yulah !

You sir are a scholar and a gentleman !

Right, lets see how long it tales for me to hit the next obstacle Smiley
  
Back to top
 
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #8 - Jun 13th, 2013 at 2:03pm
Post Tools
cheers - I actually remember banning that email suffix a few years ago when we were getting a lot of spam accounts from russia.
I'll try that Smiley
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,584
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #7 - Jun 12th, 2013 at 8:14pm
Post Tools
curious aardvark wrote on Jun 12th, 2013 at 7:15pm:
Quote:Untrapped Error :Quantifier follows nothing in regex; marked by <-- HERE in m/* <-- HERE @mail.ru/ at ./Sources/Security.pl line 147.  

ok with that error can you download and check yabb2/Variables/Settings.pl

almost at the end of the file you will see:
Code
Select All
###############################################################################
# Banning Settings (old ban.txt)                                              #
###############################################################################

$ip_banlist = "";                                 # IP banlist
$email_banlist = "";                              # EMAIL banlist
$user_banlist = "";                               # USER banlist 



in:
Code
Select All
$email_banlist = "you will have items here"; 



if you can remove all items in here so that it looks like

Code
Select All
$email_banlist = ""; 



upload it back to your new forum and check.

Edited:
curious aardvark wrote on Jun 12th, 2013 at 7:15pm:
Or a message that the page is being spoofed:  Quote:ALERT!! Form Spoofing Detected coming from IP address: 92.15.68.182 it's my ip address. So what did I do wrong or not do right (they are different) ?

this some times can happen if you f5 the page or your web browser did not send a full http head and only sent the form info < not much to worry about if you have only seen it one or two times.


curious aardvark wrote on Jun 12th, 2013 at 7:15pm:
You ever get the feeling you really shouldn't have started something in the first place ? This is day 3


that is not so bad most forum admins don't update so never really get to know the ins and outs of it also forget what they did the first time installing there forum but this is why i offer direct help sometimes. also the offer is still there if you need it.
« Last Edit: Jun 12th, 2013 at 8:27pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top