Page Index Toggle Pages: 1 [2] 
Topic Tools
Hot Topic (More than 10 Replies) trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl (Read 3,467 times)
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #15 - Jun 15th, 2013 at 12:23pm
Post Tools
well that 1% turned out to be a fairly serious issue.

Every single link both on the forum and the internet at large - is still pointing to the old forum.

Our forum is 10 years old and referenced pretty much anywhere slings are mentioned on the web.

Now I see two options.

1) work out some kind of automated routine to replace the old path with the new path. But this won't resolve the issue of any exterior links to the forum.

2) I can move the new forum into the folder the old forum used to occupy. I've got the entire contents of our server on my home machine so have no problems with wiping the old forum folder.

so 2 quextions.
1) If I just drop the new forum into the old folder wholesale - will it still work ?  

2) if not - what do I do to make it work. as I can't see any other practical alternative.
« Last Edit: Jun 15th, 2013 at 12:23pm by curious aardvark »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,475
Location: Earth

YaBB 2.6.1
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #16 - Jun 15th, 2013 at 2:08pm
Post Tools
Save all of your old forum to a safe place and then you should be able to move all your new files into the old folders (or better, note down the names of the old folders, delete them and rename your new folders to match the old ones - in most installs it will be just the 'cgi-bin/yabb2/ and the 'yabbfiles').

Remember to edit Paths.pl.

Remember in your default.css to add the '.green {display:none}' so the honeypot doesn't show.

Edited:
You're now the second person to ask about getting the old html newsfeeder to work. My current suggestion (short term) - Add an iframe to default.html at the place you want it to show and style it to not show borders, etc. and have it call 'newsfeeder.html'.

Then create a minimal newsfeeder.html file for it and put THAT in your yabb2/Templates/default/  That will be your new 'newsfeeder' file. And since it's in Templates/default, it can be edited under Forum Layout->Templates. And since it's a separate html page, it can be styled with html (in fact it can only be styled with html).

The better solution IMHO would be a javascript one as that won't involve iframes, but the general programming to make it easy to edit would be a bit hairier and beyond my personal current abilities in javascript.
« Last Edit: Jun 15th, 2013 at 2:25pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #17 - Jun 15th, 2013 at 4:58pm
Post Tools
haven't bothered with the honeypot thing - as I'm never again allowing self registration - we no longer get any spammers so antispam measures aren't necessary Smiley

Plus I like the personal touch of signing members up my own self.

Quote:
or better, note down the names of the old folders, delete them and rename your new folders to match the old ones - in most installs it will be just the 'cgi-bin/yabb2/ and the 'yabbfiles').


Not in ours - but as there's nothing else in cgi-bin but the new forum that could work too.
Okay I was just concerned nothing would be able to find anything.

Quote:
Remember to edit Paths.pl.


lol you're assuming I've got something to remember.
Not so. I didn't install the forum 10 years ago or update it 7 years ago. This is my first go round with this sort of stuff.
hence all the questions Smiley

So basically I can stick them anywhere and just tell paths.pl (when i find it) where stuff is ?
Okay I can try that Smiley
Don't need to move the yabbfiles folder - so maybe don't have to edit paths ?
we'll see.

Far as the news feature goes - I can probably just cut and paste the relevant html from the default template into my header.
Not the worlds best web writer but I can read html a bit Smiley
« Last Edit: Jun 15th, 2013 at 5:17pm by curious aardvark »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,475
Location: Earth

YaBB 2.6.1
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #18 - Jun 15th, 2013 at 6:43pm
Post Tools
Paths.pl tells YaBB where everything it needs is - including itself  Grin
So when you move or rename things, you have edit Paths.pl to reflect the changes.

Good luck.  Smiley
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #19 - Jun 15th, 2013 at 7:26pm
Post Tools
yep - well that's all gone titsup.

Everything points to the right place - but I can no longer access the administration page. Checked paths and chmods. they're okay and unchanged respectively. The right thing comes up in the browser url window.
But I can't get into the administration section.
When I click on admin it just cycles back to the forum homepage.
Every other button on that menu line works perfectly. Just the one I actually need is dead.  

And I suspect it might be stuck in maintenace mode for everyone else. (checks with different username)
Yep.
Nobody but me can login and I can't access the admin page to switch maintenance mode off.

Other than that it appears to have worked.

Any thoughts ?

***

panic over - I'd typed the paths in slightly wrong -weird that everything else wroked though.

Hopefully (lmao) that should be job done.

watch this space........................
« Last Edit: Jun 15th, 2013 at 7:42pm by curious aardvark »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,475
Location: Earth

YaBB 2.6.1
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #20 - Jun 15th, 2013 at 7:55pm
Post Tools
Since you have FTP access - open Variables/Setup.pl and find '$maintenance = 1;'
and change it to '$maintenance = 0;'

That will turn off maintenance mode.

As to the problem with AdminIndex.pl, xnoddyx may need to look in on that. Since it was working before, it's obviously something that happened during the move to its new home.



  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #21 - Jul 1st, 2013 at 10:14pm
Post Tools
Okay thought about starting new thread - but I'll try in this one first as it contains relevant history (lol)

So I've had to move everything back into the original folders to maitain url integrity both on and off the forum.

That sort of worked.
I had weirs style sheet and template issues.
ie: different user names saw different templates. Weird but true. No amount of cookie killing or browser cache clearing made any difference.
And only those who saw the blue yabb template could also see pictures and use the quotes feature.
Also the admin section was telling me the attachments folder did not exist - I could see it so i knew that wasn't right.

At this point I had 2 yabbfile folders.
So, thnks I, I'll amalgamate the yabbfiles folders in the original folder position. So I'll only have one yabbfile directory and all the old paths and links will be identical.

So earlier this evening that's exactly what i did.

Instantly lost all styling - forum and admin page. Checked the paths file against the old paths file (all files are now - supposedly - right back where they used to be) changed  
the paths to the old settings and got styling back for the admin page while still not having it for the forum.

Okay I re-uploaded all the original and new template and .css files.

Now on the template sections I can see and select all the files. But While the css files appear to work on the style sheet section - nothing I pick on the main template page does anything. I'm just left with a blank background .

Attachment 1 shows what the style sheet editing page shows - ie: the correct style sheet.

Attachment 2 shows what I actually get on the template configuration page when I select the style sheet - or any style sheet for that matter. Absolutely bugger all.

Now if the paths were wrong surely I wouldn't see the style sheet in the style sheet editing tab.
So why can't I apply ANY style sheets to my forum now ?
I've checked chmods for all relevant and most irrelevant files and they are what i think they should be.  

It's doing my head in.
« Last Edit: Jul 1st, 2013 at 10:17pm by curious aardvark »  

slingnostyle2.jpg ( 87 KB | 32 Downloads )
slingnostyle2.jpg
slingingnostyle.jpg ( 70 KB | 28 Downloads )
slingingnostyle.jpg
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Topic Tools