Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl (Read 3,497 times)
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Jun 11th, 2013 at 4:54pm
Post Tools
Currently running 2.1 and happy, but would like some of the new features plus our server pointed out how old 2.1 was and that it would be advisable if we updated.
I don't actually want to for all the usual reasons: haven't done it before, forums that get upgraded rarely come back with all their limbs and files intacts etc

But I decided to give it a go - particularly as the update process doesn't effect the existing forum so if it all goes tits up (assuming it goes at all) I can just revert back to 2.1

basically I get to the point where I point my browser at the Setup.pl file - and get the following screen
500 server error

pic below.

Help !
  

yabbinstallerror.jpg ( 18 KB | 31 Downloads )
yabbinstallerror.jpg
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #1 - Jun 11th, 2013 at 5:29pm
Post Tools
what it my be

   * Incorrect path to Perl (also known as shebang)
   * Incorrect file permissions (CHMOD)
   * Incorrect format when uploading (ASCII/Binary)
   * Incorrect filename or path when calling the script

did you check (shebang) Path to Perl line
if you don't know what this is

The Highlight Code is where to make this edit
Setup.pl:
Code (Perl)
Select All
#!/usr/bin/perl --
# $Id: yabb setup $
# $HeadURL: testbed $
# $Revision: 2012 $
# $Source: /Setup.pl $

###############################################################################
# Setup.pl                                                                    #

 



Edited:
all files to edit (shebang) Path to Perl line

Setup.pl
FixFile.pl
YaBB.pl
AdminIndex.pl
SpellChecker.pl


you can look in your YaBB.pl 2.1 for this line and check if it is the same.
« Last Edit: Jun 11th, 2013 at 5:30pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #2 - Jun 11th, 2013 at 6:40pm
Post Tools
hadn't thought of looking in an existing script. cheers.
chmod I have checked.
let you know if that's the probelm  Smiley
(10 minutes later)

Nope not that - but could be the bin thing.
Looks like I need a different ftp client can't find any bin/ascii options in core ftp.

Bugger - oh well, back to the drawig board Smiley

Ah filezilla has very simple switch between ascii and bin.
Right let's do this again Smiley
« Last Edit: Jun 11th, 2013 at 6:51pm by curious aardvark »  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #3 - Jun 11th, 2013 at 6:59pm
Post Tools
hope it works for you this time also (ASCII/Binary) list find it in the Quick-Guide_252 in Step 2 - Uploading YaBB or find a copy here http://testbed.dandello.net/Quick-Guide_252/English/install/2.php

also if you still have trouble installing it I can check it for you just PM/email me your ftp login info.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #4 - Jun 11th, 2013 at 7:24pm
Post Tools
Ah ha -turns out it was a standard bomi (Bipedal Organic Mobile Interface) error.

Had thought all files were 644 and all directories 755 chmod.
Which is correct APART from the .pl files Smiley

Less haste more speed, I believe is the appropriate aphorism.

Right back to work Smiley 
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #5 - Jun 11th, 2013 at 11:01pm
Post Tools
curious aardvark wrote on Jun 11th, 2013 at 7:24pm:
Ah ha -turns out it was a standard bomi (Bipedal Organic Mobile Interface) error.

Had thought all files were 644 and all directories 755 chmod.
Which is correct APART from the .pl files Smiley

Less haste more speed, I believe is the appropriate aphorism.

Right back to work Smiley  

cool  Wink also was it the one from here http://yabb.svn.sourceforge.net/viewvc/yabb/branches/2.5.2/
as this is more up to date than what is on the main download page just now.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #6 - Jun 12th, 2013 at 7:15pm
Post Tools
no idea where it was from.

Okay the story so far.
It's installed on the server, all the files are copied across. uploaded with the right settings in filezilla. I've been through and checked the chmod settings on every single file.

And the new forum does have my maintenance mode message up - so something's working. But when i try to login all I get is either this:

Quote:
Untrapped Error :
Quantifier follows nothing in regex; marked by <-- HERE in m/* <-- HERE @mail.ru/ at ./Sources/Security.pl line 147.


I have checked that file and '@mail.ru' is not in it. Which is even weirder.

Or a message that the page is being spoofed:
Quote:
ALERT!! Form Spoofing Detected coming from IP address: 92.15.68.182

it's my ip address.

So what did I do wrong or not do right (they are different) ?

You ever get the feeling you really shouldn't have started something in the first place ?
This is day 3 Smiley
« Last Edit: Jun 12th, 2013 at 7:47pm by curious aardvark »  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #7 - Jun 12th, 2013 at 8:14pm
Post Tools
curious aardvark wrote on Jun 12th, 2013 at 7:15pm:
Quote:Untrapped Error :Quantifier follows nothing in regex; marked by <-- HERE in m/* <-- HERE @mail.ru/ at ./Sources/Security.pl line 147.  

ok with that error can you download and check yabb2/Variables/Settings.pl

almost at the end of the file you will see:
Code
Select All
###############################################################################
# Banning Settings (old ban.txt)                                              #
###############################################################################

$ip_banlist = "";                                 # IP banlist
$email_banlist = "";                              # EMAIL banlist
$user_banlist = "";                               # USER banlist 



in:
Code
Select All
$email_banlist = "you will have items here"; 



if you can remove all items in here so that it looks like

Code
Select All
$email_banlist = ""; 



upload it back to your new forum and check.

Edited:
curious aardvark wrote on Jun 12th, 2013 at 7:15pm:
Or a message that the page is being spoofed:  Quote:ALERT!! Form Spoofing Detected coming from IP address: 92.15.68.182 it's my ip address. So what did I do wrong or not do right (they are different) ?

this some times can happen if you f5 the page or your web browser did not send a full http head and only sent the form info < not much to worry about if you have only seen it one or two times.


curious aardvark wrote on Jun 12th, 2013 at 7:15pm:
You ever get the feeling you really shouldn't have started something in the first place ? This is day 3


that is not so bad most forum admins don't update so never really get to know the ins and outs of it also forget what they did the first time installing there forum but this is why i offer direct help sometimes. also the offer is still there if you need it.
« Last Edit: Jun 12th, 2013 at 8:27pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #8 - Jun 13th, 2013 at 2:03pm
Post Tools
cheers - I actually remember banning that email suffix a few years ago when we were getting a lot of spam accounts from russia.
I'll try that Smiley
  
Back to top
 
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #9 - Jun 13th, 2013 at 2:10pm
Post Tools
halley-freeking-yulah !

You sir are a scholar and a gentleman !

Right, lets see how long it tales for me to hit the next obstacle Smiley
  
Back to top
 
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,593
Location: UK:Scotland/livingston

None
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #10 - Jun 13th, 2013 at 3:23pm
Post Tools
curious aardvark wrote on Jun 13th, 2013 at 2:03pm:
cheers - I actually remember banning that email suffix a few years ago when we were getting a lot of spam accounts from russia.
I'll try that Smiley

its cool just that when formatting ban for @email.xx it can ban all @ so some times it is best just to empty that list.

curious aardvark wrote on Jun 13th, 2013 at 2:10pm:
halley-freeking-yulah !

You sir are a scholar and a gentleman !

Right, lets see how long it tales for me to hit the next obstacle Smiley

thank you and you will be up and running in know time at all.  Wink
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #11 - Jun 14th, 2013 at 7:42pm
Post Tools
Okay next question.
I,ve let the barabarians back into the forum - but without our old template it just doesn't feel like slinging.org

I followed the old template install instructions.
copied the html file to the templates directory in it's own folder and renamed it the same name as the folder.
even rerun fixfile - just in case. (not sure if this was a good idea or not - didn't seem to kill anytrhing)

But it still does not show up  as a choosable template.
I can't find a css file (don't know where to look more like) - is this the problem or is it something different ?  

Okay - If I click on the template option, under forum layout. I can see and edit my old template.
But when I click on template configuration - it's not there.

Think I'll call it a day - bugger all sleep last night.
Hopefully this is something simple that I'm just too tired to work out.
« Last Edit: Jun 14th, 2013 at 8:02pm by curious aardvark »  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,477
Location: Earth

YaBB 2.6.1
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #12 - Jun 15th, 2013 at 12:24am
Post Tools
In Manage Templates you have to create a 'template set'.

Under Template configuration choose the various template files and folders you want in the new set and then under 'Save As' type in the name for your new template set and save it. The new template set should now appear as one of the Template choices.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #13 - Jun 15th, 2013 at 11:35am
Post Tools
that's creating a new template - I'm trying to use an existing older template.

The screen I think you are talking about is this one (first pic below):

What i want to do is use the existing template shown in the edit template screen in the second picture.
  

templateconfig1.jpg ( 77 KB | 35 Downloads )
templateconfig1.jpg
templatescreen2.jpg ( 94 KB | 38 Downloads )
templatescreen2.jpg
Back to top
 
IP Logged
 
curious aardvark
YaBB Newcomer
*
Offline



Posts: 29
Re: trying to upgrade from 2.1 to 2.5.2 - can't run Setup.pl
Reply #14 - Jun 15th, 2013 at 12:02pm
Post Tools
Ah ha - managed to add the old header and then I've just had both forums open and copied the old stylesheets settings across one at a time.
Although there are differences - it's looking a lot more like the old forum.

Now just got to figure out how to put the newsfeed back - I liked that Smiley

But on the whole I'd say we're 99% there.

many thanks guys
And if you fancy learning a thing or two about slings drop in Smiley
« Last Edit: Jun 15th, 2013 at 12:02pm by curious aardvark »  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools