Page Index Toggle Pages: [1] 2 
Topic Tools
Hot Topic (More than 10 Replies) Admin Centre (Read 1,884 times)
nigel
YaBB Newcomer
*
Offline



Posts: 13
Location: Somerset UK
Admin Centre
Aug 23rd, 2013 at 11:33am
Post Tools
An Error Has Occurred!

Error: Untrapped Error :
Can't locate ./Admin/Admin.pl in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . ./Modules ./Modules/Upload ./Modules/Digest) at /websites/123reg/LinuxPackage22/ol/dh/on/oldhonitonians.com/public_html/cgi-bin/
yabb2/AdminIndex.pl line 130.

Can you help to rectify the above problem
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,676
Location: Los Angeles

YaBB 2.5
Re: Admin Centre
Reply #1 - Aug 23rd, 2013 at 3:56pm
Post Tools
I see that your forum comes up okay, but you're saying you're unable to access your Admin Center?

I'm guessing your Admin.pl file is simply missing, and needs to be uploaded to your server just like your index page needs to be uploaded so that your site appears.

On that note, if you don't already know it, your site's index page is missing, so it only lists a bunch of files.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 528
Re: Admin Centre
Reply #2 - Aug 24th, 2013 at 3:10am
Post Tools
Bill Myers wrote on Aug 23rd, 2013 at 3:56pm:
On that note, if you don't already know it, your site's index page is missing, so it only lists a bunch of files.



Nigel, I think if you rename http://oldhonitonians.com/main_index.htm
to http://oldhonitonians.com/index.htm you'll be back on track.
« Last Edit: Aug 24th, 2013 at 3:10am by ------ »  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,676
Location: Los Angeles

YaBB 2.5
Re: Admin Centre
Reply #3 - Aug 24th, 2013 at 6:12am
Post Tools
Caution: If you think any of the visitors to your site have bookmarked your main page, then you shouldn't rename it. Leave it as is. I say this because I'm guessing this is the way your site has operated for a while now, so changes to it might not be a wise thing to do.

At the same time, you really should have an index.htm file so that all of your site's files and folders aren't listed when people go to your site's domain. As an example, Google lists your site simply by its domain name, which lists all of your files.

Recommendation: Leave your site exactly as it is now, but add an index.htm file to it. The following coding based on what you already have will work perfectly fine for your site (save it as a plain text document):

Code
Select All
<html>
<head>
<title> |   The OLD HONITONIANS Club   | </title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<META name="robots" CONTENT="noindex,nofollow">

<META HTTP-EQUIV=REFRESH CONTENT="0; URL=http://oldhonitonians.com/main_index.htm">

</head>

<frameset rows="90,100%" cols="*" frameborder="NO" border="0" framespacing="0">
  <frame src="http://www.oldhonitonians.com/contact.htm" name="title" scrolling="NO" marginwidth="0" marginheight="0" noresize frameborder="NO">
  <frameset cols="140,10*" frameborder="NO" border="0" framespacing="0">
    <frame src="http://www.oldhonitonians.com/UntitledFrame-3.htm" name="menu" scrolling="NO" marginwidth="0" marginheight="0" noresize frameborder="NO">
    <frame src="http://www.oldhonitonians.com/main.htm" name="main" scrolling="AUTO" marginwidth="0" marginheight="0" frameborder="NO">
  </frameset>
</frameset>
<noframes>
<body bgcolor="#FFFFFF">
</body></noframes>
</html> 


Save the coding above as a plain text document named index.htm or index.html and upload it to your server.

Note: If you're not already aware of it, the coding above includes an automatic refresh to the main page of your site as you have it now.

Alternately: You can simply copy your main_index.htm file as index.htm or index.html and upload it to your server. The refresh won't be there because it isn't needed, but it should work perfectly fine.

By the way, having your forum in a frame is a nice touch. Cool

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
nigel
YaBB Newcomer
*
Offline



Posts: 13
Location: Somerset UK
Re: Admin Centre
Reply #4 - Aug 24th, 2013 at 11:40am
Post Tools
I can get onto the admin centre but can not select a task. the 'untrapped error' shows
I have tried your index file, but doesn't work. Perhaps there is a time lag!
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,676
Location: Los Angeles

YaBB 2.5
Re: Admin Centre
Reply #5 - Aug 24th, 2013 at 3:28pm
Post Tools
As for the untrapped error that's showing in your Admin Center when you select a task, that's something a YaBB team member will have to address for you. I'll try to get word to them before I head off for a very busy day.

As for your site's index page not rendering properly, I see what you mean. My suggestion is to contact your host to see why that is. Meanwhile, I would leave it as it is because at least your files and folders aren't being shown to the public, and that's better than it was before.

I suppose when your host fixes that problem for you, the untrapped error that's showing in your Admin Center might also resolve itself, but I'm only guessing on that point.

Thankfully, your site as you had it working before is still working as you had it, and your forum appears to be operational as well.

Edited:
It's possible that you'll get more timely help here in this topic of Carsten's YaBB Mod Forum.

« Last Edit: Aug 24th, 2013 at 3:41pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,372
Location: Earth

YaBB 2.6.1
Re: Admin Centre
Reply #6 - Aug 24th, 2013 at 4:44pm
Post Tools
Exactly what is the error message you're getting and what version of YaBB are you running? (if it's the one in your first message, check your Paths.pl and also make sure that the Admin folder is actually named Admin (capitalized) and the folder permissions and ownership of that folder are correct.

I gather from your last post that the Admin Center is actually loading, which means that Admin.pl is loading properly. If that's the case, then replace all the other files in the Admin folder and make sure the file permissions are set to 644 (preferred) or 666 (if 644 doesn't work).
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,372
Location: Earth

YaBB 2.6.1
Re: Admin Centre
Reply #7 - Aug 24th, 2013 at 4:50pm
Post Tools
Your index page has php in it - therefore it should be named index.php, not index.htm
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
------
Senior Member
Beta Testers
****
Offline



Posts: 528
Re: Admin Centre
Reply #8 - Aug 24th, 2013 at 5:02pm
Post Tools
Bill Myers wrote on Aug 24th, 2013 at 6:12am:
Alternately
: You can simply copy your main_index.htm file as index.htm or index.html and upload it to your server. The refresh won't be there because it isn't needed, but it should work perfectly fine.



A better option
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,372
Location: Earth

YaBB 2.6.1
Re: Admin Centre
Reply #9 - Aug 24th, 2013 at 5:04pm
Post Tools
I'm accessing YaBBForum through a proxy so cannot modify my posts and the proxy was showing php code.  Embarrassed

Your main_index.htm doesn't have a doctype that would allow for frames. There are lots of other html errors in it. Those have to be fixed, starting with the doctype.

Check out http://validator.w3.org
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
nigel
YaBB Newcomer
*
Offline



Posts: 13
Location: Somerset UK
Re: Admin Centre
Reply #10 - Aug 28th, 2013 at 11:34am
Post Tools
Still no joy.
I am  not an expert!
http://www.oldhonitonians.com/cgi-bin/yabb2/AdminIndex.pl

Is the problem
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,676
Location: Los Angeles

YaBB 2.5
Re: Admin Centre
Reply #11 - Aug 28th, 2013 at 4:16pm
Post Tools
I know you said you can get into your Admin Center, and that you cannot select a task when you do, but are you sure you're accessing the correct Admin Center?

I ask this because from the error message you posted, it appears that the Admin.pl you need is actually missing. My guess at this time is you have 2 Admin.pl files, one of which is located in your /cgi-bin/ (good), and the other one is in your /public_html/cgi-bin/ folder (not good). I'm guessing this is a Path Settings issue.

If you're willing, my suggestion is to allow xnoddyx into your forum so that he can see for himself what's going on. He's on YaBB's Support Team, and an expert at how YaBB operates.

« Last Edit: Aug 28th, 2013 at 4:18pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Admin Centre
Reply #12 - Aug 28th, 2013 at 10:19pm
Post Tools
hi Bill I think there may be more here than just a forum prob as Nigel's main site is also not loading http://www.oldhonitonians.com/ or http://oldhonitonians.com/
all I get is
Code
Select All
<html> <head> <title> | The OLD HONITONIANS Club | </title> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> <META name="robots" CONTENT="noindex,nofollow"> <META HTTP-EQUIV=REFRESH CONTENT="0; URL=http://oldhonitonians.com/main_index.htm"> </head> <frameset rows="90,100%" cols="*" frameborder="NO" border="0" framespacing="0"> <frame src="http://www.oldhonitonians.com/contact.htm" name="title" scrolling="NO" marginwidth="0" marginheight="0" noresize frameborder="NO"> <frameset cols="140,10*" frameborder="NO" border="0" framespacing="0"> <frame src="http://www.oldhonitonians.com/UntitledFrame-3.htm" name="menu" scrolling="NO" marginwidth="0" marginheight="0" noresize frameborder="NO"> <frame src="http://www.oldhonitonians.com/main.htm" name="main" scrolling="AUTO" marginwidth="0" marginheight="0" frameborder="NO"> </frameset> </frameset> <noframes> <body bgcolor="#FFFFFF"> </body></noframes> </html> 



and I think the same as
Dandello wrote on Aug 24th, 2013 at 5:04pm:
doesn't have a doctype that would allow for frames. There are lots of other html errors in it. Those have to be fixed, starting with the doctype.

but I can take a look at the forum but I will need admin login info and also ftp login info so I can take a look at the forum files as well.
  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,676
Location: Los Angeles

YaBB 2.5
Re: Admin Centre
Reply #13 - Aug 28th, 2013 at 10:32pm
Post Tools
Just so you know, Nigel didn't have an index page at all, which meant in his case all of his files and folders were being publicly shown. So what he has now is better than what he had before. That file, as you can see yourself, is supposed to refresh to the main page of his site, of which his forum is accessible in a frame.

I believe he may have sent you an email as he did with me, so maybe you've already seen it. In any case, I agree that Nigel appears to have more than just a forum problem.

I told him you can pretty much fix anything.  Smiley

Edited:
Technically speaking, I'm sure Dandello is correct about the HTML file I created for him having mistakes in it. Nonetheless, that index.htm file still works as it should on a normal server, which means it automatically redirects to the main page of his site.

« Last Edit: Aug 28th, 2013 at 10:40pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
xnoddyx
Support Team
Documentation Team
YaBB Moderators
YaBB Next Team
Beta Testers
****
Offline



Posts: 1,591
Location: UK:Scotland/livingston

None
Re: Admin Centre
Reply #14 - Aug 28th, 2013 at 10:47pm
Post Tools
Bill Myers wrote on Aug 28th, 2013 at 10:32pm:
Just so you know, Nigel didn't have an index page at all, which meant in his case all of his files and folders were being publicly shown. So what he has now is better than what he had before.

that is not good for the root of a website but good to see that it has been kind of fixedBill Myers wrote on Aug 28th, 2013 at 10:32pm:
I believe he may have sent you an email as he did with me, so maybe you've already seen it.

no I have not been in my email for three days now as i have been that busy just now but just checked and there is one there so will just go have a look and see.

Bill Myers wrote on Aug 28th, 2013 at 10:32pm:
I told him you can pretty much fix anything.  

thank you and I hope this also apply to this forum as well.  Smiley
Edited:
ok not much I can do from admin good news it is not server probs as its the same host that I am on like my Almond Housing Association Tenants forum but need his ftp to check his paths and forum files as well.
« Last Edit: Aug 28th, 2013 at 11:08pm by xnoddyx »  

YaBB install help video
1. what yabb forum are you running and the url
2. describe in as much detail as you can what happens and also post screenshots if you can
3. please be patient we live in different time zones and have other commitments but we will help you
as bill and ted say (Be excellent to each other)
Back to top
IP Logged
 
Page Index Toggle Pages: [1] 2 
Topic Tools
 
  « Board Index ‹ Board  ^Top