Page Index Toggle Pages: 1
Topic Tools
Hot Topic (More than 10 Replies) Unable to access Admin? (Read 1,076 times)
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #12 - Jan 27th, 2014 at 8:29am
Post Tools
You're hardly a plonkerWink After all, you were able to figure out what the problem was. Cool

I'm kicking myself for not having posted this solution earlier on. The irony is that I actually mentioned how this might be a path problem while I was preparing a reply, but then I edited it out before posting it because I second-guessed myself, which I shouldn't have done. My bad.

In any case, I'm glad you came up with the solution, and I'm especially glad that you let us know. Anyone else with a similar issue can check to see if it's a path problem, in which case you'll have given them the solution.

By the way, there's no need to be sorry about wasting my time. You didn't. From my perspective, it's always a good thing to have a discussion about problems and possible solutions even when an answer to a problem doesn't readily come up. Discussions about it can really get the brain working.

Enjoy your YaBB forum! Smiley

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Unable to access Admin?
Reply #11 - Jan 27th, 2014 at 2:05am
Post Tools
Sorry to report I'm the plonker who didn't check the obvious! I had a look at the Paths.pl, and sure enough I had messed it up.

It should have been:

http://www.highlandpoultryadoption.co.uk/cgi-bin/yabb2

I had:

http://www.highlandpoultryadoption.co.uk/cgi-bin/yabb2/yabb/YaBB.pl

Oh well. So sorry to have wasted your time Bill!
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #10 - Jan 23rd, 2014 at 3:05am
Post Tools
As I mentioned in an edit of my previous post, as noted below it was an issue with the host ... probably the same with your similar issue.

xpgu wrote on Jan 21st, 2014 at 4:07am:
Problem solved. It was server issue.

Thanks

Also, the discussion here in this topic might help. Basically, you would temporarily change the permissions to 777 from 755, and then back again once you have access to your Admin Center again. That's not going to solve your problem permanently, but you should be able to gain access to your Admin Center again.

From that point I'd have a discussion with my host about what might be going on. They should have a better idea about how to fix your access permanently. After all, like you mentioned, the solution is probably something very simple, which they can hopefully fix with a bit of tweaking.

It might help to remind your new host that the only thing that's changed as far as you know is moving over to their server. As such, I suspect they have security protocols of some kind that are causing your problems (probably in an .htaccess file in the root of your site, or higher up than your YaBB forum).

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Unable to access Admin?
Reply #9 - Jan 23rd, 2014 at 12:33am
Post Tools
I tried two other web browsers, no change. Also uploaded a backup of the AminIndex.pl, I tried different backups, again no change. Very strange, especially as we got it working first time around. I'm sure it's something very simple, but what??
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #8 - Jan 21st, 2014 at 3:48am
Post Tools
I sure wish someone will come along who definitively knows the solution to this problem. In the meantime ...

Perhaps in the transfer of your files to your new host's server the AdminIndex.pl file got corrupted, although one would think that would result in an error message of some kind. Besides, you were subsequently able to access your Admin Center.

Still, if you have a local backup of your AdminIndex.pl file, maybe reloading it to the server will get it to become accessible again.

In any case, whatever ends up working, please let us know so that others can benefit from knowing how to fix this particular problem. Thanks.

*************************************

Another idea: Try logging in as the admin with another browser.

Edited:
The discussion here in this topic might help. Basically, you would temporarily change the permissions to 777 from 755, and then back again once you have access to your Admin Center again.

************************************

In the post below it was an issue with the host ... probably the same with your similar issue.

xpgu wrote on Jan 21st, 2014 at 4:07am:
Problem solved. It was server issue.

Thanks
« Last Edit: Jan 21st, 2014 at 4:13am by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Unable to access Admin?
Reply #7 - Jan 21st, 2014 at 1:34am
Post Tools
Thanks Bill for your further idea. Tried it, but unfortunately it's not having any of it. So for the moment it's in the hands of my ISP. Will keep you posted.
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #6 - Jan 20th, 2014 at 10:27pm
Post Tools
Please excuse the double post, but I see you're on now, and I wanted you to see this added commentary.

Another guess I have is that you may not be logged in as the admin as you think you are, or your account has timed out. To check this for sure, try right-clicking Admin on your menu to open your Admin Center in another window. If the result takes you to your forum rather than your Admin Center, then you've somehow been logged off.

If this is the case, then log off if it shows that you're on, and then log in again to access your Admin Center. Also, make sure you're logged in for "Keeps" as you'll see that option.


  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #5 - Jan 20th, 2014 at 10:12pm
Post Tools
I don't know if this will make a difference or not, but one of our forum's admin accounts (admin2.vars) couldn't access our Admin Center at one point, and changing permissions on that file from 664 to 666 did the trick. Maybe you can try this with your own admin account.

However, in that case I seem to recall that there was an error message of some kind when an edit to that account couldn't be made. As such, this solution may not solve your problem.

Regarding the changing of permissions, YaBB 2.4 automatically assigns permissions for new members to 644 (that should work fine). I had changed permissions of exisiting members to 666 (done to lesson the error rate).

As I understand it, hosts routinely change permissions per their respective security protocols. In your case it seems pretty likely that your new host has changed permissions on you (probably for security reasons at a higher folder level), so you may need to contact them for a resolution to your specific problem.

YaBB's experts can be reached over at Carsten's YaBB Mod Forum and also at Dandello's YaBB 2.5.4 Alpha (RC1) Forum.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Unable to access Admin?
Reply #4 - Jan 20th, 2014 at 8:04pm
Post Tools
I'm hoping this will solve itself in time, but today I have just logged in and the same thing is happening again!

I suspect changing host is something to do with it. I've flushed the dns from my computer, but doesn't make any difference. Checked the AminIndex.pl permission and it says 755. Just be patient I guess?
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #3 - Jan 18th, 2014 at 1:55am
Post Tools
After wiping my brow with the guess work I did, and wondering if a permissions issue was the problem, I'm so glad I was able to come back here to see that access to your Admin Center has been restored.

Enjoy your forum! Smiley
  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Re: Unable to access Admin?
Reply #2 - Jan 18th, 2014 at 12:36am
Post Tools
Hi Bill, you were spot on! It was a permissions problem. Changed the permission of AminIndex.pl to 755 as you suggested and all is now well. Thanks so much!
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,614
Location: Los Angeles

YaBB 2.5
Re: Unable to access Admin?
Reply #1 - Jan 17th, 2014 at 10:48pm
Post Tools
If you're on a Unix server, I'm guessing this may be a permissions issue. if so, check to see that your AdminIndex.pl file is set to 755 (the full Octal mode is actually 0755).

If this doesn't work, hopefully somebody else will come along to give you an accurate solution. If you don't get an answer in a timely fashion here, you might want to go to Carsten's YaBB Mod Forum and/or Dandello's YaBB 2.5.4 Alpha (RC1) Forum.

Edited:
One thing to check after you've logged in as the Admin is to replace YaBB.pl in the address bar with AdminIndex.pl to see what happens. If nothing happens, i.e., you're still on the main page of your forum, then one trick might be to log out as the Admin, and then log back in to see if that helps.

My thinking is that you may have been logged in as the Admin when your switch to a new host was made, so a real/actual Logout may not have been made. Whether or not I'm right about this, it's worth a try.

Future reference: Create and maintain a secondary Admin account so that you have another option to get to your Admin Center. Having a secondary Admin account has helped me a few times over the years.
« Last Edit: Jan 17th, 2014 at 11:03pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
earthylad
YaBB Newcomer
*
Offline



Posts: 39
Unable to access Admin?
Jan 17th, 2014 at 8:41pm
Post Tools
Having very recently changed my host, I find whilst I can login as Admin just fine, I cannot access Admin. No error message - nothing? Any pointer folks?
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top