Page Index Toggle Pages: 1
Topic Tools
Hot Topic (More than 10 Replies) Moderator helps not showing (Read 398 times)
RonS2
Senior Member
Beta Testers
****
Offline



Posts: 519

YaBB 2.5.2
Re: Moderator helps not showing
Reply #10 - Mar 26th, 2014 at 6:39pm
Post Tools
Dandello wrote on Mar 26th, 2014 at 3:12pm:
@Ron - if you want to see the bug in action on the Admin beta - go to Admin center -> Helps/FAQs and turn on 'user permisssions'. The moderator tab in Helps will disappear for Moderators and Forum Moderators but not for GMods or Admins.


Ok, I get it, thanks
  
Back to top
 
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Moderator helps not showing
Reply #9 - Mar 26th, 2014 at 3:25pm
Post Tools
Dandello wrote on Mar 26th, 2014 at 3:12pm:
What will be different is certain settings and those are not determined by what SVN version is being run but what admin is running it.

Thanks for the clarification; makes sense.

  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,200
Location: Earth

YaBB 2.6.0
Re: Moderator helps not showing
Reply #8 - Mar 26th, 2014 at 3:12pm
Post Tools
Bill Myers wrote on Mar 26th, 2014 at 3:03pm:
Then again, this is one of the reasons that I thought, and I'm now thinking again, that it might be more prudent for you and Jon to operate with the same SVN build.


The builds are usually pretty close - my site will be ahead of the beta for the simple reason that I can FTP directly to my site and JonB needs (very prudently) to double check everything that goes in on the betas.

What will be different is certain settings and those are not determined by what SVN version is being run but what admin is running it.

@Ron - if you want to see the bug in action on the Admin beta - go to Admin center -> Helps/FAQs and turn on 'user permisssions'. The moderator tab in Helps will disappear for Moderators and Forum Moderators but not for GMods or Admins.
« Last Edit: Mar 26th, 2014 at 3:15pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Moderator helps not showing
Reply #7 - Mar 26th, 2014 at 3:06pm
Post Tools

Ah, Dandello and I were almost posting at the same time. But as usual, hers is more succinct. Smiley

« Last Edit: Mar 26th, 2014 at 3:09pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,200
Location: Earth

YaBB 2.6.0
Re: Moderator helps not showing
Reply #6 - Mar 26th, 2014 at 3:04pm
Post Tools
I believe Jon has help permissions turned off on both betas (so everybody can see all the helps). I have it turned on for my site. And that's where Bill noticed the problem.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Bill Myers
God Member
Beta Testers
*****
Offline



Posts: 1,562
Location: Los Angeles

YaBB 2.4
Re: Moderator helps not showing
Reply #5 - Mar 26th, 2014 at 3:03pm
Post Tools
Edited:
Dandello wrote on Mar 26th, 2014 at 3:04pm:
I believe Jon has help permissions turned off on both betas (so everybody can see all the helps). I have it turned on for my site. And that's where Bill noticed the problem.

Regarding this edit, she and I were posting at about the same time, and my post squeezed in ahead of hers.

As you know, Dandello, it's working just fine on your beta forum after you made the fix with SVN build 1455.

But as your point about permissions illustrate:

Quote:
One of the reasons beta and this one have different permissions on various things is so things CAN be tested with different settings.

Then again, this is one of the reasons that I thought, and I'm now thinking again, that it might be more prudent for you and Jon to operate with the same SVN build.

« Last Edit: Mar 26th, 2014 at 3:12pm by Bill Myers »  

Morning, noon, or night, have a great one!

Note: This forum doesn't allow for us to freely edit our posts or topics to make corrections as needed, so please remember to look for subsequent posts if you see any mistakes or outdated information. Sorry for the inconvenience.
Back to top
IP Logged
 
RonS2
Senior Member
Beta Testers
****
Offline



Posts: 519

YaBB 2.5.2
Re: Moderator helps not showing
Reply #4 - Mar 26th, 2014 at 2:37pm
Post Tools
D, I just setup a new member as a moderator and was still able to see the help file in question

Edited:
on Admin Site
« Last Edit: Mar 26th, 2014 at 2:38pm by RonS2 »  
Back to top
 
IP Logged
 
RonS2
Senior Member
Beta Testers
****
Offline



Posts: 519

YaBB 2.5.2
Re: Moderator helps not showing
Reply #3 - Mar 26th, 2014 at 2:27pm
Post Tools
Dandello wrote on Mar 26th, 2014 at 2:21pm:
It's due to one of those orginal convoluted bits of coding logic where I scratch my head and wonder what they were drinking at the time they wrote it

  Grin
  
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,200
Location: Earth

YaBB 2.6.0
Re: Moderator helps not showing
Reply #2 - Mar 26th, 2014 at 2:21pm
Post Tools
It was always working for Users, Gmods, and Admins - just not for Moderators and Fmods. It's due to one of those orginal convoluted bits of coding logic where I scratch my head and wonder what they were drinking at the time they wrote it while I figure out how it's supposed to work and what changed.  Huh
« Last Edit: Mar 26th, 2014 at 2:22pm by Dandello »  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
RonS2
Senior Member
Beta Testers
****
Offline



Posts: 519

YaBB 2.5.2
Re: Moderator helps not showing
Reply #1 - Mar 26th, 2014 at 1:47pm
Post Tools
Yes its working now
  

ScreenHunter_01_Mar__26__2014_09_47.jpg (Attachment deleted)
Back to top
 
IP Logged
 
Dandello
YaBB Administrator
YaBB Next Team
Operations Team
Beta Testers
Support Team
*****
Offline



Posts: 2,200
Location: Earth

YaBB 2.6.0
Moderator helps not showing
Mar 26th, 2014 at 2:50am
Post Tools
When 'use permissions' is turned on the Moderator Helps were not appearing for Moderators - fixed in SVN build 1455.
  

If you only have one solution to a problem you're not trying hard enough!
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Topic Tools
 
  « Board Index ‹ Board  ^Top